chicken bug in importer: Unrecognized keyword: #:repo->guix-package

  • Open
  • quality assurance status badge
Details
3 participants
  • Josselin Poiret
  • jgart
  • Simon Tournier
Owner
unassigned
Submitted by
jgart
Severity
normal
J
J
jgart wrote on 6 Feb 2023 04:38
(address . bug-guix@gnu.org)
66683b240eae35ff30d04369bf403198@dismail.de
??

I run this:

guix import egg spiffy -r

I get this:

Backtrace:
7 (primitive-load "/home/jgart/.config/guix/current/bin/g…")
In guix/ui.scm:
2279:7 6 (run-guix . _)
2242:10 5 (run-guix-command _ . _)
In guix/scripts/import.scm:
92:11 4 (guix-import . _)
In guix/scripts/import/egg.scm:
96:19 3 (guix-import-egg . _)
In guix/import/utils.scm:
637:27 2 (recursive-import "spiffy" #:repo->guix-package _ # _ . #)
629:33 1 (lookup-node "spiffy" #f)
In guix/import/egg.scm:
329:41 0 (_ _ #:version _ #:repo _)

guix/import/egg.scm:329:41: Unrecognized keyword: #:repo->guix-package

My guix describe:

Generation 39 Feb 03 2023 20:27:46 (current)
guix c3e50c7
branch: master
commit: c3e50c731d8c175133cae1869e445cbb7a3b4d6f
J
J
Josselin Poiret wrote on 13 Feb 2023 21:45
[PATCH] import: egg: Ignore extra keys for #:repo->guix-package
(name . Josselin Poiret)(address . dev@jpoiret.xyz)
6893c426d439ef9e8097797a8fb49d9720e1162c.1676321149.git.dev@jpoiret.xyz
* guix/import/egg.scm (egg-recursive-import): Do it.

Fixes: #61309
---
guix/import/egg.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (18 lines)
diff --git a/guix/import/egg.scm b/guix/import/egg.scm
index 90d97909b5..0555f24703 100644
--- a/guix/import/egg.scm
+++ b/guix/import/egg.scm
@@ -326,7 +326,8 @@ (define egg->guix-package/m ;memoized variant
(define* (egg-recursive-import package-name #:optional version)
(recursive-import package-name
#:version version
- #:repo->guix-package (lambda* (name #:key version repo)
+ #:repo->guix-package (lambda* (name #:key version repo
+ #:allow-other-keys)
(egg->guix-package/m name version))
#:guix-name egg-name->guix-name))

base-commit: dd724cfad45d76b9dcc5b073876c995715c92a07
--
2.39.1
J
d9b95dce2649f4538e5147af07a02dff@dismail.de
Toggle quote (2 lines)
> + #:allow-other-keys)

Ah, nice, thanks, allow-other-keys all the way down!
S
S
Simon Tournier wrote on 14 Feb 2023 20:23
control message for bug #61309
(address . control@debbugs.gnu.org)
87y1p0xd8v.fsf@gmail.com
tags 61309 + patch
quit
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 61309@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61309
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch