[rust] Segfault when trying to download dependencies using Cargo

  • Open
  • quality assurance status badge
Details
One participant
  • Albin Otterhäll
Owner
unassigned
Submitted by
Albin Otterhäll
Severity
normal
A
A
Albin Otterhäll wrote on 5 Feb 2023 01:28
(name . bug-guix@gnu.org)(address . bug-guix@gnu.org)
ePDsFA2AuFFcz98E3ozd2k_yU3S6TD2tnDmYfY6F9XmKlmptcLi7NRCka_sMMPoqsF4_7xSI2-mkExyBLxrhyM2cpOLB3z4Lq9iaUnS8sDc=@a12l.xyz
# Segfault when trying to build Rust binary using cargo and a dependency

## Description

As soon as I add a dependency to `Cargo.toml` I get a segfault when I in some way try to build the binary.

## Expected behavior

When running `cargo build` after having added a dependency on `rand = "0.8.3"` in the example below Cargo should download the `rand` package (`rust-rand` in Guix).

## Actual behavior

The build process halts with a segmentation fault.

### Steps to reproduce

Create an environment with the command `guix shell --manifest=manifest.scm` and there `manifest.scm` contains

```
(specifications->manifest (list "rust"
"rust-analyzer"
"rust-cargo"))
```

and then run the commands

$ cargo new mve
Created binary (application) `mve` package

$ cd mve/

mve $ cargo build
Compiling mve v0.1.0 (/home/a12l/Long-Term/TRPL/mve)
Finished dev [unoptimized + debuginfo] target(s) in 0.56s

mve $ echo 'rand = "0.8.3"' >> Cargo.toml

mve $ cargo build
Updating crates.io index
Segmentation fault (core dumped)

## My system

I'm running Guix on a NixOS 22.11 machine, by having added `https://github.com/foo-dogsquared/nix-overlay-guix`to my system configuration.

Thanks!
--
Albin Otterhäll
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 61284@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61284
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch