Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)
* gnu/packages/bioconductor.scm (r-dorothea): New variable.
---
gnu/packages/bioconductor.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)
Toggle diff (38 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 521d6c00be..0786160b5e 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -466,6 +466,31 @@ (define-public r-bsgenome-mmusculus-ucsc-mm10
in Biostrings objects.")
(license license:artistic2.0)))
+(define-public r-dorothea
+ (package
+ (name "r-dorothea")
+ (version "1.10.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "dorothea" version
+ 'experiment))
+ (sha256
+ (base32
+ "05vkb5mash2m8p6njk842sy5pz7vblrm8n9bphqbslm86kld5n92"))))
+ (properties `((upstream-name . "dorothea")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-bcellviper r-dplyr r-magrittr r-viper))
+ (native-inputs (list r-knitr))
+ (home-page "https://saezlab.github.io/dorothea/")
+ (synopsis "Collection of human and mouse TF regulons")
+ (description
+ "DoRothEA is a gene regulatory network containing signed transcription factor.
+DoRothEA regulons, the collection of a TF andits transcriptional targets,
+were curated and collected from different types ofevidence for both human
+and mouse. A confidence level was assigned to each TF-target interaction
+based on the number of supporting evidence.")
+ (license license:gpl3)))
+
(define-public r-genomeinfodbdata
(package
(name "r-genomeinfodbdata")
--
2.34.1