Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)
* gnu/packages/bioconductor.scm (r-viper): New variable.
---
gnu/packages/bioconductor.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)
Toggle diff (34 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 711b988e7f..aeef6f4106 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -8307,6 +8307,27 @@ (define-public r-variantannotation
coding changes and predict coding outcomes.")
(license license:artistic2.0)))
+(define-public r-viper
+ (package
+ (name "r-viper")
+ (version "1.32.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "viper" version))
+ (sha256
+ (base32
+ "11i2q9nakh534nx2l736id7k1yqhk7jpg32sbfl4vrnh398q86h6"))))
+ (properties `((upstream-name . "viper")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-biobase r-e1071 r-kernsmooth r-mixtools))
+ (home-page "https://bioconductor.org/packages/viper")
+ (synopsis
+ "Virtual inference of protein-activity by enriched regulon analysis")
+ (description
+ "Inference of protein activity from gene expression data.
+Including the VIPER and msVIPER algorithms")
+ (license license:gpl2+)))
+
(define-public r-vsn
(package
(name "r-vsn")
--
2.34.1