[PATCH 1/3] gnu: Add r-viper.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)
20230203121854.95308-1-navid.afkhami@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-viper): New variable.
---
gnu/packages/bioconductor.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 711b988e7f..aeef6f4106 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -8307,6 +8307,27 @@ (define-public r-variantannotation
coding changes and predict coding outcomes.")
(license license:artistic2.0)))
+(define-public r-viper
+ (package
+ (name "r-viper")
+ (version "1.32.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "viper" version))
+ (sha256
+ (base32
+ "11i2q9nakh534nx2l736id7k1yqhk7jpg32sbfl4vrnh398q86h6"))))
+ (properties `((upstream-name . "viper")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-biobase r-e1071 r-kernsmooth r-mixtools))
+ (home-page "https://bioconductor.org/packages/viper")
+ (synopsis
+ "Virtual inference of protein-activity by enriched regulon analysis")
+ (description
+ "Inference of protein activity from gene expression data.
+Including the VIPER and msVIPER algorithms")
+ (license license:gpl2+)))
+
(define-public r-vsn
(package
(name "r-vsn")
--
2.34.1
Ricardo Wurmus wrote 2 years ago
(address . 61250-done@debbugs.gnu.org)
87ilgi92c2.fsf@elephly.net
Unfortunately, we cannot add this to Guix. The license says:

c. You agree that You will only use the Program and Documentation for
non-commercial internal academic or educational research purposes
only. You will not (i) reproduce or copy the Program (ii) use, or
cause or permit the use of, the Program in whole or in part for any
purpose other than as permitted under this License; (iii)
distribute, sell, lease, license or otherwise make the Program
available to a third party outside Your organization; or (iv)
reverse engineer, decompile, or disassemble the Program.

I have instead added the package to guix-science-nonfree.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61250@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61250
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help