[PATCH] gnu: Add gpaint

  • Done
  • quality assurance status badge
Details
2 participants
  • Andy Tai
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Andy Tai
Severity
normal

Debbugs page

Andy Tai wrote 2 years ago
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
20230203071849.26228-1-atai@atai.org
* gnu/packages/graphics.scm (gpaint): New variable
---
gnu/packages/graphics.scm | 41 +++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index ebf571d93e..67a530fb9a 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -2458,3 +2458,44 @@ (define-public f3d
glTF, STL, STEP, PLY, OBJ, FBX), and provides numerous rendering and texturing
options.")
(license license:bsd-3)))
+
+
+(define-public gpaint
+ (package
+ (name "gpaint")
+ (version "0.3.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://alpha.gnu.org/gnu/"
+ name
+ "/"
+ name
+ "-2-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1syh5l5fnzk7cw77iykafn73fvmnc83kg815fa8vvj0h0r30c5sl"))))
+ (build-system gnu-build-system)
+ (inputs (list gtk+-2 libglade))
+ (native-inputs (list gettext-minimal
+ `(,glib "bin") pkg-config))
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-undefined-references
+ (lambda _
+ (substitute* "src/drawing.c"
+ (("GTK_STOCK_DISCARD,GTK_RESPONSE_DISCARD")
+ "GTK_STOCK_DISCARD,GTK_RESPONSE_NO"))
+ (substitute* "src/menu.c"
+ (("\\#include \"menu.h\"")
+ "")))))))
+
+ (synopsis "imple paint program for GNOME")
+ (description
+ "GNU Paint is a simple, easy-to-use paint program for the GNOME
+environment. It supports drawing freehand as well as basic shapes and text.
+It features cut-and-paste for irregular regions or polygons.")
+ (home-page "https://www.gnu.org/software/gpaint/")
+ (license license:gpl3+)))
+

base-commit: 92755c6352fd967bc74d8e5354aad057d779b717
prerequisite-patch-id: bb8c7a47211c532ef9531688f76236d9b99bb025
prerequisite-patch-id: 15c6ecae300ec3f57c971a9bec35ed8ff2a0a263
--
2.39.1
Nicolas Goaziou wrote 2 years ago
(name . Andy Tai)(address . atai@atai.org)(address . 61249-done@debbugs.gnu.org)
87cz6qz7c2.fsf@nicolasgoaziou.fr
Hello,

Andy Tai <atai@atai.org> writes:

Toggle quote (2 lines)
> * gnu/packages/graphics.scm (gpaint): New variable

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61249@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61249
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help