Andy Tai wrote 2 years ago
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
* gnu/packages/graphics.scm (gpaint): New variable
---
gnu/packages/graphics.scm | 41 +++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)
Toggle diff (55 lines)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index ebf571d93e..67a530fb9a 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -2458,3 +2458,44 @@ (define-public f3d
glTF, STL, STEP, PLY, OBJ, FBX), and provides numerous rendering and texturing
options.")
(license license:bsd-3)))
+
+
+(define-public gpaint
+ (package
+ (name "gpaint")
+ (version "0.3.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://alpha.gnu.org/gnu/"
+ name
+ "/"
+ name
+ "-2-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1syh5l5fnzk7cw77iykafn73fvmnc83kg815fa8vvj0h0r30c5sl"))))
+ (build-system gnu-build-system)
+ (inputs (list gtk+-2 libglade))
+ (native-inputs (list gettext-minimal
+ `(,glib "bin") pkg-config))
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-undefined-references
+ (lambda _
+ (substitute* "src/drawing.c"
+ (("GTK_STOCK_DISCARD,GTK_RESPONSE_DISCARD")
+ "GTK_STOCK_DISCARD,GTK_RESPONSE_NO"))
+ (substitute* "src/menu.c"
+ (("\\#include \"menu.h\"")
+ "")))))))
+
+ (synopsis "imple paint program for GNOME")
+ (description
+ "GNU Paint is a simple, easy-to-use paint program for the GNOME
+environment. It supports drawing freehand as well as basic shapes and text.
+It features cut-and-paste for irregular regions or polygons.")
+ (home-page "https://www.gnu.org/software/gpaint/")
+ (license license:gpl3+)))
+
base-commit: 92755c6352fd967bc74d8e5354aad057d779b717
prerequisite-patch-id: bb8c7a47211c532ef9531688f76236d9b99bb025
prerequisite-patch-id: 15c6ecae300ec3f57c971a9bec35ed8ff2a0a263
--
2.39.1