[PATCH 1/2] gnu: Add python-pegasusio.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)
20230202160023.45975-1-navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (python-pegasusio): New variable.
---
gnu/packages/bioinformatics.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 714db27c16..6caf0e4cfa 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1136,6 +1136,36 @@ (define-public python-htsget
servers supporting the protocol.")
(license license:asl2.0)))
+(define-public python-pegasusio
+ (package
+ (name "python-pegasusio")
+ (version "0.7.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pegasusio" version))
+ (sha256
+ (base32
+ "0gqygspdy398vjymdy6756jmk99s7fhwav9rivdx59kpqjcdxaz9"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-anndata
+ python-docopt
+ python-h5py
+ python-importlib-metadata
+ python-loompy
+ python-natsort
+ python-numpy
+ python-pandas
+ python-pillow
+ python-scipy
+ python-zarr))
+ (native-inputs (list python-cython python-setuptools-scm))
+ (home-page "https://github.com/lilab-bcb/pegasusio")
+ (synopsis
+ "Pegasusio is a Python package for reading or writing single-cell genomics data")
+ (description
+ "Pegasusio is a Python package for reading or writing single-cell genomics data.")
+ (license license:bsd-3)))
+
(define-public python-phylophlan
(package
(name "python-phylophlan")
--
2.34.1
Ricardo Wurmus wrote 2 years ago
(address . 61230-done@debbugs.gnu.org)
87mt5v8x9n.fsf@elephly.net
Applied, thank you!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61230@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61230
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help