[PATCH 2/2] gnu: Add python-demuxem.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)
20230202160023.45975-2-navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (python-demuxem): New variable.
---
gnu/packages/bioinformatics.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 6caf0e4cfa..406f8616c7 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1090,6 +1090,35 @@ (define-public python-cmseq
and sequence consensus.")
(license license:expat)))
+(define-public python-demuxem
+ (package
+ (name "python-demuxem")
+ (version "0.1.7")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "demuxEM" version))
+ (sha256
+ (base32
+ "1bhyxqjk44bmyd26m1smapf68wyf7252kk65i27k50dd3kswgnd6"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-docopt
+ python-importlib-metadata
+ python-numpy
+ python-pandas
+ python-pegasusio
+ python-scikit-learn
+ python-scipy
+ python-seaborn))
+ (native-inputs (list python-cython python-setuptools-scm))
+ (home-page "https://github.com/lilab-bcb/demuxEM")
+ (synopsis
+ "This is a module on analyzing cell-hashing/nucleus-hashing data")
+ (description
+ "This is a module on analyzing cell-hashing/nucleus-hashing data.
+It is the demultiplexing module of Pegasus, which is used by Cumulus
+in demultiplexing step.")
+ (license license:bsd-3)))
+
(define-public python-hclust2
(package
(name "python-hclust2")
--
2.34.1
Ricardo Wurmus wrote 2 years ago
(address . 61229-done@debbugs.gnu.org)
87r0v78xam.fsf@elephly.net
Applied, thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61229@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61229
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help