Hi,
Leo Famulari <leo@famulari.name> writes:
Toggle quote (28 lines)
> * gnu/packages/freedesktop.scm (xdg-utils)[native-inputs]: Replace w3m with
> w3m-for-tests.
> [arguments]: Use #:disallowed-references to prevent keeping a reference to
> w3m-for-tests.
> ---
> gnu/packages/freedesktop.scm | 6 ++++--
> 1 file changed, 4 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
> index a986c8c350..677ab5fdf2 100644
> --- a/gnu/packages/freedesktop.scm
> +++ b/gnu/packages/freedesktop.scm
> @@ -482,7 +482,7 @@ (define-public xdg-utils
> "1nai806smz3zcb2l5iny4x7li0fak0rzmjg6vlyhdqm8z25b166p"))))
> (build-system gnu-build-system)
> (native-inputs
> - (list docbook-xsl docbook-xml-4.1.2 libxslt w3m xmlto))
> + (list docbook-xsl docbook-xml-4.1.2 libxslt w3m-for-tests xmlto))
> (inputs
> `(("awk" ,gawk)
> ;; TODO(staging): Make this unconditional, to avoid canonical packages,
> @@ -501,7 +501,9 @@ (define-public xdg-utils
> ("xprop" ,xprop) ; for Xfce detecting
> ("xset" ,xset))) ; for xdg-screensaver
> (arguments
> - `(#:tests? #f ; no check target
> + `(; Ensure we don't keep a reference to this old version of w3m
I was confused by the "old version". Perhaps rephrase to "[...] this
potentially old version [...]" ?
Toggle quote (6 lines)
> + #:disallowed-references (,w3m-for-tests)
> + #:tests? #f ; no check target
> #:modules ((srfi srfi-26)
> ,@%gnu-build-system-modules)
> #:phases
Otherwise, LGTM!
--
Thanks,
Maxim