Decouple w3m from xdg-utils test suite

  • Open
  • quality assurance status badge
Details
4 participants
  • Leo Famulari
  • Maxim Cournoyer
  • Bruno Victal
  • André Batista
Owner
unassigned
Submitted by
Leo Famulari
Severity
normal
L
L
Leo Famulari wrote on 2 Feb 2023 12:32
(address . guix-patches@gnu.org)
Y9ufOnxX+FRbE8pO@jasmine.lan
This patch series decouples w3m from the test suite of xdg-utils, which
is useful because of xdg-utils large reverse dependency graph.

By making this change, we will be able to update w3m more conveniently,
rather than waiting for a core-updates / staging cycle, or a feature
branch.
L
L
Leo Famulari wrote on 2 Feb 2023 12:38
[PATCH 1/5] gnu: linux-libre: Update to 6.1.9.
(address . 61226@debbugs.gnu.org)
b19c5d22cbfe867269a42c908b9ac0908b6056f7.1675337921.git.leo@famulari.name
* gnu/packages/linux.scm (linux-libre-6.1-version): Update to 6.1.9.
(linux-libre-6.1-pristine-source, deblob-scripts-6.1): Update hashes.
---
gnu/packages/linux.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (27 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 5a776168cc..af46f791a6 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -481,17 +481,17 @@ (define (%upstream-linux-source version hash)
;; The current "stable" kernels. That is, the most recently released major
;; versions that are still supported upstream.
-(define-public linux-libre-6.1-version "6.1.8")
+(define-public linux-libre-6.1-version "6.1.9")
(define-public linux-libre-6.1-gnu-revision "gnu")
(define deblob-scripts-6.1
(linux-libre-deblob-scripts
linux-libre-6.1-version
linux-libre-6.1-gnu-revision
(base32 "0p1cg5khpp8xkfaqy0cnp1m273z3xiz0m97rkrkggz9gr2klrjym")
- (base32 "0va28vs359r0rfmzh8pw58055kgd8sb62gi78vrg9p8wmj4s87v6")))
+ (base32 "1g9xqc8ajs0g2yq9xizlgr7k47x75rk3y99yicky01fm13rvfvv3")))
(define-public linux-libre-6.1-pristine-source
(let ((version linux-libre-6.1-version)
- (hash (base32 "0vc1ggjy4wvna7g6xgbjzhk93whssj9ixcal0hkhldxsp0xba2xn")))
+ (hash (base32 "0awjynyy049px0h7li59w3zgn3z39alv6glzrmx6wf1wd62z236n")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-6.1)))
--
2.38.1
L
L
Leo Famulari wrote on 2 Feb 2023 12:38
[PATCH 2/5] gnu: linux-libre 5.15: Update to 5.15.91.
(address . 61226@debbugs.gnu.org)
b02503c7cfed01850313253a2cdbf26a391a5237.1675337922.git.leo@famulari.name
* gnu/packages/linux.scm (linux-libre-5.15-version): Update to 5.15.91.
(linux-libre-5.15-pristine-source, deblob-scripts-5.15): Update hashes.
---
gnu/packages/linux.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (27 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index af46f791a6..281acbf0e6 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -499,17 +499,17 @@ (define-public linux-libre-6.1-pristine-source
;; The "longterm" kernels — the older releases with long-term upstream support.
;; Here are the support timelines:
;; <https://www.kernel.org/category/releases.html>
-(define-public linux-libre-5.15-version "5.15.90")
+(define-public linux-libre-5.15-version "5.15.91")
(define-public linux-libre-5.15-gnu-revision "gnu")
(define deblob-scripts-5.15
(linux-libre-deblob-scripts
linux-libre-5.15-version
linux-libre-5.15-gnu-revision
(base32 "0vj60bra81fmbx3lz924czbhxs4dmvd4d584g9mcs80b7c4q52kg")
- (base32 "1m73pgx8v047xb2gck2g7j7khniis8c9akn9vhzgsdfglrf8p6fj")))
+ (base32 "1lwmax7078w5p6li1gf66m494xijy4bwa7nm5dlx0k09cfif9q2f")))
(define-public linux-libre-5.15-pristine-source
(let ((version linux-libre-5.15-version)
- (hash (base32 "0hiv74mxkp3v04lphnyw16akgavaz527bzhnfnpm6rv848047zg6")))
+ (hash (base32 "107yw7mibibhfrggm8idzn5bayjvkxaq1kv3kkm1lpxipsqjng56")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-5.15)))
--
2.38.1
L
L
Leo Famulari wrote on 2 Feb 2023 12:38
[PATCH 3/5] gnu: linux-libre 5.10: Update to 5.10.166.
(address . 61226@debbugs.gnu.org)
06a6f17a70fc8838993ba45d88cbf5bce54b7961.1675337922.git.leo@famulari.name
* gnu/packages/linux.scm (linux-libre-5.10-version): Update to 5.10.166.
(linux-libre-5.10-pristine-source, deblob-scripts-5.10): Update hashes.
---
gnu/packages/linux.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (27 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 281acbf0e6..e105bad406 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -514,17 +514,17 @@ (define-public linux-libre-5.15-pristine-source
(%upstream-linux-source version hash)
deblob-scripts-5.15)))
-(define-public linux-libre-5.10-version "5.10.165")
+(define-public linux-libre-5.10-version "5.10.166")
(define-public linux-libre-5.10-gnu-revision "gnu1")
(define deblob-scripts-5.10
(linux-libre-deblob-scripts
linux-libre-5.10-version
linux-libre-5.10-gnu-revision
(base32 "0mw7qn77y9c6wrnw4rjvf75cpm1w6n1aqqhf8cnghcb97p2yxxrf")
- (base32 "0a96g4pjdgwvxn2wpz6rfc8nwdlkw138r9pp66kvfrrn08i313ii")))
+ (base32 "0fk954nniva8a7s423fnfn2wz9j9jdhscc4pqyvwn0wlxxbjgyap")))
(define-public linux-libre-5.10-pristine-source
(let ((version linux-libre-5.10-version)
- (hash (base32 "03dg8yx0gdzm8zbwd1f9jn4c5jhr8qilhjzxgwm0mv8riz2fy7cp")))
+ (hash (base32 "1bz1sgkqniwg84wv9vcg08mksa5q533vgynsd3y0xnjv1rwa2l80")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-5.10)))
--
2.38.1
L
L
Leo Famulari wrote on 2 Feb 2023 12:38
[PATCH 4/5] gnu: Add a pinned-version variant of w3m.
(address . 61226@debbugs.gnu.org)
82cc5f3d7a0ec87383fe07b60d38f7a31d6ed1e8.1675337922.git.leo@famulari.name
* gnu/packages/w3m.scm (w3m-for-tests): New variable.
---
gnu/packages/w3m.scm | 20 +++++++++++++++++++-
1 file changed, 19 insertions(+), 1 deletion(-)

Toggle diff (36 lines)
diff --git a/gnu/packages/w3m.scm b/gnu/packages/w3m.scm
index 3efacf7346..73e6417cf2 100644
--- a/gnu/packages/w3m.scm
+++ b/gnu/packages/w3m.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
-;;; Copyright © 2016, 2017, 2018 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2016, 2017, 2018, 2023 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Rutger Helling <rhelling@mykolab.com>
@@ -86,3 +86,21 @@ (define-public w3m
typesets HTML into plain text.")
(license (x11-style "file://doc/README"
"See 'doc/README' in the distribution."))))
+
+;; Used in the test suite of xdg-utils
+(define-public w3m-for-tests
+ (hidden-package
+ (package
+ (inherit w3m)
+ (name "w3m")
+ (version "0.5.3+git20230121")
+ (source (origin
+ (method git-fetch)
+ ;; Debian's fork of w3m is the only one that is still maintained.
+ (uri (git-reference
+ (url "https://salsa.debian.org/debian/w3m.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0nvhxsqxgxjrr62mvxzhhfzvbvg56g19vlqcgb8mh2x1daazk5ms")))))))
--
2.38.1
L
L
Leo Famulari wrote on 2 Feb 2023 12:38
[PATCH 5/5] gnu: xdg-utils: Use a pinned version of w3m.
(address . 61226@debbugs.gnu.org)
615a81cd5699ddeec272f4135985cc42ed1a899e.1675337922.git.leo@famulari.name
* gnu/packages/freedesktop.scm (xdg-utils)[native-inputs]: Replace w3m with
w3m-for-tests.
[arguments]: Use #:disallowed-references to prevent keeping a reference to
w3m-for-tests.
---
gnu/packages/freedesktop.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index a986c8c350..677ab5fdf2 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -482,7 +482,7 @@ (define-public xdg-utils
"1nai806smz3zcb2l5iny4x7li0fak0rzmjg6vlyhdqm8z25b166p"))))
(build-system gnu-build-system)
(native-inputs
- (list docbook-xsl docbook-xml-4.1.2 libxslt w3m xmlto))
+ (list docbook-xsl docbook-xml-4.1.2 libxslt w3m-for-tests xmlto))
(inputs
`(("awk" ,gawk)
;; TODO(staging): Make this unconditional, to avoid canonical packages,
@@ -501,7 +501,9 @@ (define-public xdg-utils
("xprop" ,xprop) ; for Xfce detecting
("xset" ,xset))) ; for xdg-screensaver
(arguments
- `(#:tests? #f ; no check target
+ `(; Ensure we don't keep a reference to this old version of w3m
+ #:disallowed-references (,w3m-for-tests)
+ #:tests? #f ; no check target
#:modules ((srfi srfi-26)
,@%gnu-build-system-modules)
#:phases
--
2.38.1
A
A
André Batista wrote on 3 Feb 2023 05:18
Re: [bug#61226] Decouple w3m from xdg-utils test suite
(name . Leo Famulari)(address . leo@famulari.name)(address . 61226@debbugs.gnu.org)
Y9yLM2V7GZ5Xi6Et@andel
Hi,

qui 02 fev 2023 �s 12:32:10 (1675351930), leo@famulari.name enviou:
Toggle quote (7 lines)
> This patch series decouples w3m from the test suite of xdg-utils, which
> is useful because of xdg-utils large reverse dependency graph.
>
> By making this change, we will be able to update w3m more conveniently,
> rather than waiting for a core-updates / staging cycle, or a feature
> branch.

My apologies. I've presumed too much and it didn't even occur to me to
check for w3m reverse dependency graph. I'll make sure to check for
every single package from now on.

Thanks for working after my mess.
L
L
Leo Famulari wrote on 3 Feb 2023 16:21
[PATCH v2 1/2] gnu: Add a pinned-version variant of w3m.
(address . 61226@debbugs.gnu.org)
c021666b5d62e66097bef398ce66233a6f7f7d80.1675437676.git.leo@famulari.name
* gnu/packages/w3m.scm (w3m-for-tests): New variable.
---
gnu/packages/w3m.scm | 20 +++++++++++++++++++-
1 file changed, 19 insertions(+), 1 deletion(-)

Toggle diff (36 lines)
diff --git a/gnu/packages/w3m.scm b/gnu/packages/w3m.scm
index 3efacf7346..73e6417cf2 100644
--- a/gnu/packages/w3m.scm
+++ b/gnu/packages/w3m.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
-;;; Copyright © 2016, 2017, 2018 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2016, 2017, 2018, 2023 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Rutger Helling <rhelling@mykolab.com>
@@ -86,3 +86,21 @@ (define-public w3m
typesets HTML into plain text.")
(license (x11-style "file://doc/README"
"See 'doc/README' in the distribution."))))
+
+;; Used in the test suite of xdg-utils
+(define-public w3m-for-tests
+ (hidden-package
+ (package
+ (inherit w3m)
+ (name "w3m")
+ (version "0.5.3+git20230121")
+ (source (origin
+ (method git-fetch)
+ ;; Debian's fork of w3m is the only one that is still maintained.
+ (uri (git-reference
+ (url "https://salsa.debian.org/debian/w3m.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0nvhxsqxgxjrr62mvxzhhfzvbvg56g19vlqcgb8mh2x1daazk5ms")))))))
--
2.38.1
L
L
Leo Famulari wrote on 3 Feb 2023 16:21
[PATCH v2 2/2] gnu: xdg-utils: Use a pinned version of w3m.
(address . 61226@debbugs.gnu.org)
935e58c604d205cf0178cefb04e5508b8530422c.1675437676.git.leo@famulari.name
* gnu/packages/freedesktop.scm (xdg-utils)[native-inputs]: Replace w3m with
w3m-for-tests.
[arguments]: Use #:disallowed-references to prevent keeping a reference to
w3m-for-tests.
---
gnu/packages/freedesktop.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index a986c8c350..677ab5fdf2 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -482,7 +482,7 @@ (define-public xdg-utils
"1nai806smz3zcb2l5iny4x7li0fak0rzmjg6vlyhdqm8z25b166p"))))
(build-system gnu-build-system)
(native-inputs
- (list docbook-xsl docbook-xml-4.1.2 libxslt w3m xmlto))
+ (list docbook-xsl docbook-xml-4.1.2 libxslt w3m-for-tests xmlto))
(inputs
`(("awk" ,gawk)
;; TODO(staging): Make this unconditional, to avoid canonical packages,
@@ -501,7 +501,9 @@ (define-public xdg-utils
("xprop" ,xprop) ; for Xfce detecting
("xset" ,xset))) ; for xdg-screensaver
(arguments
- `(#:tests? #f ; no check target
+ `(; Ensure we don't keep a reference to this old version of w3m
+ #:disallowed-references (,w3m-for-tests)
+ #:tests? #f ; no check target
#:modules ((srfi srfi-26)
,@%gnu-build-system-modules)
#:phases
--
2.38.1
L
L
Leo Famulari wrote on 3 Feb 2023 16:22
Re: [PATCH 1/5] gnu: linux-libre: Update to 6.1.9.
(address . 61226@debbugs.gnu.org)
Y90mnfheGB4QWLH7@jasmine.lan
On Thu, Feb 02, 2023 at 12:38:39PM +0100, Leo Famulari wrote:
Toggle quote (3 lines)
> * gnu/packages/linux.scm (linux-libre-6.1-version): Update to 6.1.9.
> (linux-libre-6.1-pristine-source, deblob-scripts-6.1): Update hashes.

Oops! I accidentally sent these kernel patches in addition to the w3m
patches. I've sent a v2 of the patch series which hopefully clears it
up.
L
L
Leo Famulari wrote on 5 Feb 2023 14:11
Re: [bug#61226] Decouple w3m from xdg-utils test suite
(name . André Batista)(address . nandre@riseup.net)(address . 61226@debbugs.gnu.org)
Y9+q/ayGyrZ2EPSL@jasmine.lan
On Fri, Feb 03, 2023 at 01:18:59AM -0300, Andr� Batista wrote:
Toggle quote (4 lines)
> My apologies. I've presumed too much and it didn't even occur to me to
> check for w3m reverse dependency graph. I'll make sure to check for
> every single package from now on.

Don't worry, it can hardly have been expected!

In any case, it's also a good idea to do `guix refresh -l` when working
on a package, to get the big picture.
M
M
Maxim Cournoyer wrote on 9 Feb 2023 05:05
Re: bug#61226: Decouple w3m from xdg-utils test suite
(name . Leo Famulari)(address . leo@famulari.name)(address . 61226@debbugs.gnu.org)
87k00riiup.fsf_-_@gmail.com
Leo Famulari <leo@famulari.name> writes:

Toggle quote (5 lines)
> * gnu/packages/w3m.scm (w3m-for-tests): New variable.
> ---
> gnu/packages/w3m.scm | 20 +++++++++++++++++++-
> 1 file changed, 19 insertions(+), 1 deletion(-)

LGTM!

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 9 Feb 2023 05:06
(name . Leo Famulari)(address . leo@famulari.name)(address . 61226@debbugs.gnu.org)
87fsbfiit6.fsf_-_@gmail.com
Hi,

Leo Famulari <leo@famulari.name> writes:

Toggle quote (28 lines)
> * gnu/packages/freedesktop.scm (xdg-utils)[native-inputs]: Replace w3m with
> w3m-for-tests.
> [arguments]: Use #:disallowed-references to prevent keeping a reference to
> w3m-for-tests.
> ---
> gnu/packages/freedesktop.scm | 6 ++++--
> 1 file changed, 4 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
> index a986c8c350..677ab5fdf2 100644
> --- a/gnu/packages/freedesktop.scm
> +++ b/gnu/packages/freedesktop.scm
> @@ -482,7 +482,7 @@ (define-public xdg-utils
> "1nai806smz3zcb2l5iny4x7li0fak0rzmjg6vlyhdqm8z25b166p"))))
> (build-system gnu-build-system)
> (native-inputs
> - (list docbook-xsl docbook-xml-4.1.2 libxslt w3m xmlto))
> + (list docbook-xsl docbook-xml-4.1.2 libxslt w3m-for-tests xmlto))
> (inputs
> `(("awk" ,gawk)
> ;; TODO(staging): Make this unconditional, to avoid canonical packages,
> @@ -501,7 +501,9 @@ (define-public xdg-utils
> ("xprop" ,xprop) ; for Xfce detecting
> ("xset" ,xset))) ; for xdg-screensaver
> (arguments
> - `(#:tests? #f ; no check target
> + `(; Ensure we don't keep a reference to this old version of w3m

I was confused by the "old version". Perhaps rephrase to "[...] this
potentially old version [...]" ?

Toggle quote (6 lines)
> + #:disallowed-references (,w3m-for-tests)
> + #:tests? #f ; no check target
> #:modules ((srfi srfi-26)
> ,@%gnu-build-system-modules)
> #:phases

Otherwise, LGTM!

--
Thanks,
Maxim
L
L
Leo Famulari wrote on 26 Mar 2023 22:04
Re: Decouple w3m from xdg-utils test suite
(address . guix-patches@gnu.org)
ZCClRxggnCvkRkur@jasmine.lan
On Thu, Feb 02, 2023 at 12:32:10PM +0100, Leo Famulari wrote:
Toggle quote (7 lines)
> This patch series decouples w3m from the test suite of xdg-utils, which
> is useful because of xdg-utils large reverse dependency graph.
>
> By making this change, we will be able to update w3m more conveniently,
> rather than waiting for a core-updates / staging cycle, or a feature
> branch.

I pushed the decoupling as commit 9ec1af39e29d0fa95d4db4b5b8ef1cf3613c5956.

Forbidding xdg-utils from referring to w3m-for-tests will have to be
done off of the master branch, since it causes many rebuilds.
B
B
Bruno Victal wrote on 31 Mar 2023 01:00
control-msg
(name . control)(address . control@debbugs.gnu.org)
74912071-f536-c8bc-4711-db295b4da0e6@makinata.eu
# done with 5c131aff691fa1cb0fafe71b5f2795902ae056a7
close 55819

# control fail?
close 45449

# no longer relevant
close 33078

# tags
tags 62551 patch
tags 62503 patch
tags 62461 patch
tags 62443 patch
tags 62428 patch
tags 61226 patch
tags 59893 patch
tags 59852 patch
tags 49451 patch
tags 49207 patch
tags 44258 patch


quit
?