[PATCH 3/3] gnu: supertuxkart: Update to 1.4.

  • Done
  • quality assurance status badge
Details
2 participants
  • Sughosha
  • Ludovic Courtès
Owner
unassigned
Submitted by
Sughosha
Severity
normal
S
S
Sughosha wrote on 2 Feb 2023 12:20
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
ATAfYDA977C92QXvTSwEn2N171LKe3arX3za2SiB4fJZIOB7t5m3J3yR8GFP1otBPLbCIGNCxyZ2Wcafu6HQDDjRQTYCSTmU7N2jYa2rUnM=@proton.me
Update supertuxkart to 1.4, enable recorder and unbundle mcpp.
From 81e0fb91fff6f9ae51e6992dd0be68d0ba68da5d Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Thu, 2 Feb 2023 12:13:28 +0100
Subject: [PATCH 3/3] gnu: supertuxkart: Update to 1.4.

* gnu/packages/games.scm (supertuxkart): Update to 1.4.
[snippet]: Unbundle mcpp.
[arguments]: Enable recorder.
[inputs]: Add libopenglrecorder.
[native-inputs]: Add mcpp and python.
---
gnu/packages/games.scm | 15 +++++++--------
1 file changed, 7 insertions(+), 8 deletions(-)

Toggle diff (65 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index f85e9333f7..f0f3ede821 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4082,7 +4082,7 @@ (define-public exult
(define-public supertuxkart
(package
(name "supertuxkart")
- (version "1.3")
+ (version "1.4")
(source
(origin
(method url-fetch)
@@ -4091,7 +4091,7 @@ (define-public supertuxkart
version "/SuperTuxKart-" version "-src.tar.xz"))
(sha256
(base32
- "1z9z13zarv28h4jrmjna5hr6m9266pm7c2kgiwhqls01k06ypazf"))
+ "00qg5i9y4i5gdiiq1dbfsgp7dwj60zb5lkgi2d9p3x5s34j3k44q"))
(modules '((guix build utils)))
(snippet
;; Delete bundled library sources
@@ -4099,10 +4099,11 @@ (define-public supertuxkart
;; Supertuxkart uses modified versions of the Irrlicht engine
;; and the bullet library. The developers gave an explanation
;; here: http://forum.freegamedev.net/viewtopic.php?f=17&t=3906
- ;; FIXME: try to unbundle angelscript, libmcpp and libraqm
+ ;; FIXME: try to unbundle angelscript and libraqm
(for-each delete-file-recursively
'("lib/dnsc"
"lib/enet"
+ "lib/mcpp"
"lib/mojoal"
"lib/wiiuse"))
#t))))
@@ -4115,15 +4116,14 @@ (define-public supertuxkart
"-DUSE_CRYPTO_OPENSSL=TRUE"
;; In order to use the system ENet library, IPv6 support (added in
;; SuperTuxKart version 1.1) must be disabled.
- "-DUSE_IPV6=FALSE"
- ;; FIXME: needs libopenglrecorder
- "-DBUILD_RECORDER=0")))
+ "-DUSE_IPV6=FALSE")))
(inputs
`(("curl" ,curl)
("freetype" ,freetype)
("fribidi" ,fribidi)
("glew" ,glew)
("harfbuzz" ,harfbuzz)
+ ("libopenglrecorder" ,libopenglrecorder)
("libvorbis" ,libvorbis)
("libx11" ,libx11)
("libxrandr" ,libxrandr)
@@ -4137,8 +4137,7 @@ (define-public supertuxkart
("enet" ,enet)
("libjpeg" ,libjpeg-turbo)
("openssl" ,openssl)))
- (native-inputs
- (list pkg-config))
+ (native-inputs (list mcpp pkg-config python))
(home-page "https://supertuxkart.net/Main_Page")
(synopsis "3D kart racing game")
(description "SuperTuxKart is a 3D kart racing game, with a focus on
--
2.39.1
From e879abbd120ffdfd0cb1c3104fbe9146aa15258e Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Thu, 2 Feb 2023 12:08:56 +0100
Subject: [PATCH 2/3] gnu: Add libopenglrecorder.

* gnu/packages/gl.scm (libopenglrecorder): New public variable.
---
gnu/packages/gl.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 01ab6135a4..09aafcc1c3 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -796,6 +796,32 @@ (define-public libglvnd
license:x11
license:expat))))
+(define-public libopenglrecorder
+ (package
+ (name "libopenglrecorder")
+ (version "0.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Benau/libopenglrecorder")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0sfx2kdw2mca3mx4fnk1yy74pilp2i9npcpyj894qkngz5aaz2wl"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:tests? #f)) ;no test suite
+ (native-inputs (list pkg-config))
+ (inputs (list libjpeg-turbo))
+ (home-page "https://github.com/Benau/libopenglrecorder")
+ (synopsis "Async readback OpenGL frame buffer with audio recording")
+ (description
+ "libopenglrecorder is a library allowing optional async readback OpenGL
+frame buffer with optional audio recording. It will do video and audio
+encoding together.")
+ (license license:bsd-3)))
+
(define-public soil
(package
(name "soil")
--
2.39.1
From 71affeda0d20521fd5f8ab23d5ea5046de68a702 Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Thu, 2 Feb 2023 12:08:13 +0100
Subject: [PATCH 1/3] gnu: Add mcpp.

* gnu/packages/cpp.scm (mcpp): New public variable.
---
gnu/packages/cpp.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 0eecab50fb..0a5383e35d 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -1428,6 +1428,27 @@ (define-public magic-enum
conversions to and from strings, iteration and related functionality.")
(license license:expat)))
+(define-public mcpp
+ (package
+ (name "mcpp")
+ (version "2.7.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/mcpp/mcpp/"
+ "V." version "/mcpp-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0r48rfghjm90pkdyr4khxg783g9v98rdx2n69xn8f6c5i0hl96rv"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:configure-flags #~(list "--enable-mcpplib" "--disable-static")))
+ (home-page "https://mcpp.sourceforge.net/")
+ (synopsis "C/C++ preprocessor")
+ (description
+ "@code{mcpp} is Matsui's CPP implementation precisely conformed to
+standards.")
+ (license license:bsd-2)))
+
(define-public cli11
(package
(name "cli11")
--
2.39.1
L
L
Ludovic Courtès wrote on 11 Feb 2023 00:06
(name . Sughosha)(address . Sughosha@proton.me)(address . 61225-done@debbugs.gnu.org)
87ttztnmse.fsf@gnu.org
Hi,

Sughosha <Sughosha@proton.me> skribis:

Toggle quote (11 lines)
> From 81e0fb91fff6f9ae51e6992dd0be68d0ba68da5d Mon Sep 17 00:00:00 2001
> From: Sughosha <sughosha@proton.me>
> Date: Thu, 2 Feb 2023 12:13:28 +0100
> Subject: [PATCH 3/3] gnu: supertuxkart: Update to 1.4.
>
> * gnu/packages/games.scm (supertuxkart): Update to 1.4.
> [snippet]: Unbundle mcpp.
> [arguments]: Enable recorder.
> [inputs]: Add libopenglrecorder.
> [native-inputs]: Add mcpp and python.

[...]

Toggle quote (7 lines)
> From e879abbd120ffdfd0cb1c3104fbe9146aa15258e Mon Sep 17 00:00:00 2001
> From: Sughosha <sughosha@proton.me>
> Date: Thu, 2 Feb 2023 12:08:56 +0100
> Subject: [PATCH 2/3] gnu: Add libopenglrecorder.
>
> * gnu/packages/gl.scm (libopenglrecorder): New public variable.

[...]

Toggle quote (7 lines)
> From 71affeda0d20521fd5f8ab23d5ea5046de68a702 Mon Sep 17 00:00:00 2001
> From: Sughosha <sughosha@proton.me>
> Date: Thu, 2 Feb 2023 12:08:13 +0100
> Subject: [PATCH 1/3] gnu: Add mcpp.
>
> * gnu/packages/cpp.scm (mcpp): New public variable.

Applied all three patches.

In the future please send patches using ‘git send-email’:


This will ensure https://qa.guix.gnu.orgcan apply them and test them.

Thanks!

Ludo’.
Closed
?