[PATCH] gnu: basu: Propagate libcap.

  • Done
  • quality assurance status badge
Details
2 participants
  • Josselin Poiret
  • Jelle Licht
Owner
unassigned
Submitted by
Josselin Poiret
Severity
normal
J
J
Josselin Poiret wrote on 1 Feb 2023 17:56
(address . guix-patches@gnu.org)(name . Josselin Poiret)(address . dev@jpoiret.xyz)
29854884695de3d32b2fb8899e49282aaec74c9e.1675270507.git.dev@jpoiret.xyz
* gnu/packages/freedesktop.scm (basu): Propagate libcap so that pkg-config can
find basu's dependency.
---

This fixes mako not building, just like 61145 and 61191, but this should be the
proper fix instead.

Best,

gnu/packages/freedesktop.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (18 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index a986c8c350..a7690e1092 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -827,7 +827,8 @@ (define-public basu
(build-system meson-build-system)
(native-inputs
(list pkg-config python gperf))
- (inputs
+ (propagated-inputs
+ ;; Propagated because of pkg-config
(list libcap))
(synopsis "The sd-bus library, extracted from systemd")
(description "Some projects rely on the sd-bus library for DBus support.

base-commit: 9d7a1e58f91889d5a5330d4bf9911102f2e66db9
--
2.39.1
J
J
Jelle Licht wrote on 9 Feb 2023 15:24
(address . 61213-done@debbugs.gnu.org)(name . Josselin Poiret)(address . dev@jpoiret.xyz)
87bkm2kjcu.fsf@fsfe.org
Josselin Poiret via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (31 lines)
> * gnu/packages/freedesktop.scm (basu): Propagate libcap so that pkg-config can
> find basu's dependency.
> ---
>
> This fixes mako not building, just like 61145 and 61191, but this should be the
> proper fix instead.
>
> Best,
>
> gnu/packages/freedesktop.scm | 3 ++-
> 1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
> index a986c8c350..a7690e1092 100644
> --- a/gnu/packages/freedesktop.scm
> +++ b/gnu/packages/freedesktop.scm
> @@ -827,7 +827,8 @@ (define-public basu
> (build-system meson-build-system)
> (native-inputs
> (list pkg-config python gperf))
> - (inputs
> + (propagated-inputs
> + ;; Propagated because of pkg-config
> (list libcap))
> (synopsis "The sd-bus library, extracted from systemd")
> (description "Some projects rely on the sd-bus library for DBus support.
>
> base-commit: 9d7a1e58f91889d5a5330d4bf9911102f2e66db9
> --
> 2.39.1

Thanks, applied to master!
- Jelle
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61213@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61213
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch