(address . guix-patches@gnu.org)(name . Josselin Poiret)(address . dev@jpoiret.xyz)
* gnu/packages/freedesktop.scm (basu): Propagate libcap so that pkg-config can
find basu's dependency.
---
This fixes mako not building, just like 61145 and 61191, but this should be the
proper fix instead.
Best,
gnu/packages/freedesktop.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
Toggle diff (18 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index a986c8c350..a7690e1092 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -827,7 +827,8 @@ (define-public basu
(build-system meson-build-system)
(native-inputs
(list pkg-config python gperf))
- (inputs
+ (propagated-inputs
+ ;; Propagated because of pkg-config
(list libcap))
(synopsis "The sd-bus library, extracted from systemd")
(description "Some projects rely on the sd-bus library for DBus support.
base-commit: 9d7a1e58f91889d5a5330d4bf9911102f2e66db9
--
2.39.1