[PATCH] gnu: Remove valgrind-3.20.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Simon Tournier
Owner
unassigned
Submitted by
Simon Tournier
Severity
normal

Debbugs page

Simon Tournier wrote 2 years ago
(address . guix-patches@gnu.org)(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
20230131103229.904755-1-zimon.toutoune@gmail.com
* gnu/packages/valgrind.scm (valgrind-3.20): Delete variable.
(valgrind/interactive): Update to 3.20.0.
---
gnu/packages/valgrind.scm | 22 +++-------------------
1 file changed, 3 insertions(+), 19 deletions(-)

Hi,

The patch is a follow up of [1]. It removes an unnecessary version of
Valgrind.

The patch does not imply any rebuild.



Cheers,
simon


Toggle diff (56 lines)
diff --git a/gnu/packages/valgrind.scm b/gnu/packages/valgrind.scm
index 422e542918..bd08dffc83 100644
--- a/gnu/packages/valgrind.scm
+++ b/gnu/packages/valgrind.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2022 Denis Carikli <GNUtoo@cyberdimension.org>
+;;; Copyright © 2023 Simon Tournier <zimon.toutoune@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -96,7 +97,7 @@ (define-public valgrind
(define-public valgrind/interactive
(package/inherit
valgrind
- (version "3.17.0")
+ (version "3.20.0")
(source (origin
(method url-fetch)
(uri (list (string-append "https://sourceware.org/pub/valgrind"
@@ -105,9 +106,8 @@ (define-public valgrind/interactive
"/valgrind-" version ".tar.bz2")))
(sha256
(base32
- "18l5jbk301j3462gipqn9bkfx44mdmwn0pwr73r40gl1irkfqfmd"))
+ "1ipkp6yi202pml2r0qwflysmq86dkqd8iyi1y51d6y70vcqw0dl5"))
(patches (search-patches
- "valgrind-enable-arm.patch"
"valgrind-fix-default-debuginfo-path.patch"))))
(inputs
;; GDB is needed to provide a sane default for `--db-command'.
@@ -148,19 +148,3 @@ (define libc-debug
(string-length "/usr/lib/debug")
1))))))))))
(properties '())))
-
-(define-public valgrind-3.20
- (package
- (inherit valgrind/interactive)
- (version "3.20.0")
- (source (origin
- (inherit (package-source valgrind/interactive))
- (uri (list (string-append "https://sourceware.org/pub/valgrind"
- "/valgrind-" version ".tar.bz2")
- (string-append "ftp://sourceware.org/pub/valgrind"
- "/valgrind-" version ".tar.bz2")))
- (sha256
- (base32
- "1ipkp6yi202pml2r0qwflysmq86dkqd8iyi1y51d6y70vcqw0dl5"))
- (patches (search-patches
- "valgrind-fix-default-debuginfo-path.patch"))))))

base-commit: a3b57e57e68a1f4848bf8bacd797c5d989f56de2
--
2.38.1
Ludovic Courtès wrote 2 years ago
(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
874jrvwzsd.fsf@gnu.org
Hi,

Simon Tournier <zimon.toutoune@gmail.com> skribis:

Toggle quote (3 lines)
> * gnu/packages/valgrind.scm (valgrind-3.20): Delete variable.
> (valgrind/interactive): Update to 3.20.0.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61199@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61199
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help