gnu: Add uwufetch.

  • Done
  • quality assurance status badge
Details
2 participants
  • J. Sims
  • Nicolas Goaziou
Owner
unassigned
Submitted by
J. Sims
Severity
normal

Debbugs page

J. Sims wrote 2 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
PCtpn4Z54R3M2psFCibuS_3kC0Mtx_SuQBM13k9MDPeo0C_c6PBze-ro4I74HrK-IVBtvYTlaPcvGlX9sIT_F8Py_j9eN-WTGSsAEjk0i4U=@protonmail.com
Hello,

This is a fun little fetch utility and I thought it might enjoy inclusion in Guix.

Thanks,
Juli
Attachment: file
From 17bff0290e443766b6f5cd9ff211c0026ded0bae Mon Sep 17 00:00:00 2001
From: Juliana Sims <jtsims@protonmail.com>
Date: Sun, 29 Jan 2023 15:44:48 -0600
Subject: [PATCH] gnu: Add uwufetch.

* gnu/packages/admin.scm (uwufetch): Add uwufetch.
---
gnu/packages/admin.scm | 47 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 47 insertions(+)

Toggle diff (69 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 5cea17d562..8babf4227e 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -55,6 +55,7 @@
;;; Copyright © 2022 ( <paren@disroot.org>
;;; Copyright © 2022 Matthew James Kraai <kraai@ftbfs.org>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2023 Juliana Sims <jtsims@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3944,6 +3945,52 @@ (define-public hyfetch
you are running, what theme or icon set you are using, etc.")
(license license:expat)))
+(define-public uwufetch
+ (package
+ (name "uwufetch")
+ (version "2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/TheDarkBug/uwufetch")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0s4pzaqmlq6rn54kgmlpcrc0sy3q5zn6lxh4448k9iimshljsjfs"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:tests? #f ;no tests
+ #:make-flags #~(list (string-append "DESTDIR="
+ #$output)
+ (string-append "ETC_DIR="
+ #$output "/etc")
+ (string-append "CC="
+ #$(cc-for-target)))
+ #:phases (with-imported-modules '((guix build utils))
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'path-source-paths
+ (lambda _
+ (substitute* "uwufetch.c"
+ (("(/usr(/local)?)(.*;)"
+ all _ _ rest)
+ (string-append #$output
+ rest)))))))))
+ (native-inputs (list git))
+ (inputs (list lshw
+ ;; viu XXX not yet packaged in Guix
+ xwininfo))
+ (home-page "https://github.com/TheDarkBug/uwufetch")
+ (synopsis "Cutesie *fetch utility")
+ (description
+ "UwUFetch is a system information tool in the lineage of @code{neofetch},
+@code{pfetch}, @{hyfetch}, and the like. It prints ASCII art of your system's
+logo as well as a summary of system information. UwUFetch's unique contribution
+is the uwu-ification of various words used in the description. For example, Guix
+become gUwUix.")
+ (license license:gpl3)))
+
(define-public screenfetch
(package
(name "screenfetch")

base-commit: 4eccb27b4c74a9112cbbad722d85558e9565f20b
--
2.39.1
Nicolas Goaziou wrote 2 years ago
(name . J. Sims via Guix-patches via)(address . guix-patches@gnu.org)
87bkme23cu.fsf@nicolasgoaziou.fr
Hello,

"J. Sims via Guix-patches" via <guix-patches@gnu.org> writes:

Toggle quote (3 lines)
> This is a fun little fetch utility and I thought it might enjoy
> inclusion in Guix.

Thank you. Some comments follow.

Toggle quote (4 lines)
> + (build-system gnu-build-system)
> + (arguments
> + (list #:tests? #f ;no tests

Please add a newline character after "list".

Toggle quote (7 lines)
> + #:make-flags #~(list (string-append "DESTDIR="
> + #$output)
> + (string-append "ETC_DIR="
> + #$output "/etc")
> + (string-append "CC="
> + #$(cc-for-target)))

Please also add a newline character after "flags". Every flag should fit
into a single line.

Toggle quote (2 lines)
> + #:phases (with-imported-modules '((guix build utils))

I don'tthink you need to import modules.

Toggle quote (10 lines)
> + #~(modify-phases %standard-phases
> + (delete 'configure)
> + (add-before 'build 'path-source-paths
> + (lambda _
> + (substitute* "uwufetch.c"
> + (("(/usr(/local)?)(.*;)"
> + all _ _ rest)
> + (string-append #$output
> + rest)))))))))

You can move this below "#:phases" to drastically improve indentation.

Toggle quote (2 lines)
> + (native-inputs (list git))

Are you sure git is required as a native input? If it is, then this
should be `git-minimal' instead.


Toggle quote (2 lines)
> + (synopsis "Cutesie *fetch utility")

I think we should provide better than this synopsis. Maybe, according
to upstream's About,

Meme system info tool based on Nyan/UwU trend

Toggle quote (4 lines)
> + (description
> + "UwUFetch is a system information tool in the lineage of @code{neofetch},
> +@code{pfetch}, @{hyfetch}, and the like. It prints ASCII art of your system's

I suggest to use Neofetch instead of @code{neofetch}, Pfetch instead of
@code{pfetch} and HyFetch instead of (mind the typo!) @code{hyfetch}.

Toggle quote (4 lines)
> +logo as well as a summary of system information. UwUFetch's unique contribution
> +is the uwu-ification of various words used in the description. For example, Guix
> +become gUwUix.")

Sentences should be separated with two spaces.

Toggle quote (2 lines)
> + (license license:gpl3)))

License is actually GPL3+.

Could you send an updated patch?

Regards,
--
Nicolas Goaziou
J. Sims wrote 2 years ago
T_L5ZP68uFQVEkBxiSKFeiSeaa0wnwnW9BKEO9TlrwUnUROlrixht-iH2ky73jf4ArVMJqEg5ggxicXlamstj8HCckKeMm6284v2HYGnvHM=@protonmail.com
Hello,

I believe this version of the patch should address all the concerns you raised.

On Tuesday, January 31st, 2023 at 08:19, Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:

Toggle quote (4 lines)
> > + (license license:gpl3)))
>
> License is actually GPL3+.

For future reference, where do I look to differentiate GPLv3 from GPLv3+? I do check that, but obviously I sometimes miss it.

Thanks,
Juli
From 57c7e81d9d44a9e905e8a89714f05a9059f15226 Mon Sep 17 00:00:00 2001
From: Juliana Sims <jtsims@protonmail.com>
Date: Sun, 29 Jan 2023 15:44:48 -0600
Subject: [PATCH] gnu: Add uwufetch.

* gnu/packages/admin.scm (uwufetch): Add uwufetch.
---
gnu/packages/admin.scm | 43 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (65 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 5cea17d562..46b38ef053 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -55,6 +55,7 @@
;;; Copyright © 2022 ( <paren@disroot.org>
;;; Copyright © 2022 Matthew James Kraai <kraai@ftbfs.org>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2023 Juliana Sims <jtsims@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3944,6 +3945,48 @@ (define-public hyfetch
you are running, what theme or icon set you are using, etc.")
(license license:expat)))
+(define-public uwufetch
+ (package
+ (name "uwufetch")
+ (version "2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/TheDarkBug/uwufetch")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0s4pzaqmlq6rn54kgmlpcrc0sy3q5zn6lxh4448k9iimshljsjfs"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ;no tests
+ #:make-flags
+ #~(list (string-append "DESTDIR=" #$output)
+ (string-append "ETC_DIR=" #$output "/etc")
+ (string-append "CC=" #$(cc-for-target)))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'path-source-paths
+ (lambda _
+ (substitute* "uwufetch.c"
+ (("(/usr(/local)?)(.*;)" all _ _ rest)
+ (string-append #$output rest))))))))
+ (inputs (list lshw
+ ;; viu XXX not yet packaged in Guix
+ xwininfo))
+ (home-page "https://github.com/TheDarkBug/uwufetch")
+ (synopsis "Meme system info tool based on Nyan/UwU trend")
+ (description
+ "UwUFetch is a system information tool in the lineage of NeoFetch,
+PFetch, HyFetch, and the like. It prints ASCII art of your system's logo as
+well as a summary of system information. UwUFetch's unique contribution is the
+uwu-ification of various words used in the description. For example, Guix
+becomes gUwUix.")
+ (license license:gpl3+)))
+
(define-public screenfetch
(package
(name "screenfetch")

base-commit: 4eccb27b4c74a9112cbbad722d85558e9565f20b
--
2.39.1
Nicolas Goaziou wrote 2 years ago
(name . J. Sims via Guix-patches via)(address . guix-patches@gnu.org)
87tu05ytd4.fsf@nicolasgoaziou.fr
Hello,

"J. Sims via Guix-patches" via <guix-patches@gnu.org> writes:

Toggle quote (3 lines)
> I believe this version of the patch should address all the concerns
> you raised.

It does. Thank you.

Toggle quote (2 lines)
> For future reference, where do I look to differentiate GPLv3 from GPLv3+? I do check that, but obviously I sometimes miss it.

If you look into any ".c" source file, you will read:

either version 3 of the License, or (at your option) any later version.

which basically means GPL3+.

Toggle quote (4 lines)
> Subject: [PATCH] gnu: Add uwufetch.
>
> * gnu/packages/admin.scm (uwufetch): Add uwufetch.

Applied!

Regards,
--
Nicolas Goaziou
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61157@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61157
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help