J. Sims wrote 2 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
Hello,
This is a fun little fetch utility and I thought it might enjoy inclusion in Guix.
Thanks,
Juli
From 17bff0290e443766b6f5cd9ff211c0026ded0bae Mon Sep 17 00:00:00 2001
From: Juliana Sims <jtsims@protonmail.com>
Date: Sun, 29 Jan 2023 15:44:48 -0600
Subject: [PATCH] gnu: Add uwufetch.
* gnu/packages/admin.scm (uwufetch): Add uwufetch.
---
gnu/packages/admin.scm | 47 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 47 insertions(+)
Toggle diff (69 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 5cea17d562..8babf4227e 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -55,6 +55,7 @@
;;; Copyright © 2022 ( <paren@disroot.org>
;;; Copyright © 2022 Matthew James Kraai <kraai@ftbfs.org>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2023 Juliana Sims <jtsims@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3944,6 +3945,52 @@ (define-public hyfetch
you are running, what theme or icon set you are using, etc.")
(license license:expat)))
+(define-public uwufetch
+ (package
+ (name "uwufetch")
+ (version "2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/TheDarkBug/uwufetch")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0s4pzaqmlq6rn54kgmlpcrc0sy3q5zn6lxh4448k9iimshljsjfs"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:tests? #f ;no tests
+ #:make-flags #~(list (string-append "DESTDIR="
+ #$output)
+ (string-append "ETC_DIR="
+ #$output "/etc")
+ (string-append "CC="
+ #$(cc-for-target)))
+ #:phases (with-imported-modules '((guix build utils))
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'path-source-paths
+ (lambda _
+ (substitute* "uwufetch.c"
+ (("(/usr(/local)?)(.*;)"
+ all _ _ rest)
+ (string-append #$output
+ rest)))))))))
+ (native-inputs (list git))
+ (inputs (list lshw
+ ;; viu XXX not yet packaged in Guix
+ xwininfo))
+ (home-page "https://github.com/TheDarkBug/uwufetch")
+ (synopsis "Cutesie *fetch utility")
+ (description
+ "UwUFetch is a system information tool in the lineage of @code{neofetch},
+@code{pfetch}, @{hyfetch}, and the like. It prints ASCII art of your system's
+logo as well as a summary of system information. UwUFetch's unique contribution
+is the uwu-ification of various words used in the description. For example, Guix
+become gUwUix.")
+ (license license:gpl3)))
+
(define-public screenfetch
(package
(name "screenfetch")
base-commit: 4eccb27b4c74a9112cbbad722d85558e9565f20b
--
2.39.1