[PATCH] gnu: emacs-next: Enable tree-sitter support.

  • Done
  • quality assurance status badge
Details
3 participants
  • Andrew Tropin
  • Declan Tsien
  • Luis Henrique Gomes Higino
Owner
unassigned
Submitted by
Declan Tsien
Severity
normal
D
D
Declan Tsien wrote on 29 Jan 2023 07:10
(address . guix-patches@gnu.org)
87a6217tw5.fsf@riseup.net
From d51a7e7812beec431e79164efe9d7cb87341674e Mon Sep 17 00:00:00 2001
From: Declan Tsien <declantsien@riseup.net>
Date: Sun, 29 Jan 2023 13:34:03 +0800
Subject: [PATCH] gnu: emacs-next: Enable tree-sitter support.

* gnu/packages/emacs.scm (emacs-next): Update to 29.0.60-1.2bd0b94.
* gnu/packages/emacs.scm (emacs-next)[propagated-inputs]: Add tree-sitter.
---
gnu/packages/emacs.scm | 13 +++++++++----
1 file changed, 9 insertions(+), 4 deletions(-)

Toggle diff (55 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 299ab5e992..ed62f6ec8b 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
+;;; Copyright © 2022 Declan Tsien <declantsien@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -75,6 +76,7 @@ (define-module (gnu packages emacs)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages tls)
+ #:use-module (gnu packages text-editors) ; for tree-sitter
#:use-module (gnu packages web) ; for jansson
#:use-module (gnu packages webkit)
#:use-module (gnu packages xml)
@@ -381,12 +383,12 @@ (define* (emacs-byte-compile-directory dir)
(license license:gpl3+)))
(define-public emacs-next
- (let ((commit "6adc193ad66445acd84caba6973424ecbd21da26")
- (revision "4"))
+ (let ((commit "2bd0b9475384adfb4dd2cc794bbe1d8621546717")
+ (revision "1"))
(package
(inherit emacs)
(name "emacs-next")
- (version (git-version "29.0.50" revision commit))
+ (version (git-version "29.0.60" revision commit))
(source
(origin
(inherit (package-source emacs))
@@ -401,10 +403,13 @@ (define-public emacs-next
"emacs-native-comp-driver-options.patch"))
(sha256
(base32
- "0b48qg9w7fzvhva78gzi3cs2m6asj11fk0kgys49fqhwskigzg1f"))))
+ "0pf2qlbfddpzp38x6rpz0qpadwa3vgrp3dik3a4wr3cdcby98cc3"))))
(inputs
(modify-inputs (package-inputs emacs)
(prepend sqlite)))
+ (propagated-inputs
+ (modify-inputs (package-propagated-inputs emacs)
+ (prepend tree-sitter)))
(native-inputs
(modify-inputs (package-native-inputs emacs)
(prepend autoconf))))))

base-commit: bea22409682f6d1947de7d92f264aad822c2e68c
--
2.39.1
-----BEGIN PGP SIGNATURE-----

iQHLBAEBCAA1FiEE9pXznsYl4IEztXWfD8aHA3Xv4vUFAmPWDeoXHGRlY2xhbnRz
aWVuQHJpc2V1cC5uZXQACgkQD8aHA3Xv4vUTrQwA0VeQSGzrKzvTNsFopFYbimCH
U9/o7UoJ2iEjA5hdbXs/8pbtP0S6g6+Dt8sY2/GR+3gjKlRx+tn/YHvyueTH/o2d
o02mO1X74AVueZxKGZbRLqiHU5da3ZccAQYQys9o8HUeEIHs4r6DvMUWsqwwqA3O
P0Jd7lFPXh22iMpicsIUztCUK+0MG7OMkvFV0iszUta1eBo28Iwu35SBTa1Bj21c
KGIm4PdiiNeADLN57yoGI37lrBUHcoIvZxG3TGPM1YFtyUwVjiDBdrDJISI+7SB4
BcuZ5iSw/Jo6JW1uh3w1XLk42a0bg9PSYsKiIOT7yPAOzbmQg55qkGBkfkzI2A1H
tjfBjQWjxOIu4IV8JglF6hOtfQt2TCYGDwcxdaXPJS/zUJvc7CGrpxDIpnWaguHB
mkqAF/F31Iu2tZ5wcZ0ddQ1+RwmxELuz6E6Gq+tLZwo20qhKmuvCK72KkRBABfZ9
b/zsP+yl0XdqoexPzrDPBBN/BpfyPBdCctutu60s
=g5d7
-----END PGP SIGNATURE-----

L
L
Luis Henrique Gomes Higino wrote on 29 Jan 2023 16:26
87fsbte4ds.fsf@gmail.com
Hi Declan,

Toggle quote (6 lines)
> (define-public emacs-next
> - (let ((commit "6adc193ad66445acd84caba6973424ecbd21da26")
> - (revision "4"))
> + (let ((commit "2bd0b9475384adfb4dd2cc794bbe1d8621546717")
> + (revision "1"))

Revision numbers start at 0 if I'm not mistaken.

Toggle quote (10 lines)
> (inputs
> (modify-inputs (package-inputs emacs)
> (prepend sqlite)))
> + (propagated-inputs
> + (modify-inputs (package-propagated-inputs emacs)
> + (prepend tree-sitter)))
> (native-inputs
> (modify-inputs (package-native-inputs emacs)
> (prepend autoconf))))))

Is there any reason for tree-sitter to be added as a propagated
input? It does not provide any binaries and I tested changing it
to a normal input and c-ts-mode worked fine.

Regards,
--
Luis H. Higino
D
D
Declan Tsien wrote on 29 Jan 2023 17:17
Subject: [PATCH v2] gnu: emacs-next: Enable tree-sitter support.
87ilgpuxg3.fsf@riseup.net
Hey Luis

Toggle quote (4 lines)
>
> Revision numbers start at 0 if I'm not mistaken.
>

Good to know. Thanks.

Toggle quote (6 lines)
>
> Is there any reason for tree-sitter to be added as a propagated
> input? It does not provide any binaries and I tested changing it
> to a normal input and c-ts-mode worked fine.
>

Wired. I tried to put it in the =inputs= earlier today, Emacs failed to
find tree-sitter. But it works now. I guess I did something wrong before.

Regards,
Declan
From 1d91c374a325ad8be799cadeb77b4b976b8fbce9 Mon Sep 17 00:00:00 2001
From: Declan Tsien <declantsien@riseup.net>
Date: Sun, 29 Jan 2023 13:34:03 +0800
Subject: [PATCH] gnu: emacs-next: Enable tree-sitter support.

* gnu/packages/emacs.scm (emacs-next): Update to 29.0.60-0.2bd0b94.
* gnu/packages/emacs.scm (emacs-next)[inputs]: Add tree-sitter.
---
gnu/packages/emacs.scm | 12 +++++++-----
1 file changed, 7 insertions(+), 5 deletions(-)

Toggle diff (53 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 299ab5e992..03182d233b 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
+;;; Copyright © 2022 Declan Tsien <declantsien@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -75,6 +76,7 @@ (define-module (gnu packages emacs)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages tls)
+ #:use-module (gnu packages text-editors) ; for tree-sitter
#:use-module (gnu packages web) ; for jansson
#:use-module (gnu packages webkit)
#:use-module (gnu packages xml)
@@ -381,12 +383,12 @@ (define* (emacs-byte-compile-directory dir)
(license license:gpl3+)))
(define-public emacs-next
- (let ((commit "6adc193ad66445acd84caba6973424ecbd21da26")
- (revision "4"))
+ (let ((commit "2bd0b9475384adfb4dd2cc794bbe1d8621546717")
+ (revision "0"))
(package
(inherit emacs)
(name "emacs-next")
- (version (git-version "29.0.50" revision commit))
+ (version (git-version "29.0.60" revision commit))
(source
(origin
(inherit (package-source emacs))
@@ -401,10 +403,10 @@ (define-public emacs-next
"emacs-native-comp-driver-options.patch"))
(sha256
(base32
- "0b48qg9w7fzvhva78gzi3cs2m6asj11fk0kgys49fqhwskigzg1f"))))
+ "0pf2qlbfddpzp38x6rpz0qpadwa3vgrp3dik3a4wr3cdcby98cc3"))))
(inputs
(modify-inputs (package-inputs emacs)
- (prepend sqlite)))
+ (prepend sqlite tree-sitter)))
(native-inputs
(modify-inputs (package-native-inputs emacs)
(prepend autoconf))))))

base-commit: bea22409682f6d1947de7d92f264aad822c2e68c
--
2.39.1
-----BEGIN PGP SIGNATURE-----

iQHLBAEBCAA1FiEE9pXznsYl4IEztXWfD8aHA3Xv4vUFAmPWnCwXHGRlY2xhbnRz
aWVuQHJpc2V1cC5uZXQACgkQD8aHA3Xv4vUfWgwAnDN1Zen/uOB6RhpC0derlBfv
i+OFlQ3Q4+ShkQnuP4XWmzPQep+MygVzKgR5dcdZIBv3o6dsTgj38MzyulkUhNpT
f0w4daGyjU+KiBlFxdKwuiSkTSaBdh4/Spa9gbu3lN1Rrb2jUNj1qlFdLdBX26ut
zUhlRp1MT3mc2Kgzv53AtB+sq3GVnpdyzUhba3T3OEdaLcKgufeZjlPZJFWISghV
54vpb2JWjGUY1XlitSjqtqcbyPeTafhQZHUFdRc7oRiBBmHx5dfA2Me5BE5Xwjsl
ki9AyUg1oThD1PaPTQsgMR7N/K3NMYo8xjQpwofFkHZo4G4aUT/BiIc+lGYmdjQP
A/cRi4wEOVbsNnMAge3frk0T/6aPzgTr+Kl+R2afntvm9Yoq4rd2YEnqDYQg5QSl
c4LNAOrswQ7nmwLdsYaHFXNGUIk7/XGMDpcR5Q5B1RBXPtcTYkcC9KInMv2F5Ady
QvoGA3dSf7g1pPacG4XUhzj80mEeEsu28ntgCp6P
=yd9c
-----END PGP SIGNATURE-----

L
L
Luis Henrique Gomes Higino wrote on 29 Jan 2023 18:47
(name . Declan Tsien)(address . declantsien@riseup.net)(address . 61139@debbugs.gnu.org)
878rhldyay.fsf@gmail.com
Hi Declan,

tried your newest patch and it LGTM. The only problem I see now is
that your copyright's year is wrong haha.

Regards,
--
Luis H. Higino
D
D
Declan Tsien wrote on 30 Jan 2023 03:02
[PATCH v3] gnu: emacs-next: Enable tree-sitter support.
87fsbsvky5.fsf@riseup.net
Hey Luis,

Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com> writes:

Toggle quote (9 lines)
> Hi Declan,
>
> tried your newest patch and it LGTM. The only problem I see now is
> that your copyright's year is wrong haha.
>
> Regards,
> --
> Luis H. Higino

Whops, fixed the year.

Regards,
Declan
From 8ffd29a3fb7d07630a3971d47feb765e9f99ee4d Mon Sep 17 00:00:00 2001
From: Declan Tsien <declantsien@riseup.net>
Date: Sun, 29 Jan 2023 13:34:03 +0800
Subject: [PATCH] gnu: emacs-next: Enable tree-sitter support.

* gnu/packages/emacs.scm (emacs-next): Update to 29.0.60-0.2bd0b94.
* gnu/packages/emacs.scm (emacs-next)[inputs]: Add tree-sitter.
---
gnu/packages/emacs.scm | 12 +++++++-----
1 file changed, 7 insertions(+), 5 deletions(-)

Toggle diff (53 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 299ab5e992..e21d6f7954 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
+;;; Copyright © 2023 Declan Tsien <declantsien@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -75,6 +76,7 @@ (define-module (gnu packages emacs)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages tls)
+ #:use-module (gnu packages text-editors) ; for tree-sitter
#:use-module (gnu packages web) ; for jansson
#:use-module (gnu packages webkit)
#:use-module (gnu packages xml)
@@ -381,12 +383,12 @@ (define* (emacs-byte-compile-directory dir)
(license license:gpl3+)))
(define-public emacs-next
- (let ((commit "6adc193ad66445acd84caba6973424ecbd21da26")
- (revision "4"))
+ (let ((commit "2bd0b9475384adfb4dd2cc794bbe1d8621546717")
+ (revision "0"))
(package
(inherit emacs)
(name "emacs-next")
- (version (git-version "29.0.50" revision commit))
+ (version (git-version "29.0.60" revision commit))
(source
(origin
(inherit (package-source emacs))
@@ -401,10 +403,10 @@ (define-public emacs-next
"emacs-native-comp-driver-options.patch"))
(sha256
(base32
- "0b48qg9w7fzvhva78gzi3cs2m6asj11fk0kgys49fqhwskigzg1f"))))
+ "0pf2qlbfddpzp38x6rpz0qpadwa3vgrp3dik3a4wr3cdcby98cc3"))))
(inputs
(modify-inputs (package-inputs emacs)
- (prepend sqlite)))
+ (prepend sqlite tree-sitter)))
(native-inputs
(modify-inputs (package-native-inputs emacs)
(prepend autoconf))))))

base-commit: bea22409682f6d1947de7d92f264aad822c2e68c
--
2.39.1
-----BEGIN PGP SIGNATURE-----

iQHLBAEBCAA1FiEE9pXznsYl4IEztXWfD8aHA3Xv4vUFAmPXJTIXHGRlY2xhbnRz
aWVuQHJpc2V1cC5uZXQACgkQD8aHA3Xv4vXZSQwAyzItrdweKjdZcWptuVHF2lhM
dZyvFt7YloTzNT275yO6+cOnYRBnGcJZxsLvW5MI/ndn+DWvK81z7h6/HtgtbinS
k5Wdxej2Iu4FPpUcA4APYq5pKJwv0LWnRYYI6qOrT5NU7uWS7GjR42cjtkrIEBdc
/HDEUnP4QwGtK2mgZ6VbvMAv94L9JdnTzwKa65howMTCCsjikcYfrwaAuxyBC3gp
oc9yuGVG6kRn+7+Ay/gCo7T8WVUfAKOocVyZIoEgJFGvWiSIOq47ZKb2pZiuuY7T
lecV8MNSATezc3aBMgD5t6IwbPaiEU09DCvTw9qnvPJxZz+HSoYMusMim1lWKnUM
WjyzeyUxc4O0AlOC++QjZRloyN1VOvWznv0fxBB+LIl8MSdMLQlWj4JuIDS53ibC
QBPnS/l9sxaDsBNg7+Ue+fnuSwqKgNklEZsiu6QC4IoanRZg0PWHHXMLxxKVw92m
KsEHAObJLa6xbhUhzoszubJgqtsfc5L+NKmvmgNr
=FlTX
-----END PGP SIGNATURE-----

A
A
Andrew Tropin wrote on 4 Feb 2023 05:51
87tu02ghje.fsf@trop.in
On 2023-01-30 10:02, Declan Tsien wrote:

Toggle quote (13 lines)
> Hey Luis,
>
> Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com> writes:
>
>> Hi Declan,
>>
>> tried your newest patch and it LGTM. The only problem I see now is
>> that your copyright's year is wrong haha.
>>
>> Regards,
>> --
>> Luis H. Higino

Hi Declan,

Thank you very much for the patch, applied it, updated emacs commit to
ac7ec87a7a0db887e4ae7fe9005aea517958b778 and pushed as
6f0c9053244d6b4cfc4130c963a15dbf83cbcdac.

--
Best regards,
Andrew Tropin
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmPd5DUACgkQIgjSCVjB
3rCSsA/+NihHYZ0luAzCJKF7MqhXrPaZJ/U79a0Jp+DaJixtMevfUi0x2OIq44k4
jupy32j4cSo4RziUMrswgliTXF6FNPXeRXWMnWx5IeDMSmSDCmRMctGTjRgUMZFI
0c027SRDvNakl0kqQ2YkD3HvJvcrCeEJIDpAG1dqltiCIZcmqRlKBcqxbqCEDE2z
/O4KUWAzVxx8uMyFL0dph4qBDnAyMnODgVuO+7WI5yEtbca/wsKrcEYpYakFN+Sa
qtfCMs0w+AkIUmO4vq6SVuxagpljF5AExnx+nu9masemv9HSs1DIaK/BtiRsOVry
KeUtM/GoeLN3ntfDYaV1It6E2qdUs8REelqKVHVWt37Lu4rB+6pbavuV8Bii2njX
272MGzdJbd8/MQpy31grUTryMXXWURUCxakqT4jcELDZFZP1GdXGeTttu5gfLD5I
FzYq0tVKmoiHXD1E0n2S9XoFNx8ihCgj2iT+Hw2GDXcvUY70GG3rWSk3/jpV+VQN
cYXh3V09dwn1+dr+/nNZV0byuib98jQvb21ppZw43XlABa+MaybRrRDBOuTBDpsA
PH7C8m8T0TtPb9Tj5Q6enCiBsD1ND8Qg7hXM6p8HwbNCxvVBAJAl9DkvgK255RvS
ctWmhUiOBVmla4kbdjgn4Cn/6IIdXnPfMv/7Lunk1Up3Q9bpglA=
=nh4e
-----END PGP SIGNATURE-----

A
A
Andrew Tropin wrote on 4 Feb 2023 05:51
Applied
(address . control@debbugs.gnu.org)
87r0v6ghik.fsf@trop.in
close 61139
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmPd5FMACgkQIgjSCVjB
3rAqeA/7BANoqt7PCX7T5rG+eUhiIHBIzHygMPmWq0pGji0MYEWxvhWK6vjCw9qD
kaM9X5snvmemPBU01i+fUyyHc7aL/MVK1L8VnbwZQ55M0+Vwv0TJ/lKuPkWkmw0C
R1A2Q2cQQ7rFtsAesSNOa0KRKTNE5AC4ayDO/Yrw1BsvTAbiV5Ljzn8W96fZu3td
XXdkGPs4iGjJ49gpHCPcaVgrosAkHNEFvM6lnjiYyulKuk8G/o4rt5M0hMPwxFjD
oneaq3C2sa0KdRwt4m072Z+tXiQilQXCtAHuOkbVIes8fQ7hdBWIrXTwceAQFwtV
YMP9YHeSGh87EmKg42sHDtHSz0iqBvoKdra/sutGlznCEN0tdRaf9sQgJVNtkfJX
RzyjGAq0bQdikouvB4vdRbVi7aD938AdP3/59M4LiQ2JTqk0Vj4NofLFz4xFCQe2
UZn7PNHtDaVab39w3N3VJeM+0PoerZCeO9oZTomCGalCvKx3xAmyg6denv9QB1pU
ViwLLRB3t7UOMgR21fyBNWkON14pOZt9aEQoCPcAuDvsSFQ7Trf8oFDB0f/YEdOJ
jCXDK++Zpfj3wr2YRxg8slc0TJhzUbPHRVPs9NdjwdUJHLIvdPFl8ag5QBH73mbc
LTxIZYQSodWz1sWBO6Vo27bCwTZtug/8PUWnLzo+3Rlju52O4a4=
=AVZL
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 61139@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61139
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch