[patch] fix: tcsh fails to build if guix builders have niceness 5 or more

  • Open
  • quality assurance status badge
Details
One participant
  • Dr. Arne Babenhauserheide
Owner
unassigned
Submitted by
Dr. Arne Babenhauserheide
Severity
normal
D
D
Dr. Arne Babenhauserheide wrote on 28 Jan 2023 23:14
(address . bug-guix@gnu.org)
87fsbul2xw.fsf@web.de
Hi,

guix build tcsh failed in my guix build when running
guix build --check tcsh

The attached patch disables the test that fails when the niceness of
guix builders is 5 or more.
From 193dca1b55b68aa883c3ed8b28bf19e9527fa065 Mon Sep 17 00:00:00 2001
From: Arne Babenhauserheide <arne_bab@web.de>
Date: Sat, 28 Jan 2023 22:29:39 +0100
Subject: [PATCH] gnu: tcsh: comment out test of nice with nice guix builder

* gnu/packages/patches/tcsh-fix-autotest.patch: comment out test of nice. To
reproduce:
guix shell tcsh -- nice -n 4 tcsh -c "nice echo 1" # works
guix shell tcsh -- nice -n 5 tcsh -c "nice echo 1" # breaks
---
gnu/packages/patches/tcsh-fix-autotest.patch | 29 ++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/patches/tcsh-fix-autotest.patch b/gnu/packages/patches/tcsh-fix-autotest.patch
index 9f5790641b..252560dbb2 100644
--- a/gnu/packages/patches/tcsh-fix-autotest.patch
+++ b/gnu/packages/patches/tcsh-fix-autotest.patch
@@ -1,3 +1,32 @@
+--- tests/commands.at
++++ tests/commands.at
+@@ -890,15 +890,16 @@
+ TCSH_UNTESTED([newgrp])
+
+
+-AT_SETUP([nice])
+-
+-# Nothing really tested
+-AT_CHECK([tcsh -f -c 'nice set var=1; echo $?var'], ,
+-[0
+-])
+-
+-
+-AT_CLEANUP
++# XXX This test fails if the Guix worker has a nice value >= 5
++# AT_SETUP([nice])
++#
++# # Nothing really tested
++# AT_CHECK([tcsh -f -c 'nice -n +1 set var=1; echo $?var'], ,
++# [0
++# ])
++#
++#
++# AT_CLEANUP
+
+
+ AT_SETUP([nohup])
+
--- tests/commands.at
+++ tests/commands.at
@@ -921,26 +921,27 @@ AT_CLEANUP
--
2.39.1
Best wishes,
Arne
--
Unpolitisch sein
heißt politisch sein,
ohne es zu merken.
draketo.de
-----BEGIN PGP SIGNATURE-----

iQJEBAEBCAAuFiEE801qEjXQSQPNItXAE++NRSQDw+sFAmPVnt0QHGFybmVfYmFi
QHdlYi5kZQAKCRAT741FJAPD69pcD/0ej/AE5heE9H6tdd2m8vEl+RyyDBtVNthn
hUCq0J/reLrx6C3u94CWd3DtcI21QaQpmUz/kFFqssIhRq0sw+utIO/PdcI3+36Q
gnbcovhVkkVzjCVSc5nWY6EXXqA/4S8rdCMuK8GNp5QHJ1MwzueAwDV+lzkCuDJ7
VYAYUWlySc7yUILE7+ynZtsIsKf6Q5DjwJnaJbnrERyYDVktY1hA9WLF88eZecjI
QQN7oMRnZYLRPg6ydBDdHST2PGf5igx+nBQa5H1sqGDsk89cGym1QSAXUBy8wjeq
0UdjzzpSLmttg04fOt/l7/nJg0gAdsdq6ywBTJIOLitR8U+PinWwZ4Fj2qqbKVRD
tkQB1MXvHB0j8bUUehSSgTkO66twY4JMkLDaSwlHEFYo/H3nWTQ/rYI1NI0oNl8O
VDlF7TudSdhEzIzVsa9VRFoPNRt4AKaIB4UrcjKyF6LHvR0BwyFFpSSJFeBtxGzU
FJPlCm+X4+pgWmrOC/q+gEiHcGdoiKsrS1TZYWfyqdWsC5lE72LZF9aonW6jYNGN
S0aQWlff6kt+yFJiD79L+D4K7DseeTMLB8RejSm1P4uePLveTrxc6vAje2ptgPlD
DXXwTrs+sUz9bV6/mmH8VU514WVFd6w1sFAsqcej0Y5pP7C++tEUAWZTtwOQ51Um
2dU1Abe/9YjEBAEBCAAuFiEE3Si95tmHXKvOSosd3M8NswvBBUgFAmPVnt0QHGFy
bmVfYmFiQHdlYi5kZQAKCRDczw2zC8EFSG5rA/9O8FnoAX4xJ2c6a13rNEK3d7Vj
E79bl7ghKFPho/JptOH1Up3by8Y2fqa67zi75JIhWvpZ8yOfO8x83dF764B6eiED
hmiuzd9P3Sc0mn+cIuMwTtQAfXtCQuW0/1qUObKKjYAjBZ8tbtUTLCFY3b9opjMt
srPZjfYy7S0wP9NFdw==
=u6Nm
-----END PGP SIGNATURE-----

?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 61126@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61126
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch