(no subject)

  • Done
  • quality assurance status badge
Details
3 participants
  • Liliana Marie Prikler
  • Maxim Cournoyer
  • Maya Tomasek
Owner
unassigned
Submitted by
Maya Tomasek
Severity
normal
M
M
Maya Tomasek wrote on 27 Jan 2023 20:36
(address . guix-patches@gnu.org)
7730eb7a4bbe3bde3de772349901ba21.maya.tomasek@disroot.org
From: Maya Tomasek <maya.tomasek@disroot.org>
Date: Fri, 27 Jan 2023 20:26:11 +0100
Subject: [PATCH] gnu: Move dconf-editor native-input glib:bin to
propagated-inputs

dconf-editor crashes with "No GSettings schemas are installed on the system",
this provides the expected schemas.
---
Hi,

I have noticed that dconf-editor by default crashes as it has no schemas.
This is probably undesired, as most users install dconf-editor to edit
settings on gnome. But there is no indication that the actual error is
missing glib:bin. The issue isn't fixed by moving glib:bin to inputs.
It has to be in propagated inputs.

Kind regards,
Maya

gnu/packages/gnome.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index de5b5df450..fd74b7df2d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -10035,13 +10035,14 @@ (define-public dconf-editor
(arguments
(list #:meson meson-0.60))
(native-inputs
- `(("glib:bin" ,glib "bin") ; for glib-compile-schemas, gio-2.0.
- ("gtk+-bin" ,gtk+ "bin") ; for gtk-update-icon-cache
+ `(("gtk+-bin" ,gtk+ "bin") ; for gtk-update-icon-cache
("intltool" ,intltool)
("pkg-config" ,pkg-config)
("vala" ,vala)))
(inputs
(list dconf gtk+ libxml2))
+ (propagated-inputs
+ (list `(,glib "bin")))
(home-page "https://gitlab.gnome.org/GNOME/dconf-editor")
(synopsis "Graphical editor for GNOME's dconf configuration system")
(description
--
2.39.1
L
L
Liliana Marie Prikler wrote on 4 Feb 2023 00:04
Re: No Subject
a1ed636e2c45ff0bd368e08ede888a7436ae57e0.camel@gmail.com
Hi,

Am Freitag, dem 27.01.2023 um 20:36 +0100 schrieb Maya Tomasek:
Toggle quote (18 lines)
> From: Maya Tomasek <maya.tomasek@disroot.org>
> Date: Fri, 27 Jan 2023 20:26:11 +0100
> Subject: [PATCH] gnu: Move dconf-editor native-input glib:bin to
>  propagated-inputs
>
> dconf-editor crashes with "No GSettings schemas are installed on the
> system", this provides the expected schemas.
> ---
> Hi,
>
> I have noticed that dconf-editor by default crashes as it has no
> schemas. This is probably undesired, as most users install dconf-
> editor to edit settings on gnome. But there is no indication that the
> actual error is missing glib:bin. The issue isn't fixed by moving
> glib:bin to inputs. It has to be in propagated inputs.
>
> Kind regards,
> Maya
I am fairly certain that by default, dconf-editor does not crash when
using gnome-desktop-service-type (i.e. the "default" configuration).
Now fair enough, it might still break in the way you described *outside
of gnome*, but in any case, propagating inputs is no solution and in
this case, you're breaking cross-compilation to rely on a side effect.
The package you do want is most likely gsettings-desktop-schemas, and I
think it ought to be possible to fix dconf-editor without propagating
it.

Cheers
M
M
Mája Tomášek wrote on 4 Feb 2023 11:50
877cwxaelx.fsf@disroot.org
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (3 lines)
> I am fairly certain that by default, dconf-editor does not crash when
> using gnome-desktop-service-type (i.e. the "default" configuration).

I'm afraid that it does. At least on my system it does. I use gnome-desktop-service-type.

Toggle quote (4 lines)
> Now fair enough, it might still break in the way you described *outside
> of gnome*, but in any case, propagating inputs is no solution and in
> this case, you're breaking cross-compilation to rely on a side effect.

I understand that it is not an optimal solution. I didn't like it
either, but I didn't find any other solution

Toggle quote (2 lines)
> The package you do want is most likely gsettings-desktop-schemas

I have now tried the following:

---
$ guix shell --pure gsettings-desktop-schemas dconf-editor
$ dconf-editor

(dconf-editor:4990): dbind-WARNING **: 11:46:30.355: AT-SPI: Error retrieving accessibility bus address: org.freedesktop.DBus.Error.ServiceUnknown: The name org.a11y.Bus was not provided by any .service files

(dconf-editor:4990): GLib-GIO-ERROR **: 11:46:30.369: No GSettings schemas are installed on the system
zsh: trace trap dconf-editor
---

and
---
$ guix shell gsettings-desktop-schemas dconf-editor
$ dconf-editor

(dconf-editor:5048): GLib-GIO-ERROR **: 11:47:58.518: Settings schema 'ca.desrt.dconf-editor.Lib' is not installed
zsh: trace trap dconf-editor
---

Both resulting in an error. Yes the error is different but I'm not
knowledgeable enough to fix this issue.

Toggle quote (2 lines)
> think it ought to be possible to fix dconf-editor without propagating

That would be great!

Regards,
Maya
L
L
Liliana Marie Prikler wrote on 4 Feb 2023 18:26
debc6a3a29f86ab6be45776f8783c42f0422a09c.camel@gmail.com
Am Samstag, dem 04.02.2023 um 11:50 +0100 schrieb Mája Tomášek:
Toggle quote (8 lines)
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>
> > I am fairly certain that by default, dconf-editor does not crash
> > when using gnome-desktop-service-type (i.e. the "default"
> > configuration).
>
> I'm afraid that it does. At least on my system it does. I use gnome-
> desktop-service-type.
I just tested it in a VM and for me it behaves as I would expect. Now,
you could have corrupt dconf data that make it act up (try with
~/.config/dconf and ~/.cache/dconf moved to different locations) or a
corrupt dconf/gsettings package (try guix build --repair), but as far
as gnome-desktop-service-type is concerned, this is not an expected
error mode with intact packages.

Toggle quote (1 lines)
>
Cheers
M
M
Mája Tomášek wrote on 11 Feb 2023 15:14
87edqw47c0.fsf@disroot.org
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (2 lines)
> I just tested it in a VM and for me it behaves as I would expect.

Well, that means that it really is issue on my side then.

Toggle quote (4 lines)
> you could have corrupt dconf data that make it act up (try with
> ~/.config/dconf and ~/.cache/dconf moved to different locations) or a
> corrupt dconf/gsettings package (try guix build --repair),

I have tried all of them, but the issue persists. At least if it isn't
a global issue, I'm happy.

Cheers
M
M
Maxim Cournoyer wrote on 22 Mar 2023 03:01
Re: bug#61103: (no subject)
(name . Mája Tomášek)(address . maya.tomasek@disroot.org)
875yatk0hs.fsf_-_@gmail.com
Hi,

Mája Tomášek <maya.tomasek@disroot.org> writes:

Toggle quote (48 lines)
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>
>> I am fairly certain that by default, dconf-editor does not crash when
>> using gnome-desktop-service-type (i.e. the "default" configuration).
>
> I'm afraid that it does. At least on my system it does. I use gnome-desktop-service-type.
>
>> Now fair enough, it might still break in the way you described *outside
>> of gnome*, but in any case, propagating inputs is no solution and in
>> this case, you're breaking cross-compilation to rely on a side effect.
>
> I understand that it is not an optimal solution. I didn't like it
> either, but I didn't find any other solution
>
>> The package you do want is most likely gsettings-desktop-schemas
>
> I have now tried the following:
>
> ---
> $ guix shell --pure gsettings-desktop-schemas dconf-editor
> $ dconf-editor
>
> (dconf-editor:4990): dbind-WARNING **: 11:46:30.355: AT-SPI: Error
> retrieving accessibility bus address:
> org.freedesktop.DBus.Error.ServiceUnknown: The name org.a11y.Bus was
> not provided by any .service files
>
> (dconf-editor:4990): GLib-GIO-ERROR **: 11:46:30.369: No GSettings schemas are installed on the system
> zsh: trace trap dconf-editor
> ---
>
> and
> ---
> $ guix shell gsettings-desktop-schemas dconf-editor
> $ dconf-editor
>
> (dconf-editor:5048): GLib-GIO-ERROR **: 11:47:58.518: Settings schema
> 'ca.desrt.dconf-editor.Lib' is not installed
> zsh: trace trap dconf-editor
> ---
>
> Both resulting in an error. Yes the error is different but I'm not
> knowledgeable enough to fix this issue.
>
>> think it ought to be possible to fix dconf-editor without propagating
>
> That would be great!

I don't see anything to fix; dconf-editor complains an throws an error
when there are no schemas found. Schemas are found via a
native-search-path defined on glib (XDG_DATA_DIRS).

Fixing #22138 would probably help to some degree but otherwise that's
normal Guix behavior, I think. Thus, closing.

--
Thanks,
Maxim
Closed
?