[PATCH] gnu: Add r-castor.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal
N
N
Navid Afkhami wrote on 27 Jan 2023 16:05
(address . guix-patches@gnu.org)
20230127150517.33849-1-navid.afkhami@mdc-berlin.de
* gnu/packages/cran.scm (r-castor): New variable.
---
gnu/packages/cran.scm | 28 +++++++++++++++++++++++++++-
1 file changed, 27 insertions(+), 1 deletion(-)

Toggle diff (48 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index dce349890a..51c9230156 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -35,7 +35,7 @@
;;; Copyright © 2020 Aniket Patil <aniket112.patil@gmail.com>
;;; Copyright © 2021 Marcel Schilling <marcel.schilling@uni-luebeck.de>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
-;;; Copyright © 2022 Navid Afkhami <navid.afkhami@mdc-berlin.de>
+;;; Copyright © 2022,2023 Navid Afkhami <navid.afkhami@mdc-berlin.de>
;;; Copyright © 2022 Greg Hogan <code@greghogan.com>
;;;
;;; This file is part of GNU Guix.
@@ -256,6 +256,32 @@ (define-public r-cachem
automatically pruning objects to maintain the constraints.")
(license license:expat)))
+(define-public r-castor
+ (package
+ (name "r-castor")
+ (version "1.7.6")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "castor" version))
+ (sha256
+ (base32
+ "1qbndwmzzpkzgiah0hgid9z5f9iv2j53d515bjcci1591gx1fk36"))))
+ (properties `((upstream-name . "castor")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-matrix r-naturalsort r-rcpp r-rspectra))
+ (home-page "https://cran.r-project.org/package=castor")
+ (synopsis "Efficient phylogenetics on large trees")
+ (description
+ "This tool analyses on massive phylogenies comprising up to millions of tips.
+Functions include pruning, rerooting, calculation of most-recent
+common ancestors, calculating distances from the tree root and calculating
+pairwise distances. In addition, This tool takes care of Calculation of
+phylogenetic signal and mean trait depth (trait conservatism), ancestral state
+reconstruction and hidden character prediction of discrete characters, simulating
+and fitting models of trait evolution, fitting and simulating diversification
+models, dating trees, comparing trees, and reading/writing trees in Newick format.")
+ (license license:gpl2+)))
+
(define-public r-collections
(package
(name "r-collections")
--
2.34.1
R
R
Ricardo Wurmus wrote on 27 Jan 2023 20:10
(address . 61097-done@debbugs.gnu.org)
87k017bxna.fsf@elephly.net
Applied with commit 5ebbedea5803fcee3d99eb15bacca838bf4c124d, thank you!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61097@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61097
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch