[PATCH] gnu: Add staticsite.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Vagrant Cascadian
Severity
normal

Debbugs page

Vagrant Cascadian wrote 2 years ago
(address . guix-patches@gnu.org)
871qng69w8.fsf@contorta
From 04619d89e5f3a75f108c082dcd1c390d0bd3f82f Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Thu, 26 Jan 2023 15:43:17 -0800
Subject: [PATCH] gnu: Add staticsite.

* gnu/packages/python-xyz.scm (staticsite): New variable.
---
gnu/packages/python-xyz.scm | 51 +++++++++++++++++++++++++++++++++++++
1 file changed, 51 insertions(+)

Toggle diff (64 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b14c4ff0f3..a5be587603 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31744,6 +31744,57 @@ (define-public shrinkwrap
path.")
(license license:expat)))
+(define-public staticsite
+ (package
+ (name "staticsite")
+ (version "2.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/spanezz/staticsite")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1rhr25xydvnlrrcz389j3f6nknmczm5x11cagrji1qww70piwy08"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'use-themes-in-output
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "staticsite/global_settings.py"
+ (("/usr/share/staticsite")
+ out)))))
+ (add-after 'install 'install-themes
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((themedir (string-append (assoc-ref outputs
+ "out")
+ "/themes")))
+ (copy-recursively "themes" themedir)))))))
+ (native-inputs (list python-pyinotify
+ python-markdown
+ python-docutils
+ python-jinja2
+ python-pytz
+ python-dateutil
+ python-pyyaml
+ python-pillow
+ python-slugify
+ python-ruamel.yaml
+ tzdata-for-tests
+ python-tornado
+ perl-image-exiftool))
+ (home-page "https://github.com/spanezz/staticsite")
+ (synopsis "Static site generator")
+ (description "Static site generator based on markdown and jinja2.
+Features:
+ - themable
+ - free content structure
+ - hugo-style archetypes and front matter
+ - live preview server")
+ (license (list license:gpl3+ license:expat))))
+
(define-public python-pymonad
(package
(name "python-pymonad")
--
2.39.0
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCY9MpZwAKCRDcUY/If5cW
qu/nAP9smV9IsunQZMeqgQigfOUeTESSuZCVQSI3yS+U4vItkAEA16zM9DQZ3IgU
N2e56LaBGT621hgqnz4Zrhd43tZHvgY=
=rrqA
-----END PGP SIGNATURE-----

Nicolas Goaziou wrote 2 years ago
(name . Vagrant Cascadian)(address . vagrant@debian.org)(address . 61089-done@debbugs.gnu.org)
87pma0o3b7.fsf@nicolasgoaziou.fr
Hello,

Vagrant Cascadian <vagrant@debian.org> writes:

Toggle quote (4 lines)
> Subject: [PATCH] gnu: Add staticsite.
>
> * gnu/packages/python-xyz.scm (staticsite): New variable.

Applied (with G-exps, and inputs ordered alphabetically). Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61089@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61089
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help