[PATCH] gnu: Add x11-ssh-askpass.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Simon Streit
Owner
unassigned
Submitted by
Simon Streit
Severity
normal

Debbugs page

Simon Streit wrote 2 years ago
(address . guix-patches@gnu.org)(name . Simon Streit)(address . simon@netpanic.org)
20230126222432.10812-1-simon@netpanic.org
* gnu/packages/ssh.scm (x11-ssh-askpass): New variable.
---
gnu/packages/ssh.scm | 59 ++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 59 insertions(+)

Toggle diff (76 lines)
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 2f6874f811..bd2f024689 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
+;;; Copyright © 2023 Simon Streit <simon@netpanic.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -940,3 +941,61 @@ (define-public webssh
@item Modern browsers are supported.
@end itemize")
(license license:expat)))
+
+(define-public x11-ssh-askpass
+ (package
+ (name "x11-ssh-askpass")
+ (version "1.2.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ ;; The project home page seams to be offline.
+ (uri (string-append "https://pkgs.fedoraproject.org/repo/pkgs/openssh/"
+ name "-" version ".tar.gz"
+ "/8f2e41f3f7eaa8543a2440454637f3c3/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32 "124c1frwvdmg4nv8xqv435ibjhj2y8xc1bmfr6i8a8g75b1y63b2"))))
+ (build-system gnu-build-system)
+ (native-inputs (list imake))
+ (inputs (list libxt))
+ (arguments
+ `(#:make-flags
+ (let ((out (assoc-ref %outputs "out")))
+ (list (string-append "BINDIR=" out "/libexec")
+ (string-append "MANDIR=" out "/share/man")))
+ #:tests? #f
+ #:configure-flags (list (string-append "--mandir="
+ "/usr/share/man/test")
+ (string-append "--libexecdir="
+ "/usr/lib/ssh/test")
+ (string-append "--with-app-defaults-dir="
+ "/usr/share/X11/app-defaults/test"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'configure 'xmkmf
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((imake (assoc-ref inputs "imake"))
+ (out (assoc-ref outputs "out")))
+ (invoke "xmkmf")
+ (substitute* "Makefile"
+ ;; These imake variables somehow remain undefined
+ (("DefaultGcc2[[:graph:]]*Opt") "-O2")
+ ;; Reset a few variable defaults that are set in imake templates
+ ((imake) out)
+ (("(MANPATH = )[[:graph:]]*" _ front)
+ (string-append front out "/share/man"))))))
+ (add-after 'xmkmf 'make-includes
+ (lambda _
+ (invoke "make" "includes")))
+ (add-after 'install 'install/doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (lambda _
+ (invoke "make"
+ (string-append "MANDIR=" out "/share/man")
+ "install.man"))))))))
+ (home-page "http://www.jmknoble.net/software/x11-ssh-askpass/")
+ (synopsis "Lightweight passphrase dialog for SSH")
+ (description "An X11-based pass-phrase dialog for use with OpenSSH.")
+ (license license:gpl2+)))
--
2.39.1
Nicolas Goaziou wrote 2 years ago
(name . Simon Streit)(address . simon@netpanic.org)(address . 61087-done@debbugs.gnu.org)
87lekoo37e.fsf@nicolasgoaziou.fr
Hello,

Simon Streit <simon@netpanic.org> writes:

Toggle quote (2 lines)
> * gnu/packages/ssh.scm (x11-ssh-askpass): New variable.

Applied (with G-exps, and a description with full sentences). Thank you.

Note that home page does not exist. Do you have an idea about
a replacement for it?

Regards,
--
Nicolas Goaziou
Closed
Simon Streit wrote 2 years ago
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 61087-done@debbugs.gnu.org)
ygu1qmgw1ej.fsf@netpanic.org
Hello Nicolas,

Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

Toggle quote (3 lines)
> Applied (with G-exps, and a description with full sentences). Thank
> you.

Thank you!

Toggle quote (3 lines)
> Note that home page does not exist. Do you have an idea about a
> replacement for it?

There hasn't been a release since at least Debian Sarge [1, 2].

Sadly no. I presume the project has been abandoned as it has not
received an update in a long time. Maybe since at least Debian Sarge
[1, 2].

I looked at some packages from other distributions and they still have a
reference to the original home-page and source the package from, as Arch
has done, from fedoraproject.org. Which is why I also sourced the
package from too.

I don't know of a fork that is currently extending the code either.


Kind regards
Simon

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61087@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61087
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help