gnu: packages: Add guile-simple-iterators.

  • Done
  • quality assurance status badge
Details
2 participants
  • J. Sims
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
J. Sims
Severity
normal

Debbugs page

J. Sims wrote 2 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
3jq6J-nEKJum-SbtMkcZRppVnmkz1UHeXuyFOjPr3QSdPe0FGOIAJx8wffakj447SlmPIYle9jgAISNTa-iUK_rz5esDvqtkM0E9nxu64vE=@protonmail.com
Hello,

guile-simple-iterators is a collection of macros to provide iteration inspired by Racket in Guile. I use them and find them delightful, so I thought other Guix users would appreciate ready access to them.

Thanks,
Juli
Attachment: file
From 654847381613f558d80ad8fffb89b1361181d724 Mon Sep 17 00:00:00 2001
From: Juliana Sims <jtsims@protonmail.com>
Date: Wed, 25 Jan 2023 21:07:54 -0600
Subject: [PATCH] gnu: packages: Add guile-simple-iterators.

* gnu/packages/guile-xyz.scm (guile-simple-iterators): Add guile-simple-iterators.
---
gnu/packages/guile-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 0befff1576..340b2824c2 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -2600,6 +2600,41 @@ (define-public guile-lib
;; details.
(license license:gpl3+)))
+(define-public guile-simple-iterators
+ (let ((commit "50f16a2b2aa57e657e52e19fb3c35bdc182cfa36")
+ (revision "0"))
+ (package
+ (name "guile-simple-iterators")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://gitlab.com/dustyweb/guile-simple-iterators")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1m1wirlnfwmp5a4rpszd5qsbwabz4ji033w6p2714p1r524ylah8"))))
+ (build-system guile-build-system)
+ (native-inputs (list guile-3.0))
+ (home-page "https://gitlab.com/dustyweb/guile-simple-iterators")
+ (synopsis "Simple iterators for Guile")
+ (description
+ "This is a collection of iteration macros for Guile. They are inspired by
+@code{racket}'s family of iterators. Specifically, the following iterators are
+available:
+@itemize
+@item @code{for}
+@item @code{for/map}
+@item @code{for/c}
+@item @code{for/fold}
+@item @code{for/fold-right}
+@item @code{for/folder}
+@item @code{folder}
+@end itemize")
+ (license license:expat))))
+
(define-public guile2.0-lib
(package
(inherit guile-lib)

base-commit: a84ceaa8b2e8e121957afea1d1d3fe7c8141cb8d
--
2.39.1
Liliana Marie Prikler wrote 2 years ago
ae3c651242e7285702e0c46ea7c972609418ddf7.camel@gmail.com
Am Donnerstag, dem 26.01.2023 um 03:16 +0000 schrieb J. Sims:

Toggle quote (18 lines)
> +(define-public guile-simple-iterators
> + (let ((commit "50f16a2b2aa57e657e52e19fb3c35bdc182cfa36")
> + (revision "0"))
> + (package
> + (name "guile-simple-iterators")
> + (version (git-version "0.0.0" revision commit))
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url
> +
> "https://gitlab.com/dustyweb/guile-simple-iterators")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> +
> "1m1wirlnfwmp5a4rpszd5qsbwabz4ji033w6p2714p1r524ylah8"))))
It's better to dedent this a little so that url can fit on a line.
Toggle quote (21 lines)
> + (build-system guile-build-system)
> + (native-inputs (list guile-3.0))
> + (home-page
> "https://gitlab.com/dustyweb/guile-simple-iterators")
> + (synopsis "Simple iterators for Guile")
> + (description
> + "This is a collection of iteration macros for Guile. They are
> inspired by
> +@code{racket}'s family of iterators. Specifically, the following
> iterators are
> +available:
> +@itemize
> +@item @code{for}
> +@item @code{for/map}
> +@item @code{for/c}
> +@item @code{for/fold}
> +@item @code{for/fold-right}
> +@item @code{for/folder}
> +@item @code{folder}
> +@end itemize")
> + (license license:expat))))
License should be asl2.0.

I'll wait for the CI results and schedule this towards pushing it on
February 5th (with adjustments for the above points).

Cheers
J. Sims wrote 2 years ago
P5Vw3b_-u1U9ZyGg9_CMuE6Q3SjpaGG6U2YfuhID4xwKY_dyWYoaQu9RF-fVF7MbwC9l2s8iwr2h8gVGo-gEBMOfjCXbIlonh_9u_wiSnBM=@protonmail.com
Hi,

On Saturday, January 28th, 2023 at 00:32, Liliana Marie Prikler <liliana.prikler@gmail.com> wrote:

Toggle quote (3 lines)
> I'll wait for the CI results and schedule this towards pushing it on
> February 5th (with adjustments for the above points).

Just to clarify, do I need to make the adjustments or are you making them before pushing? Either way is fine; the wording is just ambiguous.

Toggle quote (2 lines)
> It's better to dedent this a little so that url can fit on a line.

I'm not sure I understand what you mean. Dedent the hash? And how so?

Also, thanks for catching the license; I'm not sure why my brain read "Apache Software License 2.0" and went, "Ah, yeah, expat" XD

Thanks,
Juli
J. Sims wrote 2 years ago
tRQdesjVCBattiTmu7-HbadbfdoarfgQeDzkylAdcVgajsT8K5bWQrL5Vgl8p6USpq8QoY5q5EIFpyFpOSxfzWgTptt25IxhW8NcZ6TaQo4=@protonmail.com
On Saturday, January 28th, 2023 at 11:58, J. Sims <jtsims@protonmail.com> wrote:

Toggle quote (2 lines)
> I'm not sure I understand what you mean. Dedent the hash? And how so?

Scratch that, I figured it out. I really need to start double-checking guix style's work...

I've gone ahead and written up the patch, too, so just ignore my previous message.

Thanks,
Juli
From 4a978ce60c1115c01f94df76a9166d3cd3ab71e5 Mon Sep 17 00:00:00 2001
From: Juliana Sims <jtsims@protonmail.com>
Date: Wed, 25 Jan 2023 21:07:54 -0600
Subject: [PATCH] gnu: packages: Add guile-simple-iterators.

* gnu/packages/guile-xyz.scm (guile-simple-iterators): Add guile-simple-iterators.
---
gnu/packages/guile-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (57 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 0befff1576..8e33ef5bc7 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -46,6 +46,7 @@
;;; Copyright © 2022 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2022 Evgeny Pisemsky <evgeny@pisemsky.com>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2023 Juliana Sims <jtsims@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2600,6 +2601,40 @@ (define-public guile-lib
;; details.
(license license:gpl3+)))
+(define-public guile-simple-iterators
+ (let ((commit "50f16a2b2aa57e657e52e19fb3c35bdc182cfa36")
+ (revision "0"))
+ (package
+ (name "guile-simple-iterators")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/dustyweb/guile-simple-iterators")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1m1wirlnfwmp5a4rpszd5qsbwabz4ji033w6p2714p1r524ylah8"))))
+ (build-system guile-build-system)
+ (native-inputs (list guile-3.0))
+ (home-page "https://gitlab.com/dustyweb/guile-simple-iterators")
+ (synopsis "Simple iterators for Guile")
+ (description
+ "This is a collection of iteration macros for Guile. They are inspired by
+@code{racket}'s family of iterators. Specifically, the following iterators are
+available:
+@itemize
+@item @code{for}
+@item @code{for/map}
+@item @code{for/c}
+@item @code{for/fold}
+@item @code{for/fold-right}
+@item @code{for/folder}
+@item @code{folder}
+@end itemize")
+ (license license:asl2))))
+
(define-public guile2.0-lib
(package
(inherit guile-lib)

base-commit: a84ceaa8b2e8e121957afea1d1d3fe7c8141cb8d
--
2.39.1
Liliana Marie Prikler wrote 2 years ago
21f6c20043359c971281aa460d771e2865481274.camel@gmail.com
Am Samstag, dem 28.01.2023 um 17:58 +0000 schrieb J. Sims:
Toggle quote (12 lines)
> Hi,
>
> On Saturday, January 28th, 2023 at 00:32, Liliana Marie Prikler
> <liliana.prikler@gmail.com> wrote:
>
> > I'll wait for the CI results and schedule this towards pushing it
> > on
> > February 5th (with adjustments for the above points).
>
> Just to clarify, do I need to make the adjustments or are you making
> them before pushing? Either way is fine; the wording is just
> ambiguous.
They're small changes I can do as a reviewer ;)

Toggle quote (3 lines)
> > It's better to dedent this a little so that url can fit on a line.
>
> I'm not sure I understand what you mean. Dedent the hash? And how so?
No, dedent the entire origin.

Cheers
Liliana Marie Prikler wrote 2 years ago
fb0b7281592d794aa187742c45456d4dfe6a6902.camel@gmail.com
Am Samstag, dem 28.01.2023 um 19:26 +0100 schrieb Liliana Marie
Prikler:
Toggle quote (20 lines)
> Am Samstag, dem 28.01.2023 um 17:58 +0000 schrieb J. Sims:
> > Hi,
> >
> > On Saturday, January 28th, 2023 at 00:32, Liliana Marie Prikler
> > <liliana.prikler@gmail.com> wrote:
> >
> > > I'll wait for the CI results and schedule this towards pushing it
> > > on February 5th (with adjustments for the above points).
> >
> > Just to clarify, do I need to make the adjustments or are you
> > making them before pushing? Either way is fine; the wording is just
> > ambiguous.
> They're small changes I can do as a reviewer ;)
>
> > > It's better to dedent this a little so that url can fit on a
> > > line.
> >
> > I'm not sure I understand what you mean. Dedent the hash? And how
> > so?
> No, dedent the entire origin.
Aaaand it's pushed.

Thanks
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61070@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61070
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help