[PATCH] gnu: Add emacs-ein.

  • Done
  • quality assurance status badge
Details
2 participants
  • Cayetano Santos
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Cayetano Santos
Severity
normal
C
C
Cayetano Santos wrote on 25 Jan 2023 21:12
(address . guix-patches@gnu.org)(name . Cayetano Santos)(address . csantosb@inventati.org)
5522f1b746711316cd8a5a4005baf3233781a930.1674677551.git.csantosb@inventati.org
* gnu/packages/emacs-xyz.scm (emacs-ein): New variable.
---
gnu/packages/emacs-xyz.scm | 42 ++++++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)

Toggle diff (57 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index dc378581f5..30633bd52c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -34326,6 +34326,48 @@ (define-public emacs-code-cells
execute code split into cells according to certain magic comments.")
(license license:gpl3+))))
+(define-public emacs-ein
+ (package
+ (name "emacs-ein")
+ (version "20220911")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/millejoh/emacs-ipython-notebook")
+ (commit "b2410dc96f61aa806a7934099d8f1e40c8f6ca18")))
+ (sha256
+ (base32
+ "02392bxl0msda58cls0i79mzqjs73x39czx0mlb0sg2vxp84gy15"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'move-source-files
+ (lambda _
+ (let ((el-files (find-files "./lisp" ".*\\.el$")))
+ (for-each (lambda (f)
+ (rename-file f (basename f)))
+ el-files)))))))
+ (propagated-inputs (list emacs-websocket
+ emacs-anaphora
+ emacs-request
+ emacs-deferred
+ emacs-polymode
+ emacs-dash
+ emacs-with-editor))
+ (home-page "https://github.com/millejoh/emacs-ipython-notebook")
+ (synopsis "Jupyter client for all languages")
+ (description
+ "The Emacs IPython Notebook (EIN) package provides a Jupyter Notebook
+client and integrated REPL (like SLIME) in Emacs. EIN improves notebook
+editing by allowing you to use Emacs. It also expose IPython features such as
+code evaluation, object inspection and code completion. These features can be
+accessed anywhere in Emacs and improve Python code editing and reading in
+general in Emacs.")
+ (license license:gpl3+)))
+
(define-public emacs-kibit-helper
(package
(name "emacs-kibit-helper")

base-commit: 968b882f55c4d1009e62c603a860edfaee1609ad
--
2.39.1
N
N
Nicolas Goaziou wrote on 27 Jan 2023 09:47
(name . Cayetano Santos via Guix-patches via)(address . guix-patches@gnu.org)
87pmb0l5xz.fsf@nicolasgoaziou.fr
Hello,

Cayetano Santos via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-ein): New variable.

Thank you.

Toggle quote (8 lines)
> + (propagated-inputs (list emacs-websocket
> + emacs-anaphora
> + emacs-request
> + emacs-deferred
> + emacs-polymode
> + emacs-dash
> + emacs-with-editor))

Could you order propagated inputs alphabetically?

Also, upstream provides tests. Is it feasible to run them, too?

Regards,
--
Nicolas Goaziou
C
C
Cayetano Santos wrote on 27 Jan 2023 11:02
[PATCH v2] gnu: Add emacs-ein.
(address . 61065@debbugs.gnu.org)(name . Cayetano Santos)(address . csantosb@inventati.org)
4bb02cb0d7b3be8181fb0b8197f13795f8a110e6.1674813757.git.csantosb@inventati.org
* gnu/packages/emacs-xyz.scm (emacs-ein): New variable.
---
gnu/packages/emacs-xyz.scm | 50 ++++++++++++++++++++++++++++++++++++++
1 file changed, 50 insertions(+)

Toggle diff (65 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index dc378581f5..087087444f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -34326,6 +34326,56 @@ (define-public emacs-code-cells
execute code split into cells according to certain magic comments.")
(license license:gpl3+))))
+(define-public emacs-ein
+ (package
+ (name "emacs-ein")
+ (version "20220911")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/millejoh/emacs-ipython-notebook")
+ (commit "b2410dc96f61aa806a7934099d8f1e40c8f6ca18")))
+ (sha256
+ (base32
+ "02392bxl0msda58cls0i79mzqjs73x39czx0mlb0sg2vxp84gy15"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:tests? #t
+ #:test-command
+ #~(list "emacs" "-Q" "--batch"
+ "-L" "test"
+ "--load" "test/testein-loader.el")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'move-source-files
+ (lambda _
+ (let ((el-files (find-files "./lisp" ".*\\.el$")))
+ (for-each (lambda (f)
+ (rename-file f (basename f)))
+ el-files)))))))
+ (native-inputs
+ (list emacs-f emacs-mocker))
+ (propagated-inputs (list emacs-anaphora
+ emacs-dash
+ emacs-deferred
+ emacs-polymode
+ emacs-request
+ emacs-websocket
+ emacs-with-editor))
+ (home-page "https://github.com/millejoh/emacs-ipython-notebook")
+ (synopsis "Jupyter client for all languages")
+ (description
+ "The Emacs IPython Notebook (EIN) package provides a Jupyter Notebook
+client and integrated REPL (like SLIME) in Emacs. EIN improves notebook
+editing by allowing you to use Emacs. It also expose IPython features such as
+code evaluation, object inspection and code completion. These features can be
+accessed anywhere in Emacs and improve Python code editing and reading in
+general in Emacs.")
+ (license license:gpl3+)))
+
(define-public emacs-kibit-helper
(package
(name "emacs-kibit-helper")

base-commit: 968b882f55c4d1009e62c603a860edfaee1609ad
--
2.39.1
N
N
Nicolas Goaziou wrote on 27 Jan 2023 23:08
(name . Cayetano Santos via Guix-patches via)(address . guix-patches@gnu.org)
87v8krk4un.fsf@nicolasgoaziou.fr
Hello,

Cayetano Santos via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-ein): New variable.

Thank you. I applied your patch with the following changes.


Toggle quote (12 lines)
> +(define-public emacs-ein
> + (package
> + (name "emacs-ein")
> + (version "20220911")
> + (source
> + (origin
> + (method git-fetch)
> + (uri
> + (git-reference
> + (url "https://github.com/millejoh/emacs-ipython-notebook")
> + (commit "b2410dc96f61aa806a7934099d8f1e40c8f6ca18")))

I added

(file-name (git-file-name name version))

Toggle quote (29 lines)
> + (sha256
> + (base32
> + "02392bxl0msda58cls0i79mzqjs73x39czx0mlb0sg2vxp84gy15"))))
> + (build-system emacs-build-system)
> + (arguments
> + (list
> + #:tests? #t
> + #:test-command
> + #~(list "emacs" "-Q" "--batch"
> + "-L" "test"
> + "--load" "test/testein-loader.el")
> + #:phases
> + #~(modify-phases %standard-phases
> + (add-after 'unpack 'move-source-files
> + (lambda _
> + (let ((el-files (find-files "./lisp" ".*\\.el$")))
> + (for-each (lambda (f)
> + (rename-file f (basename f)))
> + el-files)))))))
> + (native-inputs
> + (list emacs-f emacs-mocker))
> + (propagated-inputs (list emacs-anaphora
> + emacs-dash
> + emacs-deferred
> + emacs-polymode
> + emacs-request
> + emacs-websocket
> + emacs-with-editor))

I added a newline character after "propagated-inputs".

Toggle quote (8 lines)
> + (synopsis "Jupyter client for all languages")
> + (description
> + "The Emacs IPython Notebook (EIN) package provides a Jupyter Notebook
> +client and integrated REPL (like SLIME) in Emacs. EIN improves notebook
> +editing by allowing you to use Emacs. It also expose IPython features such as
> +code evaluation, object inspection and code completion. These features can be

I added a missing space before "These features".

Regards,
--
Nicolas Goaziou
Closed
?