[PATCH] Fix asymetric mutex locking when joining thread.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Olivier Dion
Owner
unassigned
Submitted by
Olivier Dion
Severity
normal
O
O
Olivier Dion wrote on 25 Jan 2023 16:24
(address . bug-guile@gnu.org)(name . Olivier Dion)(address . olivier-dion@proton.me)
20230125152403.19091-1-olivier.dion@polymtl.ca
From: Olivier Dion <olivier-dion@proton.me>

If `join-thread' timeout, the thread mutex is not unlocked,
resulting in deadlock to the next call to it or deadlock of the
thread itself when it terminates.

Thus, always unlock the mutex.

Fix: #55356

* module/ice-9/threads.scm (join-thread): Always unlock thread mutex.
---
module/ice-9/threads.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/module/ice-9/threads.scm b/module/ice-9/threads.scm
index c42bd266f..962caee70 100644
--- a/module/ice-9/threads.scm
+++ b/module/ice-9/threads.scm
@@ -197,7 +197,9 @@ terminates, unless the target @var{thread} has already terminated."
(wait-condition-variable cv mutex timeout)
(wait-condition-variable cv mutex))
(lp))
- (else timeoutval))))))
+ (else
+ (unlock-mutex mutex)
+ timeoutval))))))
(define* (try-mutex mutex)
"Try to lock @var{mutex}. If the mutex is already locked, return
--
2.39.1
O
O
Olivier Dion wrote on 25 Jan 22:45 +0100
[PATCH v2] Fix asymetric mutex locking when joining thread.
(address . 61058@debbugs.gnu.org)(name . Olivier Dion)(address . olivier.dion@polymtl.ca)
20240125214547.3951-1-olivier.dion@polymtl.ca
If `join-thread' timeout, the thread mutex is not unlocked, resulting in
deadlock to the next call to it or deadlock of the thread itself when it
terminates.

Thus, always unlock the mutex.

Fix: #55356

* module/ice-9/threads.scm (join-thread): Always unlock thread mutex.
* test-suite/tests/threads.test (join-thread): New test to ensure the
mutex is released
---
module/ice-9/threads.scm | 4 +++-
test-suite/tests/threads.test | 13 ++++++++++++-
2 files changed, 15 insertions(+), 2 deletions(-)

Toggle diff (41 lines)
diff --git a/module/ice-9/threads.scm b/module/ice-9/threads.scm
index 048d8b085..a1e43b9fa 100644
--- a/module/ice-9/threads.scm
+++ b/module/ice-9/threads.scm
@@ -204,7 +204,9 @@ terminates, unless the target @var{thread} has already terminated."
(wait-condition-variable cv mutex timeout)
(wait-condition-variable cv mutex))
(lp))
- (else timeoutval))))))
+ (else
+ (unlock-mutex mutex)
+ timeoutval))))))
(define* (try-mutex mutex)
"Try to lock @var{mutex}. If the mutex is already locked, return
diff --git a/test-suite/tests/threads.test b/test-suite/tests/threads.test
index efdf36db2..af8c8c75b 100644
--- a/test-suite/tests/threads.test
+++ b/test-suite/tests/threads.test
@@ -332,7 +332,18 @@
(sleep 2)
(system-async-mark aproc)
(join-thread other-thread)))
- #t))
+ #t)
+
+ (pass-if "do not throw exception if trying to join after timeout"
+ (let ((other-thread (begin-thread (pause))))
+ (dynamic-wind
+ (const #f)
+ (lambda ()
+ (join-thread other-thread 1)
+ (join-thread other-thread 1)
+ #t)
+ (lambda ()
+ (cancel-thread other-thread))))))
;;
;; thread cancellation
--
2.41.0
L
L
Ludovic Courtès wrote on 25 Jan 23:14 +0100
(name . Olivier Dion)(address . olivier.dion@polymtl.ca)
87fryloybh.fsf@gnu.org
Hello,

Olivier Dion <olivier.dion@polymtl.ca> skribis:

Toggle quote (12 lines)
> If `join-thread' timeout, the thread mutex is not unlocked, resulting in
> deadlock to the next call to it or deadlock of the thread itself when it
> terminates.
>
> Thus, always unlock the mutex.
>
> Fix: #55356
>
> * module/ice-9/threads.scm (join-thread): Always unlock thread mutex.
> * test-suite/tests/threads.test (join-thread): New test to ensure the
> mutex is released

Pushed as 455ee49f5573baa1bc5237a8d49083ce588a13ee with a ‘NEWS’ entry
and an additional comment in the test.

Thanks!

Ludo’.
Closed
?