[PATCH 0/3] gnu: flashrom: Update to 1.2.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Hilton Chain
  • Ludovic Courtès
Owner
unassigned
Submitted by
Hilton Chain
Severity
normal
H
H
Hilton Chain wrote on 25 Jan 2023 13:02
(address . guix-patches@gnu.org)
87r0vi3jr3.wl-hako@ultrarare.space
*** BLURB HERE ***

Hilton Chain (3):
gnu: flashrom: Update to 1.2.1.
gnu: flashrom: Use G-Expressions.
gnu: flashrom: Wrap PATH to find dmidecode.

gnu/local.mk | 1 -
gnu/packages/flashing-tools.scm | 44 ++++-----
.../flashrom-fix-building-on-aarch64.patch | 89 -------------------
3 files changed, 18 insertions(+), 116 deletions(-)
delete mode 100644 gnu/packages/patches/flashrom-fix-building-on-aarch64.patch


base-commit: ba1b61a72d56600e7c6f9c490129e95ab9ba0c9e
--
2.39.1
H
H
Hilton Chain wrote on 25 Jan 2023 13:04
[PATCH 1/3] gnu: flashrom: Update to 1.2.1.
(address . 61057@debbugs.gnu.org)
87o7qm3jml.wl-hako@ultrarare.space
* gnu/packages/patches/flashrom-fix-building-on-aarch64.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
* gnu/packages/flashing-tools.scm (flashrom): Update to 1.2.1.
[arguments]<#:phases>: Remove 'patch-exec-paths and 'patch-type-error phases.

Actually, at least from 1.2, the exact "dmidecode" is not present in dmi.c.
---
gnu/local.mk | 1 -
gnu/packages/flashing-tools.scm | 22 +----
.../flashrom-fix-building-on-aarch64.patch | 89 -------------------
3 files changed, 3 insertions(+), 109 deletions(-)
delete mode 100644 gnu/packages/patches/flashrom-fix-building-on-aarch64.patch

Toggle diff (156 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 7fd658abac..778b725256 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1114,7 +1114,6 @@ dist_patch_DATA = \
%D%/packages/patches/firebird-riscv64-support-pt1.patch \
%D%/packages/patches/firebird-riscv64-support-pt2.patch \
%D%/packages/patches/flann-cmake-3.11.patch \
- %D%/packages/patches/flashrom-fix-building-on-aarch64.patch \
%D%/packages/patches/flatpak-fix-path.patch \
%D%/packages/patches/flatpak-unset-gdk-pixbuf-for-sandbox.patch \
%D%/packages/patches/fontconfig-cache-ignore-mtime.patch \
diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index e7165efe79..de4b477be8 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -58,7 +58,7 @@ (define-module (gnu packages flashing-tools)
(define-public flashrom
(package
(name "flashrom")
- (version "1.2")
+ (version "1.2.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -66,9 +66,7 @@ (define-public flashrom
version ".tar.bz2"))
(sha256
(base32
- "0ax4kqnh7kd3z120ypgp73qy1knz47l6qxsqzrfkd97mh5cdky71"))
- (patches
- (search-patches "flashrom-fix-building-on-aarch64.patch"))))
+ "0rbdqnxmcsr908rpjcachrx58lwl3fjm7lmvjn3rpj08xddzz9w9"))))
(build-system gnu-build-system)
(inputs (list dmidecode pciutils libusb libftdi))
(native-inputs (list pkg-config))
@@ -80,21 +78,7 @@ (define-public flashrom
#:tests? #f ; no 'check' target
#:phases
(modify-phases %standard-phases
- (delete 'configure) ; no configure script
- (add-before 'build 'patch-exec-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "dmi.c"
- (("\"dmidecode\"")
- (format #f "~S"
- (search-input-file inputs "/sbin/dmidecode"))))))
- (add-before 'build 'patch-type-error
- (lambda _
- ;; See https://github.com/flashrom/flashrom/pull/133
- (substitute* "libflashrom.c"
- (("supported_boards\\[i\\].working = binfo\\[i\\].working")
- "supported_boards[i].working = (enum flashrom_test_state)binfo[i].working")
- (("supported_chipsets\\[i\\].status = chipset\\[i\\].status")
- "supported_chipsets[i].status = (enum flashrom_test_state)chipset[i].status")))))))
+ (delete 'configure)))) ; no configure script
(home-page "https://flashrom.org/")
(synopsis "Identify, read, write, erase, and verify ROM/flash chips")
(description
diff --git a/gnu/packages/patches/flashrom-fix-building-on-aarch64.patch b/gnu/packages/patches/flashrom-fix-building-on-aarch64.patch
deleted file mode 100644
index 9f54305b47..0000000000
--- a/gnu/packages/patches/flashrom-fix-building-on-aarch64.patch
+++ /dev/null
@@ -1,89 +0,0 @@
-commit da6b3b70cb852dd8e9f9e21aef95fa83e7f7ab0d
-Author: Pyry Kontio <pyry.kontio@drasa.eu>
-Date: Mon Jul 6 12:57:35 2020 +0900
-
- Makefile: Fix building on AArch64 NixOS
-
- The parsing of the output of archtest.c produced an unexpected
- value on AArch64 NixOS. For example, the make variable ARCH was set to:
-
- ```
- bit outside of fd_set selected
- arm
- ```
-
- This made the arch and OS checks fail.
-
- This commit simplifies the parsing, making it more robust.
-
- The C files archtest.c, endiantest.c and os.h used to set the
- TARGET_OS, ARCH and ENDIAN variables, respectively, output
- the result of the test as the final line, so just extracting
- the final line and removing double quoting is enough.
-
- This commit also fixes a bug with debug_shell lacking escaping
- single quotes, which prevented using the single quote in the
- debug_shell calls. It used to work by accident before this fix;
- the line in the call happened to contain a balanced pair of double
- quotes and lacked other characters that needed escaping, which
- didn't break the debug_shell, but this was accidental and very
- brittle.
-
- Signed-off-by: Pyry Kontio <pyry.kontio@drasa.eu>
- Change-Id: Iaa4477a71e758cf9ecad2c22f3b77bc6508a3510
- Reviewed-on: https://review.coreboot.org/c/flashrom/+/43140
- Tested-by: build bot (Jenkins) <no-reply@coreboot.org>
- Reviewed-by: Angel Pons <th3fanbus@gmail.com>
-
-diff --git a/Makefile b/Makefile
-index f3f7717e..e475cbdb 100644
---- a/Makefile
-+++ b/Makefile
-@@ -83,7 +83,8 @@ dummy_for_make_3_80:=$(shell printf "Build started on %s\n\n" "$$(date)" >$(BUIL
-
- # Provide an easy way to execute a command, print its output to stdout and capture any error message on stderr
- # in the build details file together with the original stdout output.
--debug_shell = $(shell export LC_ALL=C ; { echo 'exec: export LC_ALL=C ; { $(1) ; }' >&2; { $(1) ; } | tee -a $(BUILD_DETAILS_FILE) ; echo >&2 ; } 2>>$(BUILD_DETAILS_FILE))
-+debug_shell = $(shell export LC_ALL=C ; { echo 'exec: export LC_ALL=C ; { $(subst ','\'',$(1)) ; }' >&2; \
-+ { $(1) ; } | tee -a $(BUILD_DETAILS_FILE) ; echo >&2 ; } 2>>$(BUILD_DETAILS_FILE))
-
- ###############################################################################
- # General OS-specific settings.
-@@ -106,7 +107,8 @@ endif
- # IMPORTANT: The following line must be placed before TARGET_OS is ever used
- # (of course), but should come after any lines setting CC because the line
- # below uses CC itself.
--override TARGET_OS := $(strip $(call debug_shell,$(CC) $(CPPFLAGS) -E os.h 2>/dev/null | grep -v '^\#' | grep '"' | cut -f 2 -d'"'))
-+override TARGET_OS := $(strip $(call debug_shell,$(CC) $(CPPFLAGS) -E os.h 2>/dev/null \
-+ | tail -1 | cut -f 2 -d'"'))
-
- ifeq ($(TARGET_OS), Darwin)
- override CPPFLAGS += -I/opt/local/include -I/usr/local/include
-@@ -490,8 +492,10 @@ endif
- # IMPORTANT: The following line must be placed before ARCH is ever used
- # (of course), but should come after any lines setting CC because the line
- # below uses CC itself.
--override ARCH := $(strip $(call debug_shell,$(CC) $(CPPFLAGS) -E archtest.c 2>/dev/null | grep -v '^\#' | grep '"' | cut -f 2 -d'"'))
--override ENDIAN := $(strip $(call debug_shell,$(CC) $(CPPFLAGS) -E endiantest.c 2>/dev/null | grep -v '^\#'))
-+override ARCH := $(strip $(call debug_shell,$(CC) $(CPPFLAGS) -E archtest.c 2>/dev/null \
-+ | tail -1 | cut -f 2 -d'"'))
-+override ENDIAN := $(strip $(call debug_shell,$(CC) $(CPPFLAGS) -E endiantest.c 2>/dev/null \
-+ | tail -1))
-
- # Disable the internal programmer on unsupported architectures (everything but x86 and mipsel)
- ifneq ($(ARCH)-little, $(filter $(ARCH),x86 mips)-$(ENDIAN))
-@@ -1299,12 +1303,12 @@ compiler: featuresavailable
- @printf "Target arch is "
- @# FreeBSD wc will output extraneous whitespace.
- @echo $(ARCH)|wc -w|grep -q '^[[:blank:]]*1[[:blank:]]*$$' || \
-- ( echo "unknown. Aborting."; exit 1)
-+ ( echo "unknown (\"$(ARCH)\"). Aborting."; exit 1)
- @printf "%s\n" '$(ARCH)'
- @printf "Target OS is "
- @# FreeBSD wc will output extraneous whitespace.
- @echo $(TARGET_OS)|wc -w|grep -q '^[[:blank:]]*1[[:blank:]]*$$' || \
-- ( echo "unknown. Aborting."; exit 1)
-+ ( echo "unknown (\"$(TARGET_OS)\"). Aborting."; exit 1)
- @printf "%s\n" '$(TARGET_OS)'
- ifeq ($(TARGET_OS), libpayload)
- @$(CC) --version 2>&1 | grep -q coreboot || \
--
2.39.1
H
H
Hilton Chain wrote on 25 Jan 2023 13:05
[PATCH 2/3] gnu: flashrom: Use G-Expressions.
(address . 61057@debbugs.gnu.org)
87mt663jlg.wl-hako@ultrarare.space
* gnu/packages/flashing-tools.scm (flashrom): Use G-Expressions.
---
gnu/packages/flashing-tools.scm | 17 +++++++++--------
1 file changed, 9 insertions(+), 8 deletions(-)

Toggle diff (37 lines)
diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index de4b477be8..7016d04092 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -29,6 +29,7 @@
(define-module (gnu packages flashing-tools)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix download)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix packages)
#:use-module (guix utils)
@@ -71,14 +72,14 @@ (define-public flashrom
(inputs (list dmidecode pciutils libusb libftdi))
(native-inputs (list pkg-config))
(arguments
- '(#:make-flags
- (list "CC=gcc"
- (string-append "PREFIX=" %output)
- "CONFIG_ENABLE_LIBUSB0_PROGRAMMERS=no")
- #:tests? #f ; no 'check' target
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)))) ; no configure script
+ (list #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output)
+ "CONFIG_ENABLE_LIBUSB0_PROGRAMMERS=no")
+ #:tests? #f ; no 'check' target
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)))) ; no configure script
(home-page "https://flashrom.org/")
(synopsis "Identify, read, write, erase, and verify ROM/flash chips")
(description
--
2.39.1
H
H
Hilton Chain wrote on 25 Jan 2023 13:06
[PATCH 3/3] gnu: flashrom: Wrap PATH to find dmidecode.
(address . 61057@debbugs.gnu.org)
87lelq3jkl.wl-hako@ultrarare.space
* gnu/packages/flashing-tools.scm (flashrom)[arguments]<#:phases>: Add phase
'wrap-program.
---
gnu/packages/flashing-tools.scm | 9 ++++++++-
1 file changed, 8 insertions(+), 1 deletion(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index 7016d04092..c2f9858fe2 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -79,7 +79,14 @@ (define-public flashrom
#:tests? #f ; no 'check' target
#:phases
#~(modify-phases %standard-phases
- (delete 'configure)))) ; no configure script
+ (delete 'configure) ; no configure script
+ (add-after 'install 'wrap-program
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((flashrom (string-append #$output "/sbin/flashrom")))
+ (wrap-program flashrom
+ `("PATH" ":" prefix
+ (,(dirname (search-input-file
+ inputs "/sbin/dmidecode")))))))))))
(home-page "https://flashrom.org/")
(synopsis "Identify, read, write, erase, and verify ROM/flash chips")
(description
--
2.39.1
H
H
Hilton Chain wrote on 28 May 2023 18:51
[PATCH v2 0/2] gnu: flashrom: Update to 1.3.0.
(address . 61057@debbugs.gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
20230528165149.13011-1-hako@ultrarare.space
v1 -> v2:
Update flashrom to 1.3.0.
Switch build system to meson-build-system.

Hilton Chain (2):
gnu: flashrom: Update to 1.3.0.
gnu: flashrom: Wrap PATH to find dmidecode.

gnu/local.mk | 1 -
gnu/packages/flashing-tools.scm | 50 +++++------
.../flashrom-fix-building-on-aarch64.patch | 89 -------------------
3 files changed, 21 insertions(+), 119 deletions(-)
delete mode 100644 gnu/packages/patches/flashrom-fix-building-on-aarch64.patch


base-commit: 9845e408e533f5834a13f294ca1ddc1dc7e248fd
--
2.40.1
H
H
Hilton Chain wrote on 28 May 2023 18:53
[PATCH v2 1/2] gnu: flashrom: Update to 1.3.0.
(address . 61057@debbugs.gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
20230528165358.13530-1-hako@ultrarare.space
* gnu/packages/patches/flashrom-fix-building-on-aarch64.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
* gnu/packages/flashing-tools.scm (flashrom): Update to 1.3.0.
[build-system]: Switch to meson-build-system.
[inputs]: Add libjaylink.
[native-inputs]: Add cmocka.

Actually, at least from 1.2, the exact \"dmidecode\" is not present in dmi.c.
---
gnu/local.mk | 1 -
gnu/packages/flashing-tools.scm | 40 +++------
.../flashrom-fix-building-on-aarch64.patch | 89 -------------------
3 files changed, 11 insertions(+), 119 deletions(-)
delete mode 100644 gnu/packages/patches/flashrom-fix-building-on-aarch64.patch

Toggle diff (189 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 73370dcc78..80b99c5986 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1131,7 +1131,6 @@ dist_patch_DATA = \
%D%/packages/patches/firebird-riscv64-support-pt1.patch \
%D%/packages/patches/firebird-riscv64-support-pt2.patch \
%D%/packages/patches/flann-cmake-3.11.patch \
- %D%/packages/patches/flashrom-fix-building-on-aarch64.patch \
%D%/packages/patches/flatpak-fix-path.patch \
%D%/packages/patches/flatpak-unset-gdk-pixbuf-for-sandbox.patch \
%D%/packages/patches/fluxbox-1.3.7-no-dynamic-cursor.patch \
diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index 028631cbd2..a1631b2940 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -29,20 +29,24 @@
(define-module (gnu packages flashing-tools)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix download)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix packages)
#:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system meson)
#:use-module (guix build-system python)
#:use-module (gnu packages autotools)
#:use-module (gnu packages admin)
#:use-module (gnu packages base)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages elf)
+ #:use-module (gnu packages embedded)
#:use-module (gnu packages flex)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages gnupg)
@@ -58,7 +62,7 @@ (define-module (gnu packages flashing-tools)
(define-public flashrom
(package
(name "flashrom")
- (version "1.2")
+ (version "1.3.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -66,35 +70,13 @@ (define-public flashrom
version ".tar.bz2"))
(sha256
(base32
- "0ax4kqnh7kd3z120ypgp73qy1knz47l6qxsqzrfkd97mh5cdky71"))
- (patches
- (search-patches "flashrom-fix-building-on-aarch64.patch"))))
- (build-system gnu-build-system)
- (inputs (list dmidecode pciutils libusb libftdi))
- (native-inputs (list pkg-config))
+ "08wn2j5vxzzvigflrjypgxxzjp32c76bshrlkzki5l6cad226lx0"))))
+ (build-system meson-build-system)
+ (inputs (list dmidecode pciutils libusb libftdi libjaylink))
+ (native-inputs (list cmocka pkg-config))
(arguments
- '(#:make-flags
- (list "CC=gcc"
- (string-append "PREFIX=" %output)
- "CONFIG_ENABLE_LIBUSB0_PROGRAMMERS=no")
- #:tests? #f ; no 'check' target
- #:phases
- (modify-phases %standard-phases
- (delete 'configure) ; no configure script
- (add-before 'build 'patch-exec-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "dmi.c"
- (("\"dmidecode\"")
- (format #f "~S"
- (search-input-file inputs "/sbin/dmidecode"))))))
- (add-before 'build 'patch-type-error
- (lambda _
- ;; See https://github.com/flashrom/flashrom/pull/133
- (substitute* "libflashrom.c"
- (("supported_boards\\[i\\].working = binfo\\[i\\].working")
- "supported_boards[i].working = (enum flashrom_test_state)binfo[i].working")
- (("supported_chipsets\\[i\\].status = chipset\\[i\\].status")
- "supported_chipsets[i].status = (enum flashrom_test_state)chipset[i].status")))))))
+ (list #:configure-flags
+ #~'("-Dprogrammer=all")))
(home-page "https://flashrom.org/")
(synopsis "Identify, read, write, erase, and verify ROM/flash chips")
(description
diff --git a/gnu/packages/patches/flashrom-fix-building-on-aarch64.patch b/gnu/packages/patches/flashrom-fix-building-on-aarch64.patch
deleted file mode 100644
index 9f54305b47..0000000000
--- a/gnu/packages/patches/flashrom-fix-building-on-aarch64.patch
+++ /dev/null
@@ -1,89 +0,0 @@
-commit da6b3b70cb852dd8e9f9e21aef95fa83e7f7ab0d
-Author: Pyry Kontio <pyry.kontio@drasa.eu>
-Date: Mon Jul 6 12:57:35 2020 +0900
-
- Makefile: Fix building on AArch64 NixOS
-
- The parsing of the output of archtest.c produced an unexpected
- value on AArch64 NixOS. For example, the make variable ARCH was set to:
-
- ```
- bit outside of fd_set selected
- arm
- ```
-
- This made the arch and OS checks fail.
-
- This commit simplifies the parsing, making it more robust.
-
- The C files archtest.c, endiantest.c and os.h used to set the
- TARGET_OS, ARCH and ENDIAN variables, respectively, output
- the result of the test as the final line, so just extracting
- the final line and removing double quoting is enough.
-
- This commit also fixes a bug with debug_shell lacking escaping
- single quotes, which prevented using the single quote in the
- debug_shell calls. It used to work by accident before this fix;
- the line in the call happened to contain a balanced pair of double
- quotes and lacked other characters that needed escaping, which
- didn't break the debug_shell, but this was accidental and very
- brittle.
-
- Signed-off-by: Pyry Kontio <pyry.kontio@drasa.eu>
- Change-Id: Iaa4477a71e758cf9ecad2c22f3b77bc6508a3510
- Reviewed-on: https://review.coreboot.org/c/flashrom/+/43140
- Tested-by: build bot (Jenkins) <no-reply@coreboot.org>
- Reviewed-by: Angel Pons <th3fanbus@gmail.com>
-
-diff --git a/Makefile b/Makefile
-index f3f7717e..e475cbdb 100644
---- a/Makefile
-+++ b/Makefile
-@@ -83,7 +83,8 @@ dummy_for_make_3_80:=$(shell printf "Build started on %s\n\n" "$$(date)" >$(BUIL
-
- # Provide an easy way to execute a command, print its output to stdout and capture any error message on stderr
- # in the build details file together with the original stdout output.
--debug_shell = $(shell export LC_ALL=C ; { echo 'exec: export LC_ALL=C ; { $(1) ; }' >&2; { $(1) ; } | tee -a $(BUILD_DETAILS_FILE) ; echo >&2 ; } 2>>$(BUILD_DETAILS_FILE))
-+debug_shell = $(shell export LC_ALL=C ; { echo 'exec: export LC_ALL=C ; { $(subst ','\'',$(1)) ; }' >&2; \
-+ { $(1) ; } | tee -a $(BUILD_DETAILS_FILE) ; echo >&2 ; } 2>>$(BUILD_DETAILS_FILE))
-
- ###############################################################################
- # General OS-specific settings.
-@@ -106,7 +107,8 @@ endif
- # IMPORTANT: The following line must be placed before TARGET_OS is ever used
- # (of course), but should come after any lines setting CC because the line
- # below uses CC itself.
--override TARGET_OS := $(strip $(call debug_shell,$(CC) $(CPPFLAGS) -E os.h 2>/dev/null | grep -v '^\#' | grep '"' | cut -f 2 -d'"'))
-+override TARGET_OS := $(strip $(call debug_shell,$(CC) $(CPPFLAGS) -E os.h 2>/dev/null \
-+ | tail -1 | cut -f 2 -d'"'))
-
- ifeq ($(TARGET_OS), Darwin)
- override CPPFLAGS += -I/opt/local/include -I/usr/local/include
-@@ -490,8 +492,10 @@ endif
- # IMPORTANT: The following line must be placed before ARCH is ever used
- # (of course), but should come after any lines setting CC because the line
- # below uses CC itself.
--override ARCH := $(strip $(call debug_shell,$(CC) $(CPPFLAGS) -E archtest.c 2>/dev/null | grep -v '^\#' | grep '"' | cut -f 2 -d'"'))
--override ENDIAN := $(strip $(call debug_shell,$(CC) $(CPPFLAGS) -E endiantest.c 2>/dev/null | grep -v '^\#'))
-+override ARCH := $(strip $(call debug_shell,$(CC) $(CPPFLAGS) -E archtest.c 2>/dev/null \
-+ | tail -1 | cut -f 2 -d'"'))
-+override ENDIAN := $(strip $(call debug_shell,$(CC) $(CPPFLAGS) -E endiantest.c 2>/dev/null \
-+ | tail -1))
-
- # Disable the internal programmer on unsupported architectures (everything but x86 and mipsel)
- ifneq ($(ARCH)-little, $(filter $(ARCH),x86 mips)-$(ENDIAN))
-@@ -1299,12 +1303,12 @@ compiler: featuresavailable
- @printf "Target arch is "
- @# FreeBSD wc will output extraneous whitespace.
- @echo $(ARCH)|wc -w|grep -q '^[[:blank:]]*1[[:blank:]]*$$' || \
-- ( echo "unknown. Aborting."; exit 1)
-+ ( echo "unknown (\"$(ARCH)\"). Aborting."; exit 1)
- @printf "%s\n" '$(ARCH)'
- @printf "Target OS is "
- @# FreeBSD wc will output extraneous whitespace.
- @echo $(TARGET_OS)|wc -w|grep -q '^[[:blank:]]*1[[:blank:]]*$$' || \
-- ( echo "unknown. Aborting."; exit 1)
-+ ( echo "unknown (\"$(TARGET_OS)\"). Aborting."; exit 1)
- @printf "%s\n" '$(TARGET_OS)'
- ifeq ($(TARGET_OS), libpayload)
- @$(CC) --version 2>&1 | grep -q coreboot || \
--
2.40.1
H
H
Hilton Chain wrote on 28 May 2023 18:53
[PATCH v2 2/2] gnu: flashrom: Wrap PATH to find dmidecode.
(address . 61057@debbugs.gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
20230528165358.13530-2-hako@ultrarare.space
* gnu/packages/flashing-tools.scm (flashrom)[inputs]: Add bash-minimal.
[arguments]<#:phases>: Add phase 'wrap-program.
---
gnu/packages/flashing-tools.scm | 14 ++++++++++++--
1 file changed, 12 insertions(+), 2 deletions(-)

Toggle diff (37 lines)
diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index a1631b2940..19219a6d7e 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -41,6 +41,7 @@ (define-module (gnu packages flashing-tools)
#:use-module (gnu packages autotools)
#:use-module (gnu packages admin)
#:use-module (gnu packages base)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
@@ -72,11 +73,20 @@ (define-public flashrom
(base32
"08wn2j5vxzzvigflrjypgxxzjp32c76bshrlkzki5l6cad226lx0"))))
(build-system meson-build-system)
- (inputs (list dmidecode pciutils libusb libftdi libjaylink))
+ (inputs (list bash-minimal dmidecode pciutils libusb libftdi libjaylink))
(native-inputs (list cmocka pkg-config))
(arguments
(list #:configure-flags
- #~'("-Dprogrammer=all")))
+ #~'("-Dprogrammer=all")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'wrap-program
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((flashrom (string-append #$output "/sbin/flashrom")))
+ (wrap-program flashrom
+ `("PATH" ":" prefix
+ (,(dirname (search-input-file
+ inputs "/sbin/dmidecode")))))))))))
(home-page "https://flashrom.org/")
(synopsis "Identify, read, write, erase, and verify ROM/flash chips")
(description
--
2.40.1
L
L
Ludovic Courtès wrote on 8 Jun 2023 23:19
Re: bug#61057: [PATCH 0/3] gnu: flashrom: Update to 1.2.1.
(name . Hilton Chain)(address . hako@ultrarare.space)(address . 61057-done@debbugs.gnu.org)
87o7lpzm7h.fsf_-_@gnu.org
Hi,

Hilton Chain <hako@ultrarare.space> skribis:

Toggle quote (8 lines)
> v1 -> v2:
> Update flashrom to 1.3.0.
> Switch build system to meson-build-system.
>
> Hilton Chain (2):
> gnu: flashrom: Update to 1.3.0.
> gnu: flashrom: Wrap PATH to find dmidecode.

Finally applied, thanks!

Ludo’.
Closed
?