[PATCH 1/1] gnu: Add zenmonitor3 * gnu/package/linux.scm (zenmonitor3): New variable.

  • Open
  • quality assurance status badge
Details
One participant
  • Steve George
Owner
unassigned
Submitted by
Steve George
Severity
normal
Merged with
S
S
Steve George wrote on 24 Jan 2023 22:34
(name . Guix patches list)(address . guix-patches@gnu.org)
20230124213404.117503-2-steve@futurile.net
---

gnu/packages/linux.scm | 49 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 49 insertions(+)

Toggle diff (62 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 250eacd076..2a590086ed 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -6694,6 +6694,55 @@ (define-public x86-energy-perf-policy
cpufreq sub-system is enabled or not.")
(license license:gpl2)))
+(define-public zenmonitor3
+ (package
+ (name "zenmonitor3")
+ (version "2e68a31b0248699ec1f3caa1782d9b520222242a")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.exozy.me/a/zenmonitor3")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "18rwk2jm2zjh15hdwqszyga2g7cyifblch0bska3drlm7ivqi2hx"))))
+ (build-system gnu-build-system)
+ (native-inputs (list pkg-config))
+ (inputs (list glib gtk+ gnu-make ncurses polkit-duktape))
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'build 'build-cli
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (apply invoke "make" "build-cli" make-flags)))
+ (add-after 'install 'install-cli
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (apply invoke
+ `("make" "install-cli"
+ ,@make-flags))))
+ (add-after 'install-cli 'install-polkit
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out")))
+ (mkdir-p (string-append out "/share/applications"))
+ (install-file "data/zenmonitor-root.desktop.in"
+ (string-append out "/share/applications"))
+ (mkdir-p (string-append out "/share/polkit-1/actions"))
+ (install-file "data/org.pkexec.zenmonitor.policy.in"
+ (string-append out
+ "/share/polkit-1/actions"))))))
+ #:tests? #f
+ #:make-flags (list (string-append "CC="
+ ,(cc-for-target))
+ (string-append "PREFIX=" %output))))
+ (home-page "https://git.exozy.me/a/zenmonitor3")
+ (synopsis "Monitoring software for AMD Zen-based CPUs")
+ (description
+ "Graphical and CLI monitoring of CPU temperature, voltage, power
+and frequency on AMD Zen family CPUs. Requires the zenpower3 and MSR
+kernel drivers.")
+ (license license:expat)))
+
(define-public haveged
(package
(name "haveged")
--
2.39.1
S
S
Steve George wrote on 24 Jan 2023 22:42
(no subject)
(address . control@debbugs.gnu.org)
088ac32a-e42f-38d7-af67-87b7196e868f@futurile.net
merge 61045 61046
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 61046@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61046
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch