[PATCH core-updates 0/1] gnu: libdrm: Fix building on ARM architectures.

  • Done
  • quality assurance status badge
Details
One participant
  • Simon South
Owner
unassigned
Submitted by
Simon South
Severity
normal
S
S
Simon South wrote on 24 Jan 2023 18:26
(address . guix-patches@gnu.org)
cover.1674580043.git.simon@simonsouth.net
On core-updates, libdrm is failing to build on aarch64-linux with

../libdrm-2.4.114/meson.build:21:0: ERROR: Value "true" (of type
"string") for combo option "Enable support for EXYNOS's experimental
KMS API." is not one of the choices. Possible choices are (as
string): "enabled", "disabled", "auto".

This is due to a recent change in libdrm[0] that changed the type, and
therefore the accepted values, of a number of build-configuration
options. The patch to follow corrects this issue and allows libdrm to
build again. (Note master and staging still provide an older version
of libdrm and are unaffected.)

Tested on x86-64 and AArch64 and everything appears fine. On x86-64,
the same package output is produced with or without the patch applied.

[0] In upstream commit 26eb15165b:

--
Simon South
simon@simonsouth.net


Simon South (1):
gnu: libdrm: Fix building on ARM architectures.

gnu/packages/xdisorg.scm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)


base-commit: ca124b098dcc7ce7898df10faf9986f44a14e0a1
--
2.39.1
S
S
Simon South wrote on 24 Jan 2023 18:28
[PATCH core-updates 1/1] gnu: libdrm: Fix building on ARM architectures.
(address . 61039@debbugs.gnu.org)
3a97f07646e9e938d86bf4b9a6690fa9cdc3c7ac.1674580043.git.simon@simonsouth.net
* gnu/packages/xdisorg.scm (libdrm)[arguments]<#:configure-flags>: Update
option values to match current version of libdrm.
---
gnu/packages/xdisorg.scm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 9b45d51637..8f5c42030c 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -706,10 +706,10 @@ (define-public libdrm
(list #:configure-flags
(match (%current-system)
((or "armhf-linux" "aarch64-linux")
- #~(list "-Dexynos=true"
- "-Domap=true"
- "-Detnaviv=true"
- "-Dtegra=true"
+ #~(list "-Dexynos=enabled"
+ "-Domap=enabled"
+ "-Detnaviv=enabled"
+ "-Dtegra=enabled"
"-Dfreedreno-kgsl=true"))
(_ ''()))
#:phases
--
2.39.1
S
S
Simon South wrote on 19 Sep 2023 16:31
Re: bug#61039: [PATCH core-updates 0/1] gnu: libdrm: Fix building on ARM architectures.
(address . 61039-done@debbugs.gnu.org)
87y1h2tetu.fsf@simonsouth.net
This issue was resolved with commit 62ff0b9086, "gnu: libdrm: Update
configure-flags."

--
Simon South
simon@simonsouth.net
Closed
?