Matthieu Lemerre wrote 2 years ago
(address . guix-patches@gnu.org)
Hi Guix!
This emacs package allows to control Kodi remotely -- I use it every day and it is very handy!
The guix installation works well.
Best regards,
Matthieu
---
gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)
Toggle diff (43 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c2be7eac57..e2efaaf47d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -26708,6 +26708,34 @@ (define-public emacs-mpdel
stored playlists.")
(license license:gpl3+)))
+
+(define-public emacs-kodi-remote
+ (package
+ (name "emacs-kodi-remote")
+ (version "20190622.1325")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/spiderbit/kodi-remote.el.git")
+ (commit "f5e932036c16e2b61a63020e006fc601e38d181e")))
+ (sha256
+ (base32
+ "1gck7lvqxcr9ikrzlpvcf4408cq6i4s8ijgb0kdsbkfzv0w86934"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-request emacs-let-alist emacs-json-mode emacs-f))
+ (home-page "http://github.com/spiderbit/kodi-remote.el")
+ (synopsis "Remote Control for Kodi")
+ (description
+ "This package provides a major to remote control kodi instances. First specify
+the hostname/ip of your kodi webserver: (setq kodi-host-name \"my-htpc:8080\")
+Then open the Remote with the command: kodi-remote Also open the current kodi
+Video Playlist with the command: kodi-remote-playlist Start play exercise mode:
+kodi-remote-exercise OPTIONAL: setup settings for deleting files (over tramp)
+(setq kodi-dangerous-options t) (setq kodi-access-host \"my-htpc\") if you don't
+use ssh to access your kodi server / nas: (setq kodi-access-method
+\"smb/ftp/adb...\")")
+ (license gpl3+)))
+
(define-public emacs-navigel
(package
(name "emacs-navigel")
base-commit: 77a34996000acf43b668ebf491afb6d02e85b0ec
--
2.38.1