[PATCH] Add emacs-kodi-remote.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Matthieu Lemerre
Owner
unassigned
Submitted by
Matthieu Lemerre
Severity
normal

Debbugs page

Matthieu Lemerre wrote 2 years ago
(address . guix-patches@gnu.org)
877cxcg9jk.fsf@cea.fr
Hi Guix!

This emacs package allows to control Kodi remotely -- I use it every day and it is very handy!
The guix installation works well.

Best regards,
Matthieu

---
gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c2be7eac57..e2efaaf47d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -26708,6 +26708,34 @@ (define-public emacs-mpdel
stored playlists.")
(license license:gpl3+)))
+
+(define-public emacs-kodi-remote
+ (package
+ (name "emacs-kodi-remote")
+ (version "20190622.1325")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/spiderbit/kodi-remote.el.git")
+ (commit "f5e932036c16e2b61a63020e006fc601e38d181e")))
+ (sha256
+ (base32
+ "1gck7lvqxcr9ikrzlpvcf4408cq6i4s8ijgb0kdsbkfzv0w86934"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-request emacs-let-alist emacs-json-mode emacs-f))
+ (home-page "http://github.com/spiderbit/kodi-remote.el")
+ (synopsis "Remote Control for Kodi")
+ (description
+ "This package provides a major to remote control kodi instances. First specify
+the hostname/ip of your kodi webserver: (setq kodi-host-name \"my-htpc:8080\")
+Then open the Remote with the command: kodi-remote Also open the current kodi
+Video Playlist with the command: kodi-remote-playlist Start play exercise mode:
+kodi-remote-exercise OPTIONAL: setup settings for deleting files (over tramp)
+(setq kodi-dangerous-options t) (setq kodi-access-host \"my-htpc\") if you don't
+use ssh to access your kodi server / nas: (setq kodi-access-method
+\"smb/ftp/adb...\")")
+ (license gpl3+)))
+
(define-public emacs-navigel
(package
(name "emacs-navigel")

base-commit: 77a34996000acf43b668ebf491afb6d02e85b0ec
--
2.38.1
Nicolas Goaziou wrote 2 years ago
(name . Matthieu Lemerre)(address . racin@free.fr)(address . 61031@debbugs.gnu.org)
87bkmmo6lp.fsf@nicolasgoaziou.fr
Hello,

Matthieu Lemerre <racin@free.fr> writes:

Toggle quote (3 lines)
> This emacs package allows to control Kodi remotely -- I use it every day and it is very handy!
> The guix installation works well.

Thank you. Some comments follow.

Toggle quote (5 lines)
> +(define-public emacs-kodi-remote
> + (package
> + (name "emacs-kodi-remote")
> + (version "20190622.1325")

According to "kodi-remote.el", version is "0", not this date-based one.

You should also use `git-version' since we're using an unreleased version.

Toggle quote (5 lines)
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/spiderbit/kodi-remote.el.git")

You should drop the ".git" suffix from URL.

Toggle quote (2 lines)
> + (commit "f5e932036c16e2b61a63020e006fc601e38d181e")))

Usually, we let-bind the commit at the beginning of the package
definition and write

(commit commit)

Toggle quote (6 lines)
> + (sha256
> + (base32
> + "1gck7lvqxcr9ikrzlpvcf4408cq6i4s8ijgb0kdsbkfzv0w86934"))))
> + (build-system emacs-build-system)
> + (propagated-inputs (list emacs-request emacs-let-alist emacs-json-mode emacs-f))

Please order inputs alphabetically.

Toggle quote (5 lines)
> + (synopsis "Remote Control for Kodi")
> + (description
> + "This package provides a major to remote control kodi instances. First specify

kodi -> Kodi

Toggle quote (8 lines)
> +the hostname/ip of your kodi webserver: (setq kodi-host-name \"my-htpc:8080\")
> +Then open the Remote with the command: kodi-remote Also open the current kodi
> +Video Playlist with the command: kodi-remote-playlist Start play exercise mode:
> +kodi-remote-exercise OPTIONAL: setup settings for deleting files (over tramp)
> +(setq kodi-dangerous-options t) (setq kodi-access-host \"my-htpc\") if you don't
> +use ssh to access your kodi server / nas: (setq kodi-access-method
> +\"smb/ftp/adb...\")")

This is more a manual excerpt than a proper description. Could you
reword it a bit to describe what the package does, not how to do it?
Note that sentences should be separated with full stops and two spaces,
per Texinfo specification.

Toggle quote (2 lines)
> + (license gpl3+)))

This cannot possibly build: the license above should be license:gpl3+.

Could you send an updated patch?

Regards,
--
Nicolas Goaziou
racin wrote 2 years ago
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 61031@debbugs.gnu.org)
1619463260.211138834.1674823418016.JavaMail.zimbra@free.fr
Thanks for all the comments! Here is an updated patch addressing everything.

You were right about the problem that it did not compile; I did not understand that I had to to make
before ./pre-inst-env guix build emacs-kodi-remote. I think I properly tested it now.

Matthieu

---
gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c2be7eac57..0c832110a0 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -26708,6 +26708,30 @@ (define-public emacs-mpdel
stored playlists.")
(license license:gpl3+)))
+
+(define-public emacs-kodi-remote
+ (let ((commit "f5e932036c16e2b61a63020e006fc601e38d181e")
+ (revision "0"))
+ (package
+ (name "emacs-kodi-remote")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/spiderbit/kodi-remote.el.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "1gck7lvqxcr9ikrzlpvcf4408cq6i4s8ijgb0kdsbkfzv0w86934"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-f emacs-json-mode emacs-let-alist emacs-request))
+ (home-page "http://github.com/spiderbit/kodi-remote.el")
+ (synopsis "Remote Control for Kodi")
+ (description
+ "This package provides a major mode to remote control Kodi
+instances (play/pause, volume control, media selection, etc.).")
+ (license license:gpl3+))))
+
(define-public emacs-navigel
(package
(name "emacs-navigel")
--
2.39.1
Nicolas Goaziou wrote 2 years ago
(address . racin@free.fr)(address . 61031-done@debbugs.gnu.org)
87zga3k516.fsf@nicolasgoaziou.fr
Hello,

racin@free.fr writes:

Toggle quote (4 lines)
> You were right about the problem that it did not compile; I did not understand that I had to to make
> before ./pre-inst-env guix build emacs-kodi-remote. I think I properly
> tested it now.

Great. I added a commit message and applied your patch, with the changes below.

Toggle quote (8 lines)
> + (package
> + (name "emacs-kodi-remote")
> + (version (git-version "0" revision commit))
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/spiderbit/kodi-remote.el.git")

I removed ".git" suffix
Toggle quote (2 lines)
> + (commit commit)))

I added

(file-name (git-file-name name version))

here

Toggle quote (6 lines)
> + (sha256
> + (base32
> + "1gck7lvqxcr9ikrzlpvcf4408cq6i4s8ijgb0kdsbkfzv0w86934"))))
> + (build-system emacs-build-system)
> + (propagated-inputs (list emacs-f emacs-json-mode emacs-let-alist emacs-request))

I added a newline character after "propagated-inputs".
Toggle quote (3 lines)
> + (synopsis "Remote Control for Kodi")

Control -> control

Regards,
--
Nicolas Goaziou
Closed
racin wrote 2 years ago
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 61031-done@debbugs.gnu.org)
1330773820.213205197.1674857454177.JavaMail.zimbra@free.fr
Toggle quote (2 lines)
> Great. I added a commit message and applied your patch, with the changes below.

Great! I'll try to be more careful next time!

Toggle quote (2 lines)
> I removed ".git" suffix

You had mentionned it, sorry.

Toggle quote (2 lines)
> I added (file-name (git-file-name name version))

This I didn't know.

Toggle quote (2 lines)
> Control -> control

Oups.

Regards,

Matthieu
Closed
Nicolas Goaziou wrote 2 years ago
(address . racin@free.fr)(address . 61031-done@debbugs.gnu.org)
87mt63k4i1.fsf@nicolasgoaziou.fr
racin@free.fr writes:

Toggle quote (4 lines)
>> I added (file-name (git-file-name name version))

> This I didn't know.

If you run

./pre-inst-env guix lint emacs-kodi-remote

you will get something like

emacs-kodi-remote@0-0.f5e9320: the source file name should contain the package name
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61031@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61031
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help