[PATCH] package the jed editor

  • Done
  • quality assurance status badge
Details
3 participants
  • Ethan Blanton
  • Ludovic Courtès
  • Bruno Victal
Owner
unassigned
Submitted by
Ethan Blanton
Severity
normal
E
E
Ethan Blanton wrote on 23 Jan 2023 03:06
(address . guix-patches@gnu.org)
Y83rjpZ/5n3Hvi0E@colt.lan
Toggle diff (49 lines)
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 9dd5d7793f..133b52438c 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -89,6 +89,7 @@
#:use-module (gnu packages regex)
#:use-module (gnu packages ruby)
#:use-module (gnu packages sdl)
+ #:use-module (gnu packages slang)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages terminals)
#:use-module (gnu packages texinfo)
@@ -1391,3 +1392,36 @@ easy to modify and extend, or to use without doing either.
The aim of Lite XL compared to lite is to be more user-friendly, improve the
quality of font rendering, and reduce CPU usage.")
(license license:expat)))
+
+(define-public jed
+ (package
+ (name "jed")
+ (version "0.99-19")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.jedsoft.org/releases/jed/jed-"
+ version ".tar.bz2"))
+ (sha256
+ (base32 "0qspdc6wss43wh1a8fddvf62xyhld5p7hl75grv4d95h5z73k8wp"))
+ (modules '((guix build utils)))
+ (snippet
+ #~(begin
+ (substitute* "src/Makefile.in"
+ (("/bin/cp") "cp"))
+ (substitute* "configure"
+ (("TERMCAP=-ltermcap") "TERMCAP="))))))
+ (build-system gnu-build-system)
+ (arguments (list #:configure-flags
+ #~(list (string-append "--with-slang="
+ #$(this-package-input "slang")))
+ #:tests? #f))
+ (inputs (list slang))
+ (home-page "https://www.jedsoft.org/jed/")
+ (synopsis "Programmer's editor using S-Lang scripting for configuration")
+ (description
+ "Jed is a powerful programmer's editor using the S-Lang scripting language
+for configuration and extensibility. It provides emulation modes for the
+key bindings of many editors (including Emacs and WordStar), and has syntax
+highlighting for dozens of languages. Jed is very small and fast.")
+ (license license:gpl2+)))
B
B
Bruno Victal wrote on 23 Jan 2023 15:19
(name . Ethan Blanton)(address . elb@kb8ojh.net)(address . 61023@debbugs.gnu.org)
01a75079-fa31-ab16-1dbf-9211082026c3@makinata.eu
Hi,

On 2023-01-23 02:06, Ethan Blanton via Guix-patches via wrote:
Toggle quote (5 lines)
> + (build-system gnu-build-system)
> + (arguments (list #:configure-flags
> + #~(list (string-append "--with-slang="
> + #$(this-package-input "slang")))
> + #:tests? #f))
You should comment the reason for disabling the tests.


Additionally, the commit should be in ChangeLog format [1], you can look
at the Guix commit logs to see what they look like.




Cheers,
Bruno
E
E
Ethan Blanton wrote on 23 Jan 2023 16:07
[PATCH] gnu: Add the jed editor.
(address . 61023@debbugs.gnu.org)
Y86ixCRzLMWT4mrj@colt.lan
* gnu/packages/text-editors.scm (jed): package for jed 0.99-19
---
gnu/packages/text-editors.scm | 36 +++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 9dd5d7793f..3f570b3831 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -89,6 +89,7 @@
#:use-module (gnu packages regex)
#:use-module (gnu packages ruby)
#:use-module (gnu packages sdl)
+ #:use-module (gnu packages slang)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages terminals)
#:use-module (gnu packages texinfo)
@@ -1391,3 +1392,38 @@ easy to modify and extend, or to use without doing either.
The aim of Lite XL compared to lite is to be more user-friendly, improve the
quality of font rendering, and reduce CPU usage.")
(license license:expat)))
+
+(define-public jed
+ (package
+ (name "jed")
+ (version "0.99-19")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.jedsoft.org/releases/jed/jed-"
+ version ".tar.bz2"))
+ (sha256
+ (base32 "0qspdc6wss43wh1a8fddvf62xyhld5p7hl75grv4d95h5z73k8wp"))
+ (modules '((guix build utils)))
+ (snippet
+ #~(begin
+ (substitute* "src/Makefile.in"
+ (("/bin/cp") "cp"))
+ ;; jed links termcap by default but does not require it
+ (substitute* "configure"
+ (("TERMCAP=-ltermcap") "TERMCAP="))))))
+ (build-system gnu-build-system)
+ (arguments (list #:configure-flags
+ #~(list (string-append "--with-slang="
+ #$(this-package-input "slang")))
+ ;; jed provides no tests
+ #:tests? #f))
+ (inputs (list slang))
+ (home-page "https://www.jedsoft.org/jed/")
+ (synopsis "Programmer's editor using S-Lang scripting for configuration")
+ (description
+ "Jed is a powerful programmer's editor using the S-Lang scripting language
+for configuration and extensibility. It provides emulation modes for the
+key bindings of many editors (including Emacs and WordStar), and has syntax
+highlighting for dozens of languages. Jed is very small and fast.")
+ (license license:gpl2+)))
--
2.30.2
L
L
Ludovic Courtès wrote on 27 Jan 2023 16:50
Re: bug#61023: [PATCH] package the jed editor
(name . Ethan Blanton)(address . elb@kb8ojh.net)(address . 61023-done@debbugs.gnu.org)
87357w5652.fsf_-_@gnu.org
Hi,

Ethan Blanton <elb@kb8ojh.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/text-editors.scm (jed): package for jed 0.99-19

Applied after passing it through ‘guix style’. I followed up with a
patch to remove .exe files from the tarball.

Thanks!

Ludo’.
Closed
?