guix style indentation problem in (list ...)

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 23 Jan 2023 01:38
(name . bug-guix)(address . bug-guix@gnu.org)
87358213wb.fsf@gmail.com
Hello,

I recently stumbled on this indentation produced with guix style:

Toggle snippet (6 lines)
(arguments
(list
;; Disable tests that use the network and non-free assets.
#:test-flags #~(list "-m" "not external and not samples")))

While the conventional way would be to indent it as:

Toggle snippet (6 lines)
(arguments
(list
;; Disable tests that use the network and non-free assets.
#:test-flags #~(list "-m" "not external and not samples")))

--
Thanks,
Maxim
L
L
Ludovic Courtès wrote on 7 Mar 2023 14:59
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 61013-done@debbugs.gnu.org)
87ttywd5n6.fsf@gnu.org
Hello,

Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:

Toggle quote (15 lines)
> I recently stumbled on this indentation produced with guix style:
>
> (arguments
> (list
> ;; Disable tests that use the network and non-free assets.
> #:test-flags #~(list "-m" "not external and not samples")))
>
>
> While the conventional way would be to indent it as:
>
> (arguments
> (list
> ;; Disable tests that use the network and non-free assets.
> #:test-flags #~(list "-m" "not external and not samples")))

Fixed in 0a37921d851b94aef6900214098dc5bd62b46e26, thanks!

Ludo’.
Closed
M
M
Maxim Cournoyer wrote on 7 Mar 2023 19:31
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 61013-done@debbugs.gnu.org)
87mt4owgzi.fsf@gmail.com
Hi Ludo,

Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (21 lines)
> Hello,
>
> Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:
>
>> I recently stumbled on this indentation produced with guix style:
>>
>> (arguments
>> (list
>> ;; Disable tests that use the network and non-free assets.
>> #:test-flags #~(list "-m" "not external and not samples")))
>>
>>
>> While the conventional way would be to indent it as:
>>
>> (arguments
>> (list
>> ;; Disable tests that use the network and non-free assets.
>> #:test-flags #~(list "-m" "not external and not samples")))
>
> Fixed in 0a37921d851b94aef6900214098dc5bd62b46e26, thanks!

Awesome, that was quick! I'll try to use it more regularly and reports
of any problematic behavior.

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61013@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61013
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch