[PATCH] gnu: wlroots: Update dependencies

  • Done
  • quality assurance status badge
Details
3 participants
  • Andy Tai
  • Josselin Poiret
  • Andy Tai
Owner
unassigned
Submitted by
Andy Tai
Severity
normal

Debbugs page

Andy Tai wrote 2 years ago
(address . guix-patches@gnu.org)
CAJsg1E_9tM4qWbuynwTdYh5g3V6myVxfUbcU9hyHFU=mZLZGWw@mail.gmail.com

Attachment: file
From 2d433dba9ee73707ec71a4209e023e91e10d094d Mon Sep 17 00:00:00 2001
From: Andy Tai <atai@atai.org>
Date: Fri, 20 Jan 2023 20:43:50 -0800
Subject: [PATCH] gnu: wlroots: Update dependencies

gnu/packages/wm.scm (wlroots): Add input xcb-util-renderutil and vulkan
for XWayland support
---
gnu/packages/wm.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (22 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 201c5994d8..b93c57b888 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -143,6 +143,7 @@ (define-module (gnu packages wm)
#:use-module (gnu packages textutils)
#:use-module (gnu packages time)
#:use-module (gnu packages video)
+ #:use-module (gnu packages vulkan)
#:use-module (gnu packages web)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xml)
@@ -1555,6 +1556,7 @@ (define-public wlroots
"xorg-server-xwayland")
"/bin/Xwayland")))
#t)))))
+ (inputs (list libpng mesa-headers vulkan-headers vulkan-loader xcb-util-renderutil))
(propagated-inputs
(list ;; As required by wlroots.pc.
eudev
--
2.39.1
Josselin Poiret wrote 2 years ago
87lelfw03g.fsf@jpoiret.xyz
Hi Andry,

First of all, looking at QA [1], I noticed that none of the WMs
depending on it actually build. Have you tested this patch on your
machine?

Andy Tai <lichengtai@gmail.com> writes:

Toggle quote (29 lines)
> From 2d433dba9ee73707ec71a4209e023e91e10d094d Mon Sep 17 00:00:00 2001
> From: Andy Tai <atai@atai.org>
> Date: Fri, 20 Jan 2023 20:43:50 -0800
> Subject: [PATCH] gnu: wlroots: Update dependencies
>
> gnu/packages/wm.scm (wlroots): Add input xcb-util-renderutil and vulkan
> for XWayland support
> ---
> gnu/packages/wm.scm | 2 ++
> 1 file changed, 2 insertions(+)
>
> diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
> index 201c5994d8..b93c57b888 100644
> --- a/gnu/packages/wm.scm
> +++ b/gnu/packages/wm.scm
> @@ -143,6 +143,7 @@ (define-module (gnu packages wm)
> #:use-module (gnu packages textutils)
> #:use-module (gnu packages time)
> #:use-module (gnu packages video)
> + #:use-module (gnu packages vulkan)
> #:use-module (gnu packages web)
> #:use-module (gnu packages xdisorg)
> #:use-module (gnu packages xml)
> @@ -1555,6 +1556,7 @@ (define-public wlroots
> "xorg-server-xwayland")
> "/bin/Xwayland")))
> #t)))))
> + (inputs (list libpng mesa-headers vulkan-headers vulkan-loader xcb-util-renderutil))

Here, xcb-util-renderutil should be propagated because it is required by
the wlroots.pc pkg-config file. Also, looking at the wlroots README, I
don't see libpng mentioned anywhere, as well as mesa-headers, and
removing both of them still lets it build fine. Do you know if those are
actually needed? Reciprocally, glslang is mentioned for the Vulkan
renderer, but I don't see it here.

Toggle quote (4 lines)
> (propagated-inputs
> (list ;; As required by wlroots.pc.
> eudev

Best,
--
Josselin Poiret
Andy Tai wrote 2 years ago
(address . 60979@debbugs.gnu.org)
CAJsg1E_Ls1_i76HPHeKFSuAJJQDfncpHF0JP+jtmJjFP5=roWg@mail.gmail.com
OK, I will close this issue as this seems complicated and will let
other people handle this package.

Toggle quote (8 lines)
>
> > (propagated-inputs
> > (list ;; As required by wlroots.pc.
> > eudev
>
> Best,
> --
> Josselin Poiret
Andy Tai wrote 2 years ago
(address . control@debbugs.gnu.org)
CAJsg1E8jBD71=zuu+3qPpwbw6cNs_tWRiz4hnGrECWnD4ouo+g@mail.gmail.com
close 60979

thanks

complicate issue, this patch withdrawn
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60979@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60979
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help