[PATCH] gnu: inkscape: Fix qrcode rendering.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 2 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20230120223342.7184-1-mike@rohleder.de

* gnu/packages/inkscape.scm (inkscape)[inputs]: Add python-cssselect.
---
gnu/packages/inkscape.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/inkscape.scm b/gnu/packages/inkscape.scm
index 2e43835e4f..d1ac5e7312 100644
--- a/gnu/packages/inkscape.scm
+++ b/gnu/packages/inkscape.scm
@@ -46,6 +46,7 @@ (define-module (gnu packages inkscape)
#:use-module (gnu packages pdf)
#:use-module (gnu packages popt)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages xml)
#:use-module (gnu packages ghostscript)
@@ -273,5 +274,6 @@ (define-public inkscape
(inputs (modify-inputs (package-inputs inkscape/stable)
(replace "lib2geom" lib2geom-1.2)
(append bash-minimal
- librsvg))) ;for the pixbuf loader
+ librsvg ;for the pixbuf loader
+ python-cssselect))) ;to render qrcode
(properties (alist-delete 'hidden? (package-properties inkscape/stable)))))
--
2.38.1
Ludovic Courtès wrote 2 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)
87bkmk5778.fsf@gnu.org
Hi,

Michael Rohleder <mike@rohleder.de> skribis:

Toggle quote (4 lines)
>
> * gnu/packages/inkscape.scm (inkscape)[inputs]: Add python-cssselect.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60975@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60975
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help