[PATCH] gnu: Add r-tsis.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)
20230120095521.50160-1-navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (r-tsis): New variable.
---
gnu/packages/bioinformatics.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 86d65d2031..cb5f71c40e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8215,6 +8215,37 @@ (define-public r-snapatac
single cell ATAC-seq sequencing data.")
(license license:gpl3)))
+(define-public r-tsis
+ (let ((commit "24460298fbe1d26e4da390f6e4f3d4d9d62334dc")
+ (revision "1"))
+ (package
+ (name "r-tsis")
+ (version (git-version "0.2.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wyguo/TSIS")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "17c8i25iwhldvs3c51m0wny40iffm8szzijalpwrxhzbv0xa94rb"))))
+ (properties `((upstream-name . "TSIS")))
+ (build-system r-build-system)
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/wyguo/TSIS")
+ (synopsis "Time-series isoform switch of alternative splicing")
+ (description
+ "TSIS is used for detecting transcript isoform switches in time-series data.
+Transcript isoform switches occur when a pair of alternatively spliced isoforms
+reverse the order of their relative expression levels. TSIS characterizes the
+transcript switch by defining the isoform switch time-points for any pair of
+transcript isoforms within a gene. In addition, this tool describes the switch
+using five different features or metrics. Also it filters the results with user’s
+specifications and visualizes the results using different plots for the user to
+examine further details of the switches.")
+ (license license:gpl3))))
+
(define-public r-umi4cpackage
(let ((commit "88b07d896a137418ba6c31c2474b9dbe1d86fc20")
(revision "1"))
--
2.34.1
Ricardo Wurmus wrote 2 years ago
(address . 60959-done@debbugs.gnu.org)
87v8l1h63p.fsf@elephly.net
Thank you for the patch, I just applied it!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60959@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60959
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help