[PATCH 2/2] gnu: Add r-scds.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal
Merged with

Debbugs page

Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)
20230120085800.47650-2-navid.afkhami@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-scds): New variable.
---
gnu/packages/bioconductor.scm | 28 ++++++++++++++++++++++++++++
gnu/packages/bioinformatics.scm | 2 +-
2 files changed, 29 insertions(+), 1 deletion(-)

Toggle diff (61 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 93c6165b62..bdbdeecc35 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2021 Hong Li <hli@mdc-berlin.de>
;;; Copyright © 2021 Tim Howes <timhowes@lavabit.com>
;;; Copyright © 2021 Nicolas Vallet <nls.vallet@gmail.com>
+;;; Copyright © 2023 Navid Afkhami <Navid.Afkhami@mdc-berlin.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -7678,6 +7679,33 @@ (define-public r-trajectoryutils
structures to hold pseudotime inference results.")
(license license:gpl3)))
+(define-public r-scds
+ (package
+ (name "r-scds")
+ (version "1.14.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "scds" version))
+ (sha256
+ (base32
+ "0zdf9yf5s0l8ma7d8yhi7bjd964yj84f5h6aq2p0sypjlnc515hd"))))
+ (properties `((upstream-name . "scds")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-dplyr
+ r-matrix
+ r-proc
+ r-s4vectors
+ r-singlecellexperiment
+ r-summarizedexperiment
+ r-xgboost))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/scds")
+ (synopsis "In-silico doublet annotation for single cell RNA sequencing data")
+ (description
+ "This is an R package for doublet annotation of single cell RNA sequencing data.
+@code{scds} provides methods to annotate doublets in scRNA-seq data computationally.")
+ (license license:expat)))
+
(define-public r-slingshot
(package
(name "r-slingshot")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 86d65d2031..70ac252a8c 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -23,7 +23,7 @@
;;; Copyright © 2021 Hong Li <hli@mdc-berlin.de>
;;; Copyright © 2021, 2022, 2023 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
-;;; Copyright © 2022 Navid Afkhami <navid.afkhami@mdc-berlin.de>
+;;; Copyright © 2022,2023 Navid Afkhami <navid.afkhami@mdc-berlin.de>
;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
;;;
;;; This file is part of GNU Guix.
--
2.34.1
Ricardo Wurmus wrote 2 years ago
(address . 60958-done@debbugs.gnu.org)
87mt6dh60d.fsf@elephly.net
Thanks for the patch!

I trimmed off the changes to bioinformatics.scm and moved the change to
the copyright line to patch #60958 where you modified that file.

Applied!

--
Ricardo
Closed
Ricardo Wurmus wrote 2 years ago
(address . control@debbugs.gnu.org)
87zga7d3e9.fsf@elephly.net
forcemerge 60958 60955
thanks

--
Ricardo
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60958@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60958
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help