[PATCH 1/2] gnu: Add r-doubletcollection.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)
20230120085800.47650-1-navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (r-doubletcollection): New variable.
---
gnu/packages/bioinformatics.scm | 40 +++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 36c9db90bd..86d65d2031 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7986,6 +7986,46 @@ (define-public r-chromunity
Pore-C concatemers.")
(license license:gpl3))))
+(define-public r-doubletcollection
+ (let ((commit "c0d62f1853942ee6a087eaf7b000d9e4261e2dfd")
+ (revision "1"))
+ (package
+ (name "r-doubletcollection")
+ (version (git-version "1.1.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xnnba1984/DoubletCollection")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "02cvibyc2nwc4037ramm5cskjwyrb9ib9hkrfhmvhbslkn5ixz1v"))))
+ (properties `((upstream-name . "DoubletCollection")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-biocgenerics
+ r-doubletfinder
+ r-gam
+ r-ggplot2
+ r-ggthemes
+ r-mast
+ r-mclust
+ r-prroc
+ r-reticulate
+ r-scales
+ r-scdblfinder
+ r-scds
+ r-seurat
+ r-singlecellexperiment
+ r-slingshot
+ r-summarizedexperiment))
+ (home-page "https://github.com/xnnba1984/DoubletCollection")
+ (synopsis "Tool for finding doublets in scRNA-seq data")
+ (description
+ "This is an R package that integrates the installation of doublet-detection methods.
+In addition, this tool is used for execution and benchmark of those eight mentioned methods.")
+ (license license:gpl3+))))
+
(define-public r-pando
(package
(name "r-pando")
--
2.34.1
Ricardo Wurmus wrote 2 years ago
(address . 60957-done@debbugs.gnu.org)
87r0vph62e.fsf@elephly.net
Thanks for the patch. Applied!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60957@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60957
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help