Update diffoscope to 232

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Vagrant Cascadian
Severity
normal
V
V
Vagrant Cascadian wrote on 19 Jan 2023 02:31
(address . guix-patches@gnu.org)
87ilh3z4vo.fsf@contorta
Working on updating diffoscope to 232.

Mostly routine changes. Notable differences are:

* Needed a newer version of python-pypdf, as the python-pypdf2 included
in guix is too old, referred to as PyPDF2 1.x, newer versions include
PyPDF2 2.x or PyPdf2 3.x... It is also not PyPDF 1.x or PyPDF 2.x,
which are very old, and I am not sure where PyPDF3 or PyPDF4 fit in,
but they exist and one is even packaged in guix... For clarity, and I
try to say this without laughing, this new package is based on the
very recently released PyPDF 3.2.1.

* Added lzip to native-inputs and upsteam code

* Dropped mono from upstream code

The upstream diffoscope changes were pushed to git upstream, so can
eventually be dropped once diffoscope 233+ is eventually released.

I have less hope for soring out the pypdf versioning madness.

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCY8idjAAKCRDcUY/If5cW
quP+AQD7cNZ584ODqJxJp43e2YRsMw5pR00cuy9mBTZ9mn7t4wD/aphZIhgjwfi/
InIYZFdq94nel/p/hYVaGNVI8ZpcqgA=
=Ca2/
-----END PGP SIGNATURE-----

V
V
Vagrant Cascadian wrote on 19 Jan 2023 02:36
[PATCH 1/2] gnu: Add python-pypdf.
(address . 60941@debbugs.gnu.org)
87edrrz4nd.fsf@contorta
From e2082819efee20a72b026eebcfc14af279e424c7 Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@reproducible-builds.org>
Date: Wed, 18 Jan 2023 16:26:41 -0800
Subject: [PATCH 1/2] gnu: Add python-pypdf.

* gnu/packages/pdf.scm (python-pypdf): New varaible.
---
gnu/packages/pdf.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 4b9d0623fe..cb94c29bde 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -1260,6 +1260,45 @@ (define-public pdf2svg
converter using the Poppler and Cairo libraries.")
(license license:gpl2+)))
+(define-public python-pypdf
+ (package
+ (name "python-pypdf")
+ (version "3.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pypdf" version))
+ (sha256
+ (base32
+ "1pdq4nbkknx61pk8w75jvx5j921m2676wfkyizsrap5mj92cssxc"))))
+ (build-system python-build-system)
+ (arguments
+ (list #:tests? #f ;pypi source does not contains tests
+ #:phases #~(modify-phases %standard-phases
+ (replace 'build
+ (lambda _
+ (invoke "flit" "build")))
+ (replace 'install
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (for-each (lambda (wheel)
+ (invoke "python"
+ "-m"
+ "pip"
+ "install"
+ wheel
+ (string-append "--prefix="
+ #$output)))
+ (find-files "dist" "\\.whl$")))))))
+ (native-inputs (list python-flit))
+ (propagated-inputs (list python-typing-extensions))
+ (home-page "https://github.com/py-pdf/pypdf")
+ (synopsis
+ "A pure-python PDF library")
+ (description
+ "This package provides a pure-python PDF library capable of splitting, merging,
+cropping, and transforming PDF files")
+ (license license:bsd-3)))
+
(define-public python-pypdf2
(package
(name "python-pypdf2")
--
2.39.0
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCY8ietwAKCRDcUY/If5cW
qnW3AQCJsIBepTqyHR97PPA4J7jSJK4tENZx/RbkSczl38lm1QEA7uoTsvr3quIq
g3UQW5lxsI8yVGV7M8MR0X2btBMS7QY=
=M40p
-----END PGP SIGNATURE-----

V
V
Vagrant Cascadian wrote on 19 Jan 2023 02:38
[PATCH 2/2] gnu: diffoscope: Update to 232.
(address . 60941@debbugs.gnu.org)
87a62fz4lj.fsf@contorta
From 784d33dad1ff114e4f8043b7b766c785e7fef79f Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@reproducible-builds.org>
Date: Wed, 18 Jan 2023 11:00:46 -0800
Subject: [PATCH 2/2] gnu: diffoscope: Update to 232.

* gnu/packages/diffoscope.scm (diffoscope): Update to 232.
[native-inputs]: Add lzip and python-pdf, drop python-pypdf2.
[phases]: Add lzip-external-tool and remove-mono-external-tool.
---
gnu/packages/diffoscope.scm | 22 +++++++++++++++++++---
1 file changed, 19 insertions(+), 3 deletions(-)

Toggle diff (63 lines)
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index f730d976fe..59875c2e8e 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -75,7 +75,7 @@ (define-module (gnu packages diffoscope)
(define-public diffoscope
(package
(name "diffoscope")
- (version "224")
+ (version "232")
(source
(origin
(method git-fetch)
@@ -84,7 +84,7 @@ (define-public diffoscope
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1qdivsf4yygg2az5018pw0q4169zas3hfqjydd0q3bhdrfpl0q4q"))
+ (base32 "0zix2m1rlgj7kyx8bkfjb9dnc5idblz6xhmxqq0w3jpnkxxjj8yq"))
(patches
(search-patches "diffoscope-fix-llvm-test.patch"))))
(build-system python-build-system)
@@ -112,6 +112,21 @@ (define-public diffoscope
(string-append "[\"" (which "stat") "\","))
(("\\[\"getfacl\",")
(string-append "[\"" (which "getfacl") "\",")))))
+ (add-after 'unpack 'lzip-external-tool
+ ;; Fixed upstream, remove this phase when updating to
+ ;; diffoscope 233
+ (lambda _
+ (substitute* "diffoscope/external_tools.py"
+ ((".debian.: .lzip.")
+ "\"debian\": \"lzip\", \"guix\": \"lzip\""))))
+ (add-after 'unpack 'remove-mono-external-tool
+ ;; Fixed upstream, remove this phase when updating to
+ ;; diffoscope 233
+ (lambda _
+ (substitute* "diffoscope/external_tools.py"
+ ;; "guix": "mono",
+ ((".guix.: .mono.,")
+ ""))))
(add-after 'build 'build-man-page
(lambda* (#:key (make-flags '()) #:allow-other-keys)
(apply invoke "make" "-C" "doc" make-flags)))
@@ -160,7 +175,7 @@ (define-public diffoscope
python-pytest
python-chardet
python-h5py
- python-pypdf2
+ python-pypdf
python-progressbar33
abootimg
@@ -195,6 +210,7 @@ (define-public diffoscope
libarchive
llvm-9
lz4
+ lzip
ocaml
odt2txt
openssh
--
2.39.0
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCY8ie+AAKCRDcUY/If5cW
ql8qAP9AGfllaFnK0LEg96nnZeyK6Fxa2XEtqqTKWxFykotbzAEA0D7iqvnPrI2H
lz9gFZxosHLS01wI9FDrxXoq5xy2/wY=
=ISJT
-----END PGP SIGNATURE-----

M
M
Maxim Cournoyer wrote on 19 Jan 2023 02:42
Re: [bug#60941] [PATCH 1/2] gnu: Add python-pypdf.
(name . Vagrant Cascadian)(address . vagrant@reproducible-builds.org)(address . 60941@debbugs.gnu.org)
87pmbbe1vw.fsf@gmail.com
Hello,

Vagrant Cascadian <vagrant@reproducible-builds.org> writes:

Toggle quote (30 lines)
> From e2082819efee20a72b026eebcfc14af279e424c7 Mon Sep 17 00:00:00 2001
> From: Vagrant Cascadian <vagrant@reproducible-builds.org>
> Date: Wed, 18 Jan 2023 16:26:41 -0800
> Subject: [PATCH 1/2] gnu: Add python-pypdf.
>
> * gnu/packages/pdf.scm (python-pypdf): New varaible.
> ---
> gnu/packages/pdf.scm | 39 +++++++++++++++++++++++++++++++++++++++
> 1 file changed, 39 insertions(+)
>
> diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
> index 4b9d0623fe..cb94c29bde 100644
> --- a/gnu/packages/pdf.scm
> +++ b/gnu/packages/pdf.scm
> @@ -1260,6 +1260,45 @@ (define-public pdf2svg
> converter using the Poppler and Cairo libraries.")
> (license license:gpl2+)))
>
> +(define-public python-pypdf
> + (package
> + (name "python-pypdf")
> + (version "3.2.1")
> + (source (origin
> + (method url-fetch)
> + (uri (pypi-uri "pypdf" version))
> + (sha256
> + (base32
> + "1pdq4nbkknx61pk8w75jvx5j921m2676wfkyizsrap5mj92cssxc"))))
> + (build-system python-build-system)

You should use pyproject-build-system, which knows how to build a
project from a PEP 517 build system.

Toggle quote (3 lines)
> + (arguments
> + (list #:tests? #f ;pypi source does not contains tests

When this occurs, you can fetch from git instead. Typically Python
packages come with test suites, and this one is no exception.

Toggle quote (22 lines)
> + #:phases #~(modify-phases %standard-phases
> + (replace 'build
> + (lambda _
> + (invoke "flit" "build")))
> + (replace 'install
> + (lambda* (#:key inputs outputs #:allow-other-keys)
> + (add-installed-pythonpath inputs outputs)
> + (for-each (lambda (wheel)
> + (invoke "python"
> + "-m"
> + "pip"
> + "install"
> + wheel
> + (string-append "--prefix="
> + #$output)))
> + (find-files "dist" "\\.whl$")))))))
> + (native-inputs (list python-flit))
> + (propagated-inputs (list python-typing-extensions))
> + (home-page "https://github.com/py-pdf/pypdf")
> + (synopsis
> + "A pure-python PDF library")

guix lint should complain about the leading determinant ("A").

Toggle quote (4 lines)
> + (description
> + "This package provides a pure-python PDF library capable of splitting, merging,
> +cropping, and transforming PDF files")

Missing period, and "pure-python" is odd. Perhaps just "This package
provides a Python PDF library [...]"

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 19 Jan 2023 02:48
Re: bug#60941: Update diffoscope to 232
(name . Vagrant Cascadian)(address . vagrant@reproducible-builds.org)(address . 60941@debbugs.gnu.org)
87lelze1ll.fsf_-_@gmail.com
Hi,

Vagrant Cascadian <vagrant@reproducible-builds.org> writes:

Toggle quote (9 lines)
> From 784d33dad1ff114e4f8043b7b766c785e7fef79f Mon Sep 17 00:00:00 2001
> From: Vagrant Cascadian <vagrant@reproducible-builds.org>
> Date: Wed, 18 Jan 2023 11:00:46 -0800
> Subject: [PATCH 2/2] gnu: diffoscope: Update to 232.
>
> * gnu/packages/diffoscope.scm (diffoscope): Update to 232.
> [native-inputs]: Add lzip and python-pdf, drop python-pypdf2.
> [phases]: Add lzip-external-tool and remove-mono-external-tool.

Nitpick: GNU Change Logs style doesn't use a hanging indent in the left
margin (see: info '(standards) Style of Change Logs').

Toggle quote (34 lines)
> ---
> gnu/packages/diffoscope.scm | 22 +++++++++++++++++++---
> 1 file changed, 19 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
> index f730d976fe..59875c2e8e 100644
> --- a/gnu/packages/diffoscope.scm
> +++ b/gnu/packages/diffoscope.scm
> @@ -75,7 +75,7 @@ (define-module (gnu packages diffoscope)
> (define-public diffoscope
> (package
> (name "diffoscope")
> - (version "224")
> + (version "232")
> (source
> (origin
> (method git-fetch)
> @@ -84,7 +84,7 @@ (define-public diffoscope
> (commit version)))
> (file-name (git-file-name name version))
> (sha256
> - (base32 "1qdivsf4yygg2az5018pw0q4169zas3hfqjydd0q3bhdrfpl0q4q"))
> + (base32 "0zix2m1rlgj7kyx8bkfjb9dnc5idblz6xhmxqq0w3jpnkxxjj8yq"))
> (patches
> (search-patches "diffoscope-fix-llvm-test.patch"))))
> (build-system python-build-system)
> @@ -112,6 +112,21 @@ (define-public diffoscope
> (string-append "[\"" (which "stat") "\","))
> (("\\[\"getfacl\",")
> (string-append "[\"" (which "getfacl") "\",")))))
> + (add-after 'unpack 'lzip-external-tool
> + ;; Fixed upstream, remove this phase when updating to
> + ;; diffoscope 233

nitpick: stand-alone comments should end with a period (complete
sentence).

Toggle quote (15 lines)
> + (lambda _
> + (substitute* "diffoscope/external_tools.py"
> + ((".debian.: .lzip.")
> + "\"debian\": \"lzip\", \"guix\": \"lzip\""))))
> + (add-after 'unpack 'remove-mono-external-tool
> + ;; Fixed upstream, remove this phase when updating to
> + ;; diffoscope 233
> + (lambda _
> + (substitute* "diffoscope/external_tools.py"
> + ;; "guix": "mono",
> + ((".guix.: .mono.,")
> + ""))))
> (add-after 'build 'build-man-page
> (lambda* (#:key (make-flags '()) #:allow-other-keys)

There are no #:make-flags argument for the python or pyproject build
systems, so that's useless.

Toggle quote (19 lines)
> (apply invoke "make" "-C" "doc" make-flags)))
> @@ -160,7 +175,7 @@ (define-public diffoscope
> python-pytest
> python-chardet
> python-h5py
> - python-pypdf2
> + python-pypdf
> python-progressbar33
>
> abootimg
> @@ -195,6 +210,7 @@ (define-public diffoscope
> libarchive
> llvm-9
> lz4
> + lzip
> ocaml
> odt2txt
> openssh

The rest LGTM, thanks for the update!

--
Thanks,
Maxim
V
V
Vagrant Cascadian wrote on 22 Jan 2023 04:26
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 60941@debbugs.gnu.org)
87fsc36yh4.fsf@contorta
On 2023-01-18, Maxim Cournoyer wrote:
Toggle quote (10 lines)
> Vagrant Cascadian <vagrant@reproducible-builds.org> writes:
>> Subject: [PATCH 2/2] gnu: diffoscope: Update to 232.
>>
>> * gnu/packages/diffoscope.scm (diffoscope): Update to 232.
>> [native-inputs]: Add lzip and python-pdf, drop python-pypdf2.
>> [phases]: Add lzip-external-tool and remove-mono-external-tool.
>
> Nitpick: GNU Change Logs style doesn't use a hanging indent in the left
> margin (see: info '(standards) Style of Change Logs').

Wow, I think every single one of my commits to date has that issue... hah!


Toggle quote (4 lines)
>> diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
>> index f730d976fe..59875c2e8e 100644
>> --- a/gnu/packages/diffoscope.scm
>> +++ b/gnu/packages/diffoscope.scm
...
Toggle quote (14 lines)
>> + (add-after 'unpack 'remove-mono-external-tool
>> + ;; Fixed upstream, remove this phase when updating to
>> + ;; diffoscope 233
>> + (lambda _
>> + (substitute* "diffoscope/external_tools.py"
>> + ;; "guix": "mono",
>> + ((".guix.: .mono.,")
>> + ""))))
>> (add-after 'build 'build-man-page
>> (lambda* (#:key (make-flags '()) #:allow-other-keys)
>
> There are no #:make-flags argument for the python or pyproject build
> systems, so that's useless.

I would welcome a fix for that... I could not figure out how to make it
build successfully without it, but that does not say a whole lot. :)

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCY8ys+AAKCRDcUY/If5cW
qn/wAQDCmqsRNOVMJs8/Px1FgyBhFcIPs8bmjGBJEBdnH9s5lQD+MTfx7gAdtSAj
bCZVi+Ed/UK7wQjLGJyRddUfh0c00gg=
=Upr1
-----END PGP SIGNATURE-----

V
V
Vagrant Cascadian wrote on 22 Jan 2023 04:30
[PATCH v2 1/2] gnu: Add python-pypdf.
(address . 60941@debbugs.gnu.org)(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
87bkmr6yad.fsf@contorta
This series switches to pyproject-build-system, git-fetch, and has
tests! Some tests are disabled due to network access requirements and
non-free assets.
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCY8yt6gAKCRDcUY/If5cW
qkalAP9O9Db1R1LYSLcIpVvgGhcr1Or2CJk90EJgbiVDSIAYKwD7BfcJbGa1cELO
1uBSStzk/HwNemjeTyHRL/IGge1wpg4=
=pDTE
-----END PGP SIGNATURE-----

V
V
Vagrant Cascadian wrote on 22 Jan 2023 04:32
[PATCH v2 2/2] gnu: diffoscope: Update to 233.
(address . 60941@debbugs.gnu.org)
878rhv6y7e.fsf@contorta
New upstream version which includes some of the changes monkey-patched
in from the previous version.
From 7d56d84b140931d434c8b0178797de5b93474173 Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@reproducible-builds.org>
Date: Sat, 21 Jan 2023 19:17:46 -0800
Subject: [PATCH 2/2] gnu: diffoscope: Update to 233.

* gnu/packages/diffoscope.scm (diffoscope): Update to 233.
[native-inputs]: Add lzip and python-pdf, drop python-pypdf2.
---
gnu/packages/diffoscope.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (41 lines)
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index f730d976fe..6decb86f02 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -75,7 +75,7 @@ (define-module (gnu packages diffoscope)
(define-public diffoscope
(package
(name "diffoscope")
- (version "224")
+ (version "233")
(source
(origin
(method git-fetch)
@@ -84,7 +84,7 @@ (define-public diffoscope
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1qdivsf4yygg2az5018pw0q4169zas3hfqjydd0q3bhdrfpl0q4q"))
+ (base32 "1m6fc7k8cd7ahra05vqccw1fdbjj6d20vr3q8v67ynnyih5nmbnb"))
(patches
(search-patches "diffoscope-fix-llvm-test.patch"))))
(build-system python-build-system)
@@ -160,7 +160,7 @@ (define-public diffoscope
python-pytest
python-chardet
python-h5py
- python-pypdf2
+ python-pypdf
python-progressbar33
abootimg
@@ -195,6 +195,7 @@ (define-public diffoscope
libarchive
llvm-9
lz4
+ lzip
ocaml
odt2txt
openssh
--
2.39.0
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCY8yuVQAKCRDcUY/If5cW
qoKoAQDuzhXSXTBtXVzEaie9nXM+uVEBoI/mUhx5cbDLdP4acgD9FloBHzIwJnrz
QKhvBzW8p+v78scaggntu0YUmUHAaQM=
=uY9f
-----END PGP SIGNATURE-----

V
V
Vagrant Cascadian wrote on 22 Jan 2023 08:03
Re: [PATCH v3 1/2] gnu: Add python-pypdf.
(address . 60941@debbugs.gnu.org)(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
87ilgzuk38.fsf@contorta
No change.
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCY8zfzAAKCRDcUY/If5cW
quOtAP48C8oh/a7gOUVQH+5r/M+AhdthE+/knTKzd3a8ukd5XgEA0Vk3qrD1J7WX
P+awPkgfldAw9Zq8ApNxImDmCv1yBwg=
=maXQ
-----END PGP SIGNATURE-----

V
V
Vagrant Cascadian wrote on 22 Jan 2023 08:06
Re: [PATCH v3 2/2] gnu: diffoscope: Update to 233.
(address . 60941@debbugs.gnu.org)(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
87edrnujyq.fsf@contorta
Fix typo in commit message (python-pdf -> python-pypdf).

Hopefully patchwork will correctly identify the python-pypdf patch as a
dependency this time...
From 420781d76b8323df36e27dea0cd7561d150f874b Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@reproducible-builds.org>
Date: Sat, 21 Jan 2023 19:17:46 -0800
Subject: [PATCH 2/2] gnu: diffoscope: Update to 233.

* gnu/packages/diffoscope.scm (diffoscope): Update to 233.
[native-inputs]: Add lzip and python-pypdf, drop python-pypdf2.
---
gnu/packages/diffoscope.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (41 lines)
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index f730d976fe..6decb86f02 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -75,7 +75,7 @@ (define-module (gnu packages diffoscope)
(define-public diffoscope
(package
(name "diffoscope")
- (version "224")
+ (version "233")
(source
(origin
(method git-fetch)
@@ -84,7 +84,7 @@ (define-public diffoscope
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1qdivsf4yygg2az5018pw0q4169zas3hfqjydd0q3bhdrfpl0q4q"))
+ (base32 "1m6fc7k8cd7ahra05vqccw1fdbjj6d20vr3q8v67ynnyih5nmbnb"))
(patches
(search-patches "diffoscope-fix-llvm-test.patch"))))
(build-system python-build-system)
@@ -160,7 +160,7 @@ (define-public diffoscope
python-pytest
python-chardet
python-h5py
- python-pypdf2
+ python-pypdf
python-progressbar33
abootimg
@@ -195,6 +195,7 @@ (define-public diffoscope
libarchive
llvm-9
lz4
+ lzip
ocaml
odt2txt
openssh
--
2.39.0
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCY8zgbQAKCRDcUY/If5cW
qpXkAP4s9zl7GVu+9sx9/Ltz9uVXVvr/xIdVMezwFwF/OvbpkgD+IvxUyZ7abp8H
4lgjCyg+S75i01JNv1LSYheNcIwtSAM=
=KAvv
-----END PGP SIGNATURE-----

M
M
Maxim Cournoyer wrote on 23 Jan 2023 02:04
Re: bug#60941: Update diffoscope to 232
(name . Vagrant Cascadian)(address . vagrant@reproducible-builds.org)(address . 60941@debbugs.gnu.org)
87wn5eysb6.fsf@gmail.com
Hi,

Vagrant Cascadian <vagrant@reproducible-builds.org> writes:

[...]

Toggle quote (22 lines)
>>> diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
>>> index f730d976fe..59875c2e8e 100644
>>> --- a/gnu/packages/diffoscope.scm
>>> +++ b/gnu/packages/diffoscope.scm
> ...
>>> + (add-after 'unpack 'remove-mono-external-tool
>>> + ;; Fixed upstream, remove this phase when updating to
>>> + ;; diffoscope 233
>>> + (lambda _
>>> + (substitute* "diffoscope/external_tools.py"
>>> + ;; "guix": "mono",
>>> + ((".guix.: .mono.,")
>>> + ""))))
>>> (add-after 'build 'build-man-page
>>> (lambda* (#:key (make-flags '()) #:allow-other-keys)
>>
>> There are no #:make-flags argument for the python or pyproject build
>> systems, so that's useless.
>
> I would welcome a fix for that... I could not figure out how to make it
> build successfully without it, but that does not say a whole lot. :)

I addressed it in a subsequent commit ("gnu: diffoscope: Simplify the
build-man-page phase.").

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 23 Jan 2023 02:07
Re: [PATCH v3 2/2] gnu: diffoscope: Update to 233.
(name . Vagrant Cascadian)(address . vagrant@reproducible-builds.org)(address . 60941-done@debbugs.gnu.org)
87pmb6ys7d.fsf@gmail.com
Hi,

Vagrant Cascadian <vagrant@reproducible-builds.org> writes:

Toggle quote (13 lines)
> Fix typo in commit message (python-pdf -> python-pypdf).
>
> Hopefully patchwork will correctly identify the python-pypdf patch as a
> dependency this time...
>
> From 420781d76b8323df36e27dea0cd7561d150f874b Mon Sep 17 00:00:00 2001
> From: Vagrant Cascadian <vagrant@reproducible-builds.org>
> Date: Sat, 21 Jan 2023 19:17:46 -0800
> Subject: [PATCH 2/2] gnu: diffoscope: Update to 233.
>
> * gnu/packages/diffoscope.scm (diffoscope): Update to 233.
> [native-inputs]: Add lzip and python-pypdf, drop python-pypdf2.

Applied, along with python-pypdf.

--
Thanks,
Maxim
Closed
?