[patch] gnu: Add r-breakpointrdata and r-breakpointr

  • Done
  • quality assurance status badge
Details
3 participants
  • MadalinIonel.Patrascu@mdc-berlin.de
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
MadalinIonel.Patrascu@mdc-berlin.de
Severity
normal

Debbugs page

MadalinIonel.Patrascu@mdc-berlin.de wrote 2 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
2098d8d186584816ab54d4bf0fae811b@mdc-berlin.de

Attachment: file
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 1/2] gnu: Add r-breakpointrdata.
(address . 60938@debbugs.gnu.org)
20230118173559.73235-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-breakpointrdata): New variable.
---
gnu/packages/bioconductor.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index ca236bcf75..27f8111982 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1291,6 +1291,26 @@ (define-public r-biscuiteerdata
biscuiteer.")
(license license:gpl3)))
+(define-public r-breakpointrdata
+ (package
+ (name "r-breakpointrdata")
+ (version "1.16.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "breakpointRdata" version 'experiment))
+ (sha256
+ (base32
+ "0f23i4ynb4vgn22c3d2l64z92rzv3qnwd4j8qyvalklrxkwilhfn"))))
+ (properties `((upstream-name . "breakpointRdata")))
+ (build-system r-build-system)
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/daewoooo/breakpointRdata")
+ (synopsis "Strand-seq data for demonstration purposes")
+ (description
+ "This packpage is a collection of Strand-seq data. The main pupose is to
+demonstrate functionalities of breakpointR package.")
+ (license license:expat)))
+
(define-public r-celldex
(package
(name "r-celldex")

base-commit: f088763356e88c4911ee933fdafcad6ed66a7aa3
--
2.39.1
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 2/2] gnu: Add r-breakpointr.
(address . 60938@debbugs.gnu.org)
20230118173559.73235-2-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-breakpointr): New variable.
---
gnu/packages/bioconductor.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 27f8111982..5a69aecf18 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -3500,6 +3500,40 @@ (define-public r-biocgenerics
packages.")
(license license:artistic2.0)))
+(define-public r-breakpointr
+ (package
+ (name "r-breakpointr")
+ (version "1.16.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "breakpointR" version))
+ (sha256
+ (base32
+ "0j1f43lhgkapjyxlil9fflqh9nf3andhmvirdcv45y60wvljn4gx"))))
+ (properties `((upstream-name . "breakpointR")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biocgenerics
+ r-breakpointrdata
+ r-cowplot
+ r-doparallel
+ r-foreach
+ r-genomeinfodb
+ r-genomicalignments
+ r-genomicranges
+ r-ggplot2
+ r-gtools
+ r-iranges
+ r-rsamtools
+ r-s4vectors))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/daewoooo/BreakPointR")
+ (synopsis "Find breakpoints in Strand-seq data")
+ (description
+ "This package implements functions for finding breakpoints, plotting and
+export of Strand-seq data.")
+ (license license:expat)))
+
(define-public r-cardelino
(package
(name "r-cardelino")
--
2.39.1
Ricardo Wurmus wrote 2 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 60938-done@debbugs.gnu.org)
87lelzikgb.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (3 lines)
> * gnu/packages/bioconductor.scm (r-breakpointrdata): New variable.
> * gnu/packages/bioconductor.scm (r-breakpointr): New variable.

I applied them both after fixing two typos in the description of
r-breakpointrdata.

Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60938@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60938
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help