[PATCH 0/4] Some bioinfo packages

  • Done
  • quality assurance status badge
Details
2 participants
  • Ricardo Wurmus
  • Simon Tournier
Owner
unassigned
Submitted by
Simon Tournier
Severity
normal
S
S
Simon Tournier wrote on 17 Jan 2023 18:26
(address . guix-patches@gnu.org)(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
20230117172650.1849207-1-zimon.toutoune@gmail.com
Hi,

Here some pacakages used in Bioinformatics.

Note that the package numbat comes with 'bin/pileup_and_phase.R' for preparing
the data, as explained in online documentation [1].

Here, this script goes under 'site-library/numbat/bin' which does not
perfectly match the online documentation mentioning 'numbat/inst/bin/'
instead.


Cheers,
simon

Simon Tournier (4):
gnu: Add python-vireosnp.
gnu: Add r-scistreer.
gnu: Add r-roptim.
gnu: Add r-numbat.

gnu/packages/bioconductor.scm | 106 +++++++++++++++++++++++++++++++-
gnu/packages/bioinformatics.scm | 22 +++++++
gnu/packages/cran.scm | 23 ++++++-
3 files changed, 149 insertions(+), 2 deletions(-)


base-commit: ecda67a577570f412b103e5dd8ed1a44193a9c11
--
2.38.1
S
S
Simon Tournier wrote on 17 Jan 2023 18:30
[PATCH 1/4] gnu: Add python-vireosnp.
(address . 60885@debbugs.gnu.org)(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
20230117173041.1851206-1-zimon.toutoune@gmail.com
* gnu/packages/bioinformatics.scm (python-vireosnp): New variable.
---
gnu/packages/bioinformatics.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index e60dffc21e..5fc2d18690 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -17604,6 +17604,28 @@ (define-public r-kbet
;; Any version of the GPL
(license license:gpl3+))))
+(define-public python-vireosnp
+ (package
+ (name "python-vireosnp")
+ (version "0.5.7")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "vireoSNP" version))
+ (sha256
+ (base32
+ "02ybhzivsxwnb1axlgbs63wni1j27xajnkl4jw1ps5vmsz2l4b0d"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-matplotlib python-numpy python-scipy))
+ (home-page "https://github.com/huangyh09/vireoSNP")
+ (synopsis "Deconvolution based on SNP for multiplexed scRNA-seq data")
+ (description
+ "This package provides a deconvolution based on Single Nucleotide
+Position (SNP) for multiplexed scRNA-seq data. The name vireo stand for
+Variational Inference for Reconstructing Ensemble Origin by expressed SNPs in
+multiplexed scRNA-seq data and follows the clone identification from
+single-cell data named @url{https://github.com/PMBio/cardelino, cardelino}.")
+ (license license:asl2.0)))
+
(define-public ccwl
(package
(name "ccwl")
--
2.38.1
S
S
Simon Tournier wrote on 17 Jan 2023 18:30
[PATCH 2/4] gnu: Add r-scistreer.
(address . 60885@debbugs.gnu.org)(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
20230117173041.1851206-2-zimon.toutoune@gmail.com
* gnu/packages/bioconductor.scm (r-scistreer): New variable.
---
gnu/packages/bioconductor.scm | 39 ++++++++++++++++++++++++++++++++++-
1 file changed, 38 insertions(+), 1 deletion(-)

Toggle diff (59 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index ca236bcf75..3511bfd81a 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2017, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017, 2018, 2019, 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2019, 2020, 2021, 2022 Simon Tournier <zimon.toutoune@gmail.com>
+;;; Copyright © 2019, 2020, 2021, 2022, 2023 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2020 Peter Lo <peterloleungyau@gmail.com>
;;; Copyright © 2020, 2021, 2022 M?d?lin Ionel Patra?cu <madalinionel.patrascu@mdc-berlin.de>
;;; Copyright © 2020 Jakub K?dzio?ka <kuba@kadziolka.net>
@@ -7343,6 +7343,43 @@ (define-public r-scdblfinder
comprehensive scDblFinder method.")
(license license:gpl3)))
+;; This is a CRAN package, but it depends on packages from Bioconductor.
+(define-public r-scistreer
+ (package
+ (name "r-scistreer")
+ (version "1.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "scistreer" version))
+ (sha256
+ (base32
+ "0cdp26ngfp5rxa21nqnj6j2098f6996368g4msb3shh7n75np4s9"))))
+ (properties `((upstream-name . "scistreer")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-ape
+ r-dplyr
+ r-ggplot2
+ r-ggtree
+ r-igraph
+ r-paralleldist
+ r-patchwork
+ r-phangorn
+ r-rcpp
+ r-rcpparmadillo
+ r-rcppparallel
+ r-reshape2
+ r-rhpcblasctl
+ r-stringr
+ r-tidygraph))
+ (home-page "https://github.com/kharchenkolab/scistreer")
+ (synopsis "Maximum-likelihood perfect phylogeny Inference at scale")
+ (description
+ "This packages provides fast maximum-likelihood phylogeny inference from
+noisy single-cell data using the ScisTree algorithm proposed by
+@code{doi.org/10.1093/bioinformatics/btz676, Yufeng Wu (2019)}. It makes the
+method applicable to massive single-cell datasets (>10,000 cells).")
+ (license license:gpl3)))
+
(define-public r-scmap
(package
(name "r-scmap")
--
2.38.1
S
S
Simon Tournier wrote on 17 Jan 2023 18:30
[PATCH 4/4] gnu: Add r-numbat.
(address . 60885@debbugs.gnu.org)(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
20230117173041.1851206-4-zimon.toutoune@gmail.com
* gnu/packages/bioconductor.scm (r-numbat): New variable.
---
gnu/packages/bioconductor.scm | 67 +++++++++++++++++++++++++++++++++++
1 file changed, 67 insertions(+)

Toggle diff (80 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 3511bfd81a..2d6093b238 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -6696,6 +6696,73 @@ (define-public r-mzr
previously been used in XCMS.")
(license license:artistic2.0)))
+;; This is a CRAN package, but it depends on a Bioconductor package.
+(define-public r-numbat
+ (package
+ (name "r-numbat")
+ (version "1.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "numbat" version))
+ (sha256
+ (base32
+ "1jkz24j99cd333mvisp8x5swwr0iyix1kc962d2yx3mv5cn28xdb"))))
+ (properties `((upstream-name . "numbat")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-ape
+ r-catools
+ r-data-table
+ r-dendextend
+ r-dplyr
+ r-genomicranges
+ r-ggplot2
+ r-ggraph
+ r-ggtree
+ r-glue
+ r-igraph
+ r-iranges
+ r-logger
+ r-magrittr
+ r-matrix
+ r-optparse
+ r-paralleldist
+ r-patchwork
+ r-pryr
+ r-purrr
+ r-r-utils
+ r-rcpp
+ r-rcpparmadillo
+ r-rhpcblasctl
+ r-roptim
+ r-scales
+ r-scistreer
+ r-stringr
+ r-tibble
+ r-tidygraph
+ r-tidyr
+ r-vcfr
+ r-zoo))
+ (home-page "https://github.com/kharchenkolab/numbat")
+ (synopsis "Haplotype-aware CNV analysis from scRNA-Seq")
+ (description
+ "This package provides a computational method that infers copy number
+variations (CNV) in cancer scRNA-seq data and reconstructs the tumor
+phylogeny. It integrates signals from gene expression, allelic ratio, and
+population haplotype structures to accurately infer allele-specific CNVs in
+single cells and reconstruct their lineage relationship. It does not require
+tumor/normal-paired DNA or genotype data, but operates solely on the donor
+scRNA-data data (for example, 10x Cell Ranger output). It can be used to:
+
+@enumerate
+@item detect allele-specific copy number variations from single-cells
+@item differentiate tumor versus normal cells in the tumor microenvironment
+@item infer the clonal architecture and evolutionary history of profiled tumors
+@end enumerate
+
+For details on the method see @url{https://doi.org/10.1038/s41587-022-01468-y,
+Gao et al in Nature Biotechnology 2022}.")
+ (license license:expat)))
+
(define-public r-organism-dplyr
(package
(name "r-organism-dplyr")
--
2.38.1
S
S
Simon Tournier wrote on 17 Jan 2023 18:30
[PATCH 3/4] gnu: Add r-roptim.
(address . 60885@debbugs.gnu.org)(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
20230117173041.1851206-3-zimon.toutoune@gmail.com
* gnu/packages/cran.scm (r-roptim): New variable.
---
gnu/packages/cran.scm | 23 ++++++++++++++++++++++-
1 file changed, 22 insertions(+), 1 deletion(-)

Toggle diff (43 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3fcbd3b9f6..aad49b4524 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -31,7 +31,7 @@
;;; Copyright © 2020 Antoine Côté <antoine.cote@posteo.net>
;;; Copyright © 2020 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2020 Magali Lemes <magalilemes00@gmail.com>
-;;; Copyright © 2020, 2021, 2022 Simon Tournier <zimon.toutoune@gmail.com>
+;;; Copyright © 2020, 2021, 2022, 2023 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2020 Aniket Patil <aniket112.patil@gmail.com>
;;; Copyright © 2021 Marcel Schilling <marcel.schilling@uni-luebeck.de>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
@@ -9214,6 +9214,27 @@ (define-public r-randomizr
experimental designs and random samples for common sampling designs.")
(license license:expat)))
+(define-public r-roptim
+ (package
+ (name "r-roptim")
+ (version "0.1.6")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "roptim" version))
+ (sha256
+ (base32
+ "11h6qdi0rsv0bpps6nxkzzapan284q0gldzkmgx3ww5kvnic5w3y"))))
+ (properties `((upstream-name . "roptim")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-rcpp r-rcpparmadillo))
+ (home-page "https://github.com/ypan1988/roptim/")
+ (synopsis "General purpose optimization in R using C++")
+ (description
+ "This package performs optimization in R using C++. A unified wrapper
+interface is provided to call C functions of the five optimization algorithms
+('Nelder-Mead', BFGS', CG', L-BFGS-B and SANN') underlying @code{optim()}.")
+ (license license:gpl2+)))
+
(define-public r-base64url
(package
(name "r-base64url")
--
2.38.1
R
R
Ricardo Wurmus wrote on 20 Jan 2023 10:56
[PATCH 0/4] Some bioinfo packages
(address . 60885-done@debbugs.gnu.org)
87zgadh6k7.fsf@elephly.net
Thank you for the patches! I applied them with very minor changes to
descriptions.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60885@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60885
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch