[PATCH] gnu: Add perl-memory-usage.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 2 years ago
(address . guix-patches@gnu.org)
20230117135309.57301-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/perl.scm (perl-memory-usage): New variable.
---
gnu/packages/perl.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 7cdc052cee..14e4934918 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -34,6 +34,7 @@
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2022 Evgeny Pisemsky <evgeny@pisemsky.com>
;;; Copyright © 2022 gemmaro <gemmaro.dev@gmail.com>
+;;; Copyright © 2023 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6608,6 +6609,30 @@ (define-public perl-memoize-expirelru
the argument to the CACHESIZE parameter, will be cached.")
(license (package-license perl))))
+(define-public perl-memory-usage
+ (package
+ (name "perl-memory-usage")
+ (version "0.201")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/D/DO/DONEILL/Memory-Usage-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0jakrq9yk2njzc5qhbgvp7fi933ir903w3wc3kl4i9s03v9glalg"))))
+ (build-system perl-build-system)
+ (native-inputs
+ (list perl-module-install
+ perl-test-pod
+ perl-test-pod-coverage))
+ (home-page "https://metacpan.org/release/Memory-Usage")
+ (synopsis "Tools to determine actual memory usage")
+ (description
+ "This module lets you attempt to measure, from your operating system's
+perspective, how much memory a process is using at any given time.")
+ (license license:perl-license)))
+
(define-public perl-mime-base64
(package
(name "perl-mime-base64")

base-commit: 29efa2791dafb042ca8ace77bcf8538fb404d492
--
2.38.1
Ricardo Wurmus wrote 2 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 60881-done@debbugs.gnu.org)
87k01fezgj.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (2 lines)
> * gnu/packages/perl.scm (perl-memory-usage): New variable.

Applied, thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60881@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60881
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help