[PATCH] gnu: Add r-rapiclient and r-anvil.

  • Done
  • quality assurance status badge
Details
3 participants
  • MadalinIonel.Patrascu@mdc-berlin.de
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
MadalinIonel.Patrascu@mdc-berlin.de
Severity
normal

Debbugs page

MadalinIonel.Patrascu@mdc-berlin.de wrote 2 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
74d154b3c447432ebf531d0fb7415d91@mdc-berlin.de

Attachment: file
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 2/2] gnu: Add r-anvil.
(address . 60878@debbugs.gnu.org)
20230117131823.55318-2-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-anvil): New variable.
---
gnu/packages/bioconductor.scm | 41 +++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index ca236bcf75..35aed4b62c 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2443,6 +2443,47 @@ (define-public r-animalcules
to understand their data better and discover new insights.")
(license license:artistic2.0)))
+(define-public r-anvil
+ (package
+ (name "r-anvil")
+ (version "1.10.1")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "AnVIL" version))
+ (sha256
+ (base32
+ "0iqsffkrxv28g9cddx2w05f2dbscwxhh6bpizwa8xaxhvn5bcpsv"))))
+ (properties `((upstream-name . "AnVIL")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biocmanager
+ r-dplyr
+ r-dt
+ r-futile-logger
+ r-htmltools
+ r-httr
+ r-jsonlite
+ r-miniui
+ r-rapiclient
+ r-rlang
+ r-shiny
+ r-tibble
+ r-tidyr
+ r-tidyselect))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/AnVIL")
+ (synopsis "Provides access to AnVIL, Terra, Leonardo and other projects")
+ (description
+ "The AnVIL is a cloud computing resource developed in part by the National
+Human Genome Research Institute. The AnVIL package provides end-user and developer
+functionality. For the end-user, AnVIL provides fast binary package installation,
+utitlities for working with Terra/AnVIL table and data resources, and convenient
+functions for file movement to and from Google cloud storage. For developers,
+AnVIL provides programatic access to the Terra, Leonardo, Rawls, Dockstore, and
+Gen3 RESTful programming interface, including helper functions to transform JSON
+responses to formats more amenable to manipulation in R.")
+ (license license:artistic2.0)))
+
(define-public r-aldex2
(package
(name "r-aldex2")
--
2.38.1
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 1/2] gnu: Add r-rapiclient.
(address . 60878@debbugs.gnu.org)
20230117131823.55318-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-rapiclient): New variable.
---
gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3fcbd3b9f6..1914c9d85a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -10252,6 +10252,30 @@ (define-public r-collapsibletree
the source data frame.")
(license license:gpl3+)))
+(define-public r-rapiclient
+ (package
+ (name "r-rapiclient")
+ (version "0.1.3")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "rapiclient" version))
+ (sha256
+ (base32
+ "1pm4kdga2nz1cpmchdb0ad8gr3bqfm84b1kl32cyc0x3x5rr2syz"))))
+ (properties `((upstream-name . "rapiclient")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-httr
+ r-jsonlite
+ r-yaml))
+ (home-page "https://github.com/bergant/rapiclient")
+ (synopsis "Dynamic OpenAPI/Swagger client")
+ (description
+ "This package access services specified in OpenAPI (formerly Swagger) format.
+It is not a code generator. The client is generated dynamically as a list of R
+functions.")
+ (license license:expat)))
+
(define-public r-rappdirs
(package
(name "r-rappdirs")

base-commit: 29efa2791dafb042ca8ace77bcf8538fb404d492
--
2.38.1
Ricardo Wurmus wrote 2 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 60878-done@debbugs.gnu.org)
87o7qrf0fz.fsf@elephly.net
Hi Mădălin,

I applied this series after minor changes to the descriptions.
Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60878@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60878
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help