[PATCH] gnu: Add r-baseline, r-missforest, r-speaq and r-alpsnmr

  • Done
  • quality assurance status badge
Details
3 participants
  • MadalinIonel.Patrascu@mdc-berlin.de
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
MadalinIonel.Patrascu@mdc-berlin.de
Severity
normal

Debbugs page

MadalinIonel.Patrascu@mdc-berlin.de wrote 2 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
e24e3bb057c945438fa5f5668efe7262@mdc-berlin.de

Attachment: file
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 1/4] gnu: Add r-baseline.
(address . 60877@debbugs.gnu.org)
20230117122538.41537-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-baseline): New variable.
---
gnu/packages/cran.scm | 27 ++++++++++++++++++++++++++-
1 file changed, 26 insertions(+), 1 deletion(-)

Toggle diff (49 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3fcbd3b9f6..53f3ebbcf5 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2018 Sandeep Subramanian <sandeepsubramanian94@gmail.com>
;;; Copyright © 2018 Charlie Ritter <chewzeirta@posteo.net>
;;; Copyright © 2018 Konrad Hinsen <konrad.hinsen@fastmail.net>
-;;; Copyright © 2018, 2020, 2021, 2022 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
+;;; Copyright © 2018, 2020-2023 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
;;; Copyright © 2018 Laura Lazzati <laura.lazzati.15@gmail.com>
;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
@@ -9241,6 +9241,31 @@ (define-public r-base64url
systems.")
(license license:gpl3)))
+(define-public r-baseline
+ (package
+ (name "r-baseline")
+ (version "1.3-4")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "baseline" version))
+ (sha256
+ (base32
+ "1kl68zvyi2zd73jy3axrvrymwn4y6l4pd62nz0fciwbgkjhz3yyx"))))
+ (properties `((upstream-name . "baseline")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-limsolve r-sparsem))
+ (home-page "https://github.com/khliland/baseline/")
+ (synopsis "Baseline correction of spectra")
+ (description
+ "This package is a collection of baseline correction algorithms. Beside
+those it provides a framework and a Tcl/Tk enabled GUI for optimizing baseline
+algorithm parameters. Typical use is the removal of the background effects from
+spectra, which are originating from various types of spectroscopy and spectrometry.
+Also, there is a possibility of optimizing this with regard to regression or
+classification results. Correction methods include polynomial fitting, weighted
+local smoothers and many more.")
+ (license license:gpl2)))
+
(define-public r-radiant-data
(package
(name "r-radiant-data")

base-commit: 789d73234d5b6bbd83bb054146d5bbd1d374d51a
--
2.38.1
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 2/4] gnu: Add r-missforest.
(address . 60877@debbugs.gnu.org)
20230117122538.41537-2-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-missforest): New variable.
---
gnu/packages/cran.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 53f3ebbcf5..6ae5b96eb2 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -15227,6 +15227,36 @@ (define-public r-misc3d
;; Any version of the GPL.
(license (list license:gpl2+ license:gpl3+))))
+(define-public r-missforest
+ (package
+ (name "r-missforest")
+ (version "1.5")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "missForest" version))
+ (sha256
+ (base32
+ "13c38hpl60ca1kwyv61cxsla6ccmsj4qzp0vrxcq7b827fh5aw21"))))
+ (properties `((upstream-name . "missForest")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-dorng
+ r-foreach
+ r-iterators
+ r-itertools
+ r-randomforest))
+ (home-page "https://github.com/stekhoven/missForest")
+ (synopsis "Nonparametric missing value imputation using Random Forest")
+ (description
+ "The function @code{missForest} in this package is used to impute missing
+values, particularly in the case of mixed-type data. It uses a random forest
+trained on the observed values of a data matrix to predict the missing values.
+It can be used to impute continuous and/or categorical data, including complex
+interactions and non-linear relations. It yields an @acronym{OOB, out-of-bag}
+imputation error estimate without the need of a test set or elaborate cross-
+validation. It can be run in parallel to save computation time.")
+ (license license:gpl2+)))
+
(define-public r-ks
(package
(name "r-ks")
--
2.38.1
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 3/4] gnu: Add r-speaq.
(address . 60877@debbugs.gnu.org)
20230117122538.41537-3-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-speaq): New variable.
---
gnu/packages/bioconductor.scm | 42 ++++++++++++++++++++++++++++++++++-
1 file changed, 41 insertions(+), 1 deletion(-)

Toggle diff (62 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index c2fa26cb59..7498c3a767 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2017, 2018, 2019, 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019, 2020, 2021, 2022 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2020 Peter Lo <peterloleungyau@gmail.com>
-;;; Copyright © 2020, 2021, 2022 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
+;;; Copyright © 2020-2023 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2021 Hong Li <hli@mdc-berlin.de>
;;; Copyright © 2021 Tim Howes <timhowes@lavabit.com>
@@ -7624,6 +7624,46 @@ (define-public r-slingshot
graph construction.")
(license license:artistic2.0)))
+;; This is a CRAN package but it depends on a bionconductor package.
+(define-public r-speaq
+ (package
+ (name "r-speaq")
+ (version "2.7.0")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "speaq" version))
+ (sha256
+ (base32
+ "0z9a3nbfazphp090c6hg892vjq7jp4g4cij3s5wbs1q567inbmlk"))))
+ (properties `((upstream-name . "speaq")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-cluster
+ r-data-table
+ r-dosnow
+ r-foreach
+ r-ggplot2
+ r-gridextra
+ r-impute
+ r-massspecwavelet
+ r-missforest
+ r-reshape2
+ r-rfast
+ r-rvest
+ r-xml2))
+ (native-inputs (list r-knitr))
+ (home-page "https://cran.r-project.org/package=speaq")
+ (synopsis "Tools for nuclear magnetic resonance spectra alignment")
+ (description
+ "This package helps with @acronym{NMR, Nuclear Magnetic Resonance} spectroscopy
+data analysis as easy as possible. It only requires a small set of functions to
+perform an entire analysis. Speaq offers the possibility of raw spectra alignment
+and quantitation but also an analysis based on features whereby the spectra are
+converted to peaks which are then grouped and turned into features. These features
+can be processed with any number of statistical tools either included in speaq
+or available elsewhere on CRAN.")
+ (license license:asl2.0)))
+
(define-public r-stager
(package
(name "r-stager")
--
2.38.1
Mădălin Ionel Patrașcu wrote 2 years ago
[PATCH 4/4] gnu: Add r-alpsnmr.
(address . 60877@debbugs.gnu.org)
20230117122538.41537-4-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-alpsnmr): New variable.
---
gnu/packages/bioconductor.scm | 53 +++++++++++++++++++++++++++++++++++
1 file changed, 53 insertions(+)

Toggle diff (66 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 7498c3a767..118f218f4b 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2598,6 +2598,59 @@ (define-public r-alpine
data.")
(license license:gpl2+)))
+(define-public r-alpsnmr
+ (package
+ (name "r-alpsnmr")
+ (version "4.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "AlpsNMR" version))
+ (sha256
+ (base32
+ "1y4qqc6l8flv5ns4qwzjwmcykm6zcm4jg097mn8xyp7mnxymy7pl"))))
+ (properties `((upstream-name . "AlpsNMR")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-baseline
+ r-biocparallel
+ r-dplyr
+ r-fs
+ r-future
+ r-generics
+ r-ggplot2
+ r-glue
+ r-htmltools
+ r-magrittr
+ r-matrixstats
+ r-mixomics
+ r-pcapp
+ r-purrr
+ r-readxl
+ r-reshape2
+ r-rlang
+ r-rmarkdown
+ r-scales
+ r-signal
+ r-speaq
+ r-stringr
+ r-tibble
+ r-tidyr
+ r-tidyselect
+ r-vctrs))
+ (native-inputs (list r-knitr))
+ (home-page "https://sipss.github.io/AlpsNMR/")
+ (synopsis "Automated spectral processing system for NMR")
+ (description
+ "This package reads Bruker @acronym{NMR, Nuclear Magnetic Resonance} data
+directories both zipped and unzipped. It provides automated and efficient signal
+processing for untargeted NMR metabolomics. It is able to interpolate the samples,
+detect outliers, exclude regions, normalize, detect peaks, align the spectra,
+integrate peaks, manage metadata and visualize the spectra. After spectra
+proccessing, it can apply multivariate analysis on extracted data. Efficient
+plotting with 1-D data is also available. Basic reading of 1D ACD/Labs exported
+JDX samples is also available.")
+ (license license:expat)))
+
(define-public r-altcdfenvs
(package
(name "r-altcdfenvs")
--
2.38.1
Ricardo Wurmus wrote 2 years ago
Re: [bug#60877] [PATCH 1/4] gnu: Add r-baseline.
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 60877-done@debbugs.gnu.org)
87sfg3f0ow.fsf@elephly.net
Hi Mădălin,

Toggle quote (2 lines)
> * gnu/packages/cran.scm (r-baseline): New variable.

Thanks for the patches.

The r-baseline package actually needs an additional input for the GUI.
I packaged gWidgets2tcltk and added it as an input. (The GTK variant
has been archived on CRAN because RGtk has been abandoned.)

I fixed a typo in a description and pushed. Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60877@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60877
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help