Andy Tai wrote 2 years ago
(address . guix-patches@gnu.org)
From e8ded4d8f7a3741595e5e2ec7c61e2addc575dd9 Mon Sep 17 00:00:00 2001
From: Andy Tai <atai@atai.org>
Date: Mon, 16 Jan 2023 08:35:34 -0800
Subject: [PATCH] gnu: octave: Update to 7.3.0
* gnu/packages/maths.scm (octave): Update to 7.3.0
---
gnu/packages/maths.scm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
Toggle diff (42 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index d9bc2922c5..ef747569ae 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2850,7 +2850,7 @@ (define (compile-file top-dir)
(define-public octave-cli
(package
(name "octave-cli")
- (version "7.2.0")
+ (version "7.3.0")
(source
(origin
(method url-fetch)
@@ -2858,7 +2858,7 @@ (define-public octave-cli
version ".tar.xz"))
(sha256
(base32
- "0w81ncl9d4x1ay3ylsag87k20c0byiyjcmfd9kb7b7ylr71pivsa"))))
+ "1wap9p9imxxqpnm27rxcvpjahk1wg440lzlygjb6iyncxdmfw255"))))
(build-system gnu-build-system)
(inputs
`(("alsa-lib" ,alsa-lib)
@@ -2890,7 +2890,6 @@ (define-public octave-cli
("qhull" ,qhull)
("readline" ,readline)
("suitesparse" ,suitesparse)
- ("texinfo" ,texinfo)
("zlib" ,zlib)))
(native-inputs
(list gfortran
@@ -2905,7 +2904,8 @@ (define-public octave-cli
;; provide.
less
ghostscript
- gnuplot))
+ gnuplot
+ texinfo))
;; Octave code uses this variable to detect directories holding multiple CA
;; certificates to verify peers with. This is required for the networking
;; functions that require encryption to work properly.
--
2.38.1