[PATCH staging] gnu: shared-mime-info: Update to 2.2.

  • Open
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Bruno Victal
Owner
unassigned
Submitted by
Bruno Victal
Severity
normal
B
B
Bruno Victal wrote on 15 Jan 03:32 +0100
(address . guix-patches@gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
c8c976b9d2598c46cc0c688095aabf9db43650d9.1673749940.git.mirai@makinata.eu
* gnu/packages/gnome.scm (shared-mime-info): Update to 2.2.
[source]: Switch to git source.
[build-system]: Switch to meson.
[arguments]: Enable parallel builds. Patch source for docbook-xml.
[native-inputs]: Switch to new style. Add python, perl, xmlto,
docbook-xml-4.1.2 and docbook-xsl.
---
gnu/packages/gnome.scm | 39 ++++++++++++++++++++++++++-------------
1 file changed, 26 insertions(+), 13 deletions(-)

Toggle diff (68 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 09b8056cc9..aedd1df17f 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -73,6 +73,7 @@
;;; Copyright © 2022 Rene Saavedra <nanuui@protonmail.com>
;;; Copyright © 2022 Alexandros Theodotou <alex@zrythm.org>
;;; Copyright © 2022 Arjan Adriaanse <arjan@adriaan.se>
+;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2920,26 +2921,38 @@ (define-public tango-icon-theme
(define-public shared-mime-info
(package
(name "shared-mime-info")
- (version "1.15")
+ (version "2.2")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://gitlab.freedesktop.org/xdg/shared-mime-info/uploads/"
- "b27eb88e4155d8fccb8bb3cd12025d5b/shared-mime-info-" version
- ".tar.xz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/xdg/shared-mime-info.git")
+ ;; XXX: needs to fetch submodule 'xdgmime' which is not independent
+ (recursive? #t)
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "146vynj78wcwdq0ms52jzm1r4m6dzi1rhyh3h4xyb6bw8ckv10pl"))))
- (build-system gnu-build-system)
+ "04dfnnflspprxg7qia3whz1754lfvgi4ihvmihg379936zy5xd22"))))
(arguments
- ;; The build system appears not to be parallel-safe.
- '(#:parallel-build? #f))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; FIXME: xdgmime presence is required for building but
+ ;; it can also be built to provide additional tests.
+ (add-after 'unpack 'patch-docbook-xml
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; FIXME: xmlto fails to find docbook DTDs because
+ ;; there's no xmlcatalog available for docbook-4.1.2.
+ ;; Modify the man XML otherwise xmlto tries to access the network
+ (substitute* "data/shared-mime-info-spec.xml"
+ (("http://www.oasis-open.org/docbook/xml/4.1.2/")
+ (string-append #$docbook-xml "/xml/dtd/docbook/"))))))))
+ (build-system meson-build-system)
(inputs
(list glib libxml2))
(native-inputs
- `(("gettext" ,gettext-minimal)
- ("itstool" ,itstool)
- ("pkg-config" ,pkg-config)))
+ (list gettext-minimal itstool pkg-config python perl xmlto
+ docbook-xml-4.1.2 docbook-xsl))
(home-page "https://www.freedesktop.org/wiki/Software/shared-mime-info")
(synopsis "Database of common MIME types")
(description

base-commit: d9bcd1a8d6300b79f5884e48b2cefff05de8dce4
--
2.38.1
M
M
Maxim Cournoyer wrote on 22 Mar 01:52 +0100
(name . Bruno Victal)(address . mirai@makinata.eu)(address . 60826@debbugs.gnu.org)
87pm91li9b.fsf@gmail.com
Hi!

Bruno Victal <mirai@makinata.eu> writes:

Toggle quote (39 lines)
> * gnu/packages/gnome.scm (shared-mime-info): Update to 2.2.
> [source]: Switch to git source.
> [build-system]: Switch to meson.
> [arguments]: Enable parallel builds. Patch source for docbook-xml.
> [native-inputs]: Switch to new style. Add python, perl, xmlto,
> docbook-xml-4.1.2 and docbook-xsl.
> ---
> gnu/packages/gnome.scm | 39 ++++++++++++++++++++++++++-------------
> 1 file changed, 26 insertions(+), 13 deletions(-)
>
> diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
> index 09b8056cc9..aedd1df17f 100644
> --- a/gnu/packages/gnome.scm
> +++ b/gnu/packages/gnome.scm
> @@ -73,6 +73,7 @@
> ;;; Copyright © 2022 Rene Saavedra <nanuui@protonmail.com>
> ;;; Copyright © 2022 Alexandros Theodotou <alex@zrythm.org>
> ;;; Copyright © 2022 Arjan Adriaanse <arjan@adriaan.se>
> +;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -2920,26 +2921,38 @@ (define-public tango-icon-theme
> (define-public shared-mime-info
> (package
> (name "shared-mime-info")
> - (version "1.15")
> + (version "2.2")
> (source (origin
> - (method url-fetch)
> - (uri (string-append
> - "https://gitlab.freedesktop.org/xdg/shared-mime-info/uploads/"
> - "b27eb88e4155d8fccb8bb3cd12025d5b/shared-mime-info-" version
> - ".tar.xz"))
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://gitlab.freedesktop.org/xdg/shared-mime-info.git")
> + ;; XXX: needs to fetch submodule 'xdgmime' which is not independent

What do you mean by "not independent"; do you mean that it's been
patched/customized by this project?

Toggle quote (17 lines)
> + (recursive? #t)
> + (commit version)))
> + (file-name (git-file-name name version))
> (sha256
> (base32
> - "146vynj78wcwdq0ms52jzm1r4m6dzi1rhyh3h4xyb6bw8ckv10pl"))))
> - (build-system gnu-build-system)
> + "04dfnnflspprxg7qia3whz1754lfvgi4ihvmihg379936zy5xd22"))))
> (arguments
> - ;; The build system appears not to be parallel-safe.
> - '(#:parallel-build? #f))
> + (list
> + #:phases
> + #~(modify-phases %standard-phases
> + ;; FIXME: xdgmime presence is required for building but
> + ;; it can also be built to provide additional tests.

Sorry, but I don't understand; could you try rephrase that comment? :-)

Toggle quote (6 lines)
> + (add-after 'unpack 'patch-docbook-xml
> + (lambda* (#:key inputs #:allow-other-keys)
> + ;; FIXME: xmlto fails to find docbook DTDs because
> + ;; there's no xmlcatalog available for docbook-4.1.2.
> + ;; Modify the man XML otherwise xmlto tries to access the network

The last sentence of the comment misses a period.

Toggle quote (16 lines)
> + (substitute* "data/shared-mime-info-spec.xml"
> + (("http://www.oasis-open.org/docbook/xml/4.1.2/")
> + (string-append #$docbook-xml "/xml/dtd/docbook/"))))))))
> + (build-system meson-build-system)
> (inputs
> (list glib libxml2))
> (native-inputs
> - `(("gettext" ,gettext-minimal)
> - ("itstool" ,itstool)
> - ("pkg-config" ,pkg-config)))
> + (list gettext-minimal itstool pkg-config python perl xmlto
> + docbook-xml-4.1.2 docbook-xsl))
> (home-page "https://www.freedesktop.org/wiki/Software/shared-mime-info")
> (synopsis "Database of common MIME types")
> (description

--
Thanks,
Maxim
?