[PATCH core-updates] Update and wrap perl-xml-xpath.

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Bruno Victal
Owner
unassigned
Submitted by
Bruno Victal
Severity
normal
B
B
Bruno Victal wrote on 15 Jan 2023 02:20
[PATCH 1/2] gnu: perl-xml-xpath: Wrap xpath command.
(address . guix-patches@gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
024ddbe123ad4d22ca508e1cb998da48fb16338b.1673745598.git.mirai@makinata.eu
* gnu/packages/xml.scm (perl-xml-xpath)[arguments]: Wrap xpath.
[description]: Document xpath command presence.
---
gnu/packages/xml.scm | 13 ++++++++++++-
1 file changed, 12 insertions(+), 1 deletion(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index b5065f9f30..7fdc3a2e32 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -33,6 +33,7 @@
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 David Larsson <david.larsson@selfhosted.xyz>
;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
+;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1050,6 +1051,16 @@ (define-public perl-xml-xpath
(base32
"03yxj7w5a43ibbpiqsvb3lswj2b71dydsx4rs2fw0p8n0l3i3j8w"))))
(build-system perl-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'wrap 'wrap-xpath
+ (lambda _
+ (wrap-program (string-append #$output "/bin/xpath")
+ `("PERL5LIB" ":" prefix
+ ,(cons (string-append #$output "/lib/perl5/site_perl")
+ (string-split (getenv "PERL5LIB") #\:)))))))))
(native-inputs
(list perl-path-tiny))
(propagated-inputs
@@ -1059,7 +1070,7 @@ (define-public perl-xml-xpath
(description
"This module aims to comply exactly to the @url{XPath specification,
https://www.w3.org/TR/xpath} and yet allow extensions to be added in
-the form of functions.")
+the form of functions. It also provides the command @command{xpath}.")
(license license:perl-license)))
(define-public pugixml

base-commit: fb3085e80fd3d4559057b60d9e2c1c1f1ff51022
--
2.38.1
B
B
Bruno Victal wrote on 15 Jan 2023 02:22
[PATCH 2/2] gnu: perl-xml-xpath: Update to 1.48.
(address . 60824@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
8643dd63470d549c2e48ec0d465c5663e919bbd5.1673745598.git.mirai@makinata.eu
* gnu/packages/xml.scm (perl-xml-xpath): Update to 1.48.
---
gnu/packages/xml.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 7fdc3a2e32..e022932782 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1042,14 +1042,14 @@ (define-public perl-xml-feed
(define-public perl-xml-xpath
(package
(name "perl-xml-xpath")
- (version "1.44")
+ (version "1.48")
(source (origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/M/MA/MANWAR/"
"XML-XPath-" version ".tar.gz"))
(sha256
(base32
- "03yxj7w5a43ibbpiqsvb3lswj2b71dydsx4rs2fw0p8n0l3i3j8w"))))
+ "1kch6w4zk7rzfimbwakz8qyhjhrvnp97158af0p5p7i3dgimpivv"))))
(build-system perl-build-system)
(arguments
(list
--
2.38.1
B
B
Bruno Victal wrote on 6 May 2023 18:07
bump
(address . 60824@debbugs.gnu.org)
05dc577a-df3e-30a8-58b6-3ddbcd9155f3@makinata.eu
Patch still applies to master (1cb0dee3a31c6d235389d4d9787fa583c2babc30)
B
B
Bruno Victal wrote on 18 May 2023 19:33
[PATCH v2 1/2] gnu: perl-xml-xpath: Wrap xpath command.
(address . 60824@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
1b22f02d1d3237a361262b9fcc8ecbf43e935c20.1684431164.git.mirai@makinata.eu
* gnu/packages/xml.scm (perl-xml-xpath)[arguments]: Wrap xpath.
[description]: Document xpath command presence.
---
gnu/packages/xml.scm | 13 ++++++++++++-
1 file changed, 12 insertions(+), 1 deletion(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 2bc4f66c01..3c94937f49 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -33,6 +33,7 @@
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 David Larsson <david.larsson@selfhosted.xyz>
;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
+;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1044,6 +1045,16 @@ (define-public perl-xml-xpath
(base32
"03yxj7w5a43ibbpiqsvb3lswj2b71dydsx4rs2fw0p8n0l3i3j8w"))))
(build-system perl-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'wrap 'wrap-xpath
+ (lambda _
+ (wrap-program (string-append #$output "/bin/xpath")
+ `("PERL5LIB" ":" prefix
+ ,(cons (string-append #$output "/lib/perl5/site_perl")
+ (string-split (getenv "PERL5LIB") #\:)))))))))
(native-inputs
(list perl-path-tiny))
(propagated-inputs
@@ -1053,7 +1064,7 @@ (define-public perl-xml-xpath
(description
"This module aims to comply exactly to the @url{XPath specification,
https://www.w3.org/TR/xpath} and yet allow extensions to be added in
-the form of functions.")
+the form of functions. It also provides the command @command{xpath}.")
(license license:perl-license)))
(define-public pugixml

base-commit: 5b700945fb0b33eec410de8979cae2fbf0d4f118
--
2.39.2
B
B
Bruno Victal wrote on 18 May 2023 19:33
[PATCH v2 2/2] gnu: perl-xml-xpath: Update to 1.48.
(address . 60824@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
13b4b7b1ffb95f83f4bda93628a4b24cbd1ae9fe.1684431164.git.mirai@makinata.eu
* gnu/packages/xml.scm (perl-xml-xpath): Update to 1.48.
---
gnu/packages/xml.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 3c94937f49..c1cc561ccd 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1036,14 +1036,14 @@ (define-public perl-xml-feed
(define-public perl-xml-xpath
(package
(name "perl-xml-xpath")
- (version "1.44")
+ (version "1.48")
(source (origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/M/MA/MANWAR/"
"XML-XPath-" version ".tar.gz"))
(sha256
(base32
- "03yxj7w5a43ibbpiqsvb3lswj2b71dydsx4rs2fw0p8n0l3i3j8w"))))
+ "1kch6w4zk7rzfimbwakz8qyhjhrvnp97158af0p5p7i3dgimpivv"))))
(build-system perl-build-system)
(arguments
(list
--
2.39.2
B
B
Bruno Victal wrote on 27 May 2023 20:11
[PATCH v3 1/2] gnu: perl-xml-xpath: Wrap xpath command.
(address . 60824@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
d3ab57bfdc7ce7bca845722dcab9d67d7483454f.1685211087.git.mirai@makinata.eu
* gnu/packages/xml.scm (perl-xml-xpath)[arguments]: Wrap xpath. Add test for
wrapped xpath.
[description]: Document xpath command presence.
---

Notable changes since v2:
* Wrap xpath minimally.
* Add a phase to check if the wrapped xpath works.
* Add missing test dependency.

gnu/packages/xml.scm | 25 ++++++++++++++++++++++++-
1 file changed, 24 insertions(+), 1 deletion(-)

Toggle diff (54 lines)
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 2bc4f66c01..ec622cec63 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -33,6 +33,7 @@
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 David Larsson <david.larsson@selfhosted.xyz>
;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
+;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1044,6 +1045,28 @@ (define-public perl-xml-xpath
(base32
"03yxj7w5a43ibbpiqsvb3lswj2b71dydsx4rs2fw0p8n0l3i3j8w"))))
(build-system perl-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'wrap 'wrap-xpath
+ (lambda _
+ (let ((xpath (string-append #$output "/bin/xpath"))
+ (perl5lib
+ (list #$@(map (lambda (i)
+ (file-append (this-package-input i)
+ "/lib/perl5/site_perl"))
+ '("perl-xml-parser"))
+ (string-append #$output
+ "/lib/perl5/site_perl/"
+ #$(package-version perl)))))
+ (wrap-program xpath
+ `("PERL5LIB" ":" prefix ,perl5lib)))))
+ (add-after 'wrap-xpath 'check-wrap
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (unsetenv "PERL5LIB")
+ (invoke/quiet (string-append #$output "/bin/xpath"))))))))
(native-inputs
(list perl-path-tiny))
(propagated-inputs
@@ -1053,7 +1076,7 @@ (define-public perl-xml-xpath
(description
"This module aims to comply exactly to the @url{XPath specification,
https://www.w3.org/TR/xpath} and yet allow extensions to be added in
-the form of functions.")
+the form of functions. It also provides the command @command{xpath}.")
(license license:perl-license)))
(define-public pugixml

base-commit: b96b82bcd4bc24529941ff74a91432481f1a71b5
--
2.39.2
B
B
Bruno Victal wrote on 27 May 2023 20:11
[PATCH v3 2/2] gnu: perl-xml-xpath: Update to 1.48.
(address . 60824@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
4995325d5906f63d65deaf9370742c6f951758c6.1685211087.git.mirai@makinata.eu
* gnu/packages/xml.scm (perl-xml-xpath): Update to 1.48.
[native-inputs]: Add perl-test-leaktrace.
---
gnu/packages/xml.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index ec622cec63..5f0290d007 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1036,14 +1036,14 @@ (define-public perl-xml-feed
(define-public perl-xml-xpath
(package
(name "perl-xml-xpath")
- (version "1.44")
+ (version "1.48")
(source (origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/M/MA/MANWAR/"
"XML-XPath-" version ".tar.gz"))
(sha256
(base32
- "03yxj7w5a43ibbpiqsvb3lswj2b71dydsx4rs2fw0p8n0l3i3j8w"))))
+ "1kch6w4zk7rzfimbwakz8qyhjhrvnp97158af0p5p7i3dgimpivv"))))
(build-system perl-build-system)
(arguments
(list
@@ -1068,7 +1068,7 @@ (define-public perl-xml-xpath
(unsetenv "PERL5LIB")
(invoke/quiet (string-append #$output "/bin/xpath"))))))))
(native-inputs
- (list perl-path-tiny))
+ (list perl-path-tiny perl-test-leaktrace))
(propagated-inputs
(list perl-xml-parser))
(home-page "https://metacpan.org/release/XML-XPath")
--
2.39.2
B
B
Bruno Victal wrote on 24 Aug 2023 18:07
[PATCH core-updates v4 0/2] Wrap and upgrade perl-xml-xpath
(address . 60824@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
cover.1692892804.git.mirai@makinata.eu
Notable changes since v3:
* Rebased against core-updates.
* Use search-path-as-list for wrapping.

Bruno Victal (2):
gnu: perl-xml-xpath: Wrap xpath command.
gnu: perl-xml-xpath: Update to 1.48.

gnu/packages/xml.scm | 28 ++++++++++++++++++++++++----
1 file changed, 24 insertions(+), 4 deletions(-)


base-commit: c365cc69881f3aec633b88ba22c7fe8faec3597e
--
2.41.0
B
B
Bruno Victal wrote on 24 Aug 2023 18:08
[PATCH core-updates v4 1/2] gnu: perl-xml-xpath: Wrap xpath command.
(address . 60824@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
523126c228f088aa1fccf0ed28c47593f94b27bf.1692893331.git.mirai@makinata.eu
* gnu/packages/xml.scm (perl-xml-xpath)[arguments]: Wrap xpath. Add test for
wrapped xpath.
[description]: Document xpath command presence.
---
gnu/packages/xml.scm | 22 +++++++++++++++++++++-
1 file changed, 21 insertions(+), 1 deletion(-)

Toggle diff (51 lines)
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 555f0ab624..ca7aaf29ed 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -33,6 +33,7 @@
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 David Larsson <david.larsson@selfhosted.xyz>
;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
+;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1044,6 +1045,25 @@ (define-public perl-xml-xpath
(base32
"03yxj7w5a43ibbpiqsvb3lswj2b71dydsx4rs2fw0p8n0l3i3j8w"))))
(build-system perl-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'wrap 'wrap-xpath
+ (lambda _
+ (let ((xpath (string-append #$output "/bin/xpath"))
+ (perl5lib
+ (search-path-as-list
+ '("/lib/perl5/site_perl")
+ (list #$(this-package-input "perl-xml-parser")
+ #$output))))
+ (wrap-program xpath
+ `("PERL5LIB" ":" prefix ,perl5lib)))))
+ (add-after 'wrap-xpath 'check-wrap
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (unsetenv "PERL5LIB")
+ (invoke/quiet (string-append #$output "/bin/xpath"))))))))
(native-inputs
(list perl-path-tiny))
(propagated-inputs
@@ -1053,7 +1073,7 @@ (define-public perl-xml-xpath
(description
"This module aims to comply exactly to the @url{XPath specification,
https://www.w3.org/TR/xpath} and yet allow extensions to be added in
-the form of functions.")
+the form of functions. It also provides the command @command{xpath}.")
(license license:perl-license)))
(define-public pugixml

base-commit: c365cc69881f3aec633b88ba22c7fe8faec3597e
--
2.40.1
B
B
Bruno Victal wrote on 24 Aug 2023 18:08
[PATCH core-updates v4 2/2] gnu: perl-xml-xpath: Update to 1.48.
(address . 60824@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
eb7633ea2f76d8315aaa9de28f6b4ec1b6397691.1692893331.git.mirai@makinata.eu
* gnu/packages/xml.scm (perl-xml-xpath): Update to 1.48.
[native-inputs]: Add perl-test-leaktrace.
---
gnu/packages/xml.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index ca7aaf29ed..2f33a777cd 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1036,14 +1036,14 @@ (define-public perl-xml-feed
(define-public perl-xml-xpath
(package
(name "perl-xml-xpath")
- (version "1.44")
+ (version "1.48")
(source (origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/M/MA/MANWAR/"
"XML-XPath-" version ".tar.gz"))
(sha256
(base32
- "03yxj7w5a43ibbpiqsvb3lswj2b71dydsx4rs2fw0p8n0l3i3j8w"))))
+ "1kch6w4zk7rzfimbwakz8qyhjhrvnp97158af0p5p7i3dgimpivv"))))
(build-system perl-build-system)
(arguments
(list
@@ -1065,7 +1065,7 @@ (define-public perl-xml-xpath
(unsetenv "PERL5LIB")
(invoke/quiet (string-append #$output "/bin/xpath"))))))))
(native-inputs
- (list perl-path-tiny))
+ (list perl-path-tiny perl-test-leaktrace))
(propagated-inputs
(list perl-xml-parser))
(home-page "https://metacpan.org/release/XML-XPath")
--
2.40.1
B
B
Bruno Victal wrote on 23 Sep 2023 15:59
control-msg
(address . control@debbugs.gnu.org)
87edipyoqx.fsf@makinata.eu
retitle 63617 [PATCH core-updates] gnu: socat: Update to 1.7.4.4.
retitle 60824 [PATCH core-updates] Update and wrap perl-xml-xpath.
quit

--
Thanks,
Bruno.
M
M
Maxim Cournoyer wrote on 9 Oct 2023 15:16
Re: bug#60824: [PATCH core-updates] Update and wrap perl-xml-xpath.
(name . Bruno Victal)(address . mirai@makinata.eu)(address . 60824@debbugs.gnu.org)
87o7h8c4xa.fsf_-_@gmail.com
Hello,

Bruno Victal <mirai@makinata.eu> writes:

Toggle quote (11 lines)
> Notable changes since v3:
> * Rebased against core-updates.
> * Use search-path-as-list for wrapping.
>
> Bruno Victal (2):
> gnu: perl-xml-xpath: Wrap xpath command.
> gnu: perl-xml-xpath: Update to 1.48.
>
> gnu/packages/xml.scm | 28 ++++++++++++++++++++++++----
> 1 file changed, 24 insertions(+), 4 deletions(-)

LGTM!

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 9 Oct 2023 16:12
control message for bug #60824
(address . control@debbugs.gnu.org)
87mswrdgv9.fsf@gmail.com
close 60824
quit
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60824@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60824
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch