Matthieu Lemerre wrote 2 years ago
(address . guix-patches@gnu.org)
Hi Guix!
This is my first guix package -- I have some texlive, ocaml and emacs packages missing for my installation, so I thought it would be best to share them!
Bests
Matthieu
---
gnu/packages/tex.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)
Toggle diff (32 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index dafed9d3c3..1e28c36549 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11935,6 +11935,25 @@ (define-public texlive-latex-hyphenat
fonts.")
(license license:lppl1.3c+)))
+(define-public texlive-latex-totpages
+ (package
+ (inherit (simple-texlive-package "texlive-latex-totpages"
+ (list "doc/latex/totpages/"
+ "source/latex/totpages/"
+ "tex/latex/totpages/")
+ (base32
+ "1mmya2fqdskyavw3hvdiygfyp9cll7bl4lpi7pl2jf9s7ds49j5a")
+ #:trivial? #t))
+ (build-system texlive-build-system)
+ (version "2.00")
+ (home-page "https://ctan.org/pkg/totpages")
+ (synopsis "Count pages in a document, and report last page number")
+ (description
+ "The package counts the actual pages in the document (as opposed to reporting the
+number of the last page, as does lastpage). The counter itself may be shipped
+out to the DVI file. The package uses the everyshi package for its task.")
+ (license license:lppl)))
+
(define-public texlive-latex-lastpage
(package
(inherit (simple-texlive-package
--
2.38.1