[PATCH] gnu: Add r-maser.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 2 years ago
(address . guix-patches@gnu.org)
20230113150716.202509-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-maser): New variable.
---
gnu/packages/bioconductor.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index c2fa26cb59..ca236bcf75 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -6274,6 +6274,38 @@ (define-public r-makecdfenv
package that automatically loads that environment.")
(license license:gpl2+)))
+(define-public r-maser
+ (package
+ (name "r-maser")
+ (version "1.16.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "maser" version))
+ (sha256
+ (base32
+ "1zycx8s046g4d3w5qrn950bmi0nrnq1g7fvqji48mr6hmsyzplvv"))))
+ (properties `((upstream-name . "maser")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biocgenerics
+ r-data-table
+ r-dplyr
+ r-dt
+ r-genomeinfodb
+ r-genomicranges
+ r-ggplot2
+ r-gviz
+ r-iranges
+ r-reshape2
+ r-rtracklayer))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/DiogoVeiga/maser")
+ (synopsis "Mapping alternative splicing events to proteins")
+ (description
+ "This package provides functionalities for downstream analysis, annotation
+and visualizaton of alternative splicing events generated by rMATS.")
+ (license license:expat)))
+
(define-public r-metaneighbor
(package
(name "r-metaneighbor")

base-commit: 789d73234d5b6bbd83bb054146d5bbd1d374d51a
--
2.38.1
Ricardo Wurmus wrote 2 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 60785-done@debbugs.gnu.org)
87wn5pk2hy.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (2 lines)
> * gnu/packages/bioconductor.scm (r-maser): New variable.

Applied, thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60785@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60785
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help