[PATCH] services: connman: Add iwd backend support.

  • Done
  • quality assurance status badge
Details
3 participants
  • Andrew Tropin
  • Declan Tsien
  • Bruno Victal
Owner
unassigned
Submitted by
Declan Tsien
Severity
normal
Merged with
D
D
Declan Tsien wrote on 12 Jan 2023 13:56
(address . guix-patches@gnu.org)
874jsvc3ms.fsf@riseup.net
From d15947bcbfd16b1509df555a2b05a5639dec923a Mon Sep 17 00:00:00 2001
From: Declan Tsien <declantsien@riseup.net>
Date: Thu, 12 Jan 2023 18:37:51 +0800
Subject: [PATCH] services: connman: Add iwd backend support.

* gnu/services/networking.scm (connman-configuration)[iwd?]: New
field.
(connman-shepherd-service): Applied iwd? logic.
* doc/guix.texi: Add information about connman-configuration iwd? option.
---
doc/guix.texi | 3 +++
gnu/services/networking.scm | 13 +++++++++----
2 files changed, 12 insertions(+), 4 deletions(-)

Toggle diff (63 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index 751d0957d8..ac483dacb9 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -19726,6 +19726,9 @@ The connman package to use.
@item @code{disable-vpn?} (default: @code{#f})
When true, disable connman's vpn plugin.
+
+@item @code{iwd?} (default: @code{#f})
+When true, ConnMan uses iwd to connect to wireless networks.
@end table
@end deftp
diff --git a/gnu/services/networking.scm b/gnu/services/networking.scm
index 702404bc6c..f24c8f7063 100644
--- a/gnu/services/networking.scm
+++ b/gnu/services/networking.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2022 Andrew Tropin <andrew@trop.in>
+;;; Copyright © 2022 Declan Tsien <declantsien@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1265,7 +1266,8 @@ (define-record-type* <connman-configuration>
(connman connman-configuration-connman
(default connman))
(disable-vpn? connman-configuration-disable-vpn?
- (default #f)))
+ (default #f))
+ (iwd? connman-configuration-iwd? (default #f)))
(define (connman-activation config)
(let ((disable-vpn? (connman-configuration-disable-vpn? config)))
@@ -1281,18 +1283,21 @@ (define (connman-shepherd-service config)
(and
(connman-configuration? config)
(let ((connman (connman-configuration-connman config))
- (disable-vpn? (connman-configuration-disable-vpn? config)))
+ (disable-vpn? (connman-configuration-disable-vpn? config))
+ (iwd? (connman-configuration-iwd? config)))
(list (shepherd-service
(documentation "Run Connman")
(provision '(networking))
(requirement
- '(user-processes dbus-system loopback wpa-supplicant))
+ (append '(user-processes dbus-system loopback)
+ (if iwd? '(iwd) '(wpa-supplicant))))
(start #~(make-forkexec-constructor
(list (string-append #$connman
"/sbin/connmand")
"--nodaemon"
"--nodnsproxy"
- #$@(if disable-vpn? '("--noplugin=vpn") '()))
+ #$@(if disable-vpn? '("--noplugin=vpn") '())
+ #$@(if iwd? '("--wifi=iwd_agent") '()))
;; As connman(8) notes, when passing '-n', connman
;; "directs log output to the controlling terminal in
--
2.38.1
-----BEGIN PGP SIGNATURE-----

iQHLBAEBCAA1FiEE9pXznsYl4IEztXWfD8aHA3Xv4vUFAmPAA5sXHGRlY2xhbnRz
aWVuQHJpc2V1cC5uZXQACgkQD8aHA3Xv4vViYwwAmolZNLg7R6PNeTP+9c6Hanc+
tK3MceBKWhhdw8uoW8mcSjQ48tQOTz1ekxuaw1fFKhPLse2Nt7aUyMmkwBSOTqKF
Yl8YZy+Ykx3n1BhE9OyFnXnel5fXe1sZkfzU+jlqJsTPkrhGfenLepGSQ8XwsfLJ
pxfIezb29+YYcb/CyuVFmfjpNcmRUGu86bEWSORD6D1MJhXPOysKOQWw8YyTiDV/
JueE+kSJhn4odeYBUgpMfKwzWo27DgrKTO8SIpv+4lLecep0CSav7Brpao/15mrw
OzbyoBNv4kg4NL8aoejYVL1tnN77tCDNo2sw1aSWgwuBX5+YDuqBBhbOgi3/9Kjg
q5cvk7ohEuakeAvFILNJnGi7agEFMGs1Jwf6+SGRcQGRqdbXoeN8N5UCcHGg+74u
r4//TfTbyY774Fb1bGedkaLy9cgcIOJanTXo8oj+w3NxZD5qtYmRDwX7NM+OnTRa
t/4JxcnOa8d/AFXMSs2COte8WFr6oQgYLiNDfQmu
=sfc0
-----END PGP SIGNATURE-----

B
B
Bruno Victal wrote on 12 Jan 2023 15:12
(address . 60752@debbugs.gnu.org)(address . declantsien@riseup.net)
e9b7a448-0a87-a8d5-08c0-c5d600be0823@makinata.eu
Hi,

Does connman absolutely require a wireless adapter backend?
IMO if that's not the case, neither iwd nor wpa-supplicant backends should be pulled by connman. (or at least they should be required only if they are present among the services field)
This is because not every machine comes or wants to use a wireless adapter.


Cheers,
Bruno
D
D
Declan Tsien wrote on 12 Jan 2023 15:31
(address . 60752@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
87fscfbz9k.fsf@riseup.net
Bruno Victal <mirai@makinata.eu> writes:

Toggle quote (5 lines)
>
> IMO if that's not the case, neither iwd nor wpa-supplicant backends should be pulled by connman. (or at least they should be required only if they are present among the services field)
> This is because not every machine comes or wants to use a wireless adapter.
>

Right, are you suggesting removing wpa-supplicant from requirement
field?

Yeah, it would make more sense and fit my needs too.
-----BEGIN PGP SIGNATURE-----

iQHLBAEBCAA1FiEE9pXznsYl4IEztXWfD8aHA3Xv4vUFAmPAGbcXHGRlY2xhbnRz
aWVuQHJpc2V1cC5uZXQACgkQD8aHA3Xv4vUVUwv8CJRMP2pOEot4aTIE5c27jZld
ZR2uw7QEg4H8ABugEs/NiouJ+7SnaVPwZOZC3lCP2ZUiYuJ3XYtDkhoa43/qqErU
hSH3t1e4QK+rqTqP53xDoXJewPKsVkN0S0EVK7rxCUZlFuhgFuMnynBZfmZ6AbuH
TpKQZFXNQtdgZYxdLqT/c1la+SWHVRZ7gdYUYtxGbw4xkDUKwFGfgaRfZSwa+KEu
tF+o8nT4IN9WpVrhdGZr2xhZtJ4U81Ng1BLOmXrwpi45L6CitiLYCCi/IDpSEgck
39KleaYmoikZkKwCB5K/14Zg8SukiVIC6DEH+MnWIfTb4zL5HXqFkudYYVuUJlQB
l6TuDoo9S8C1itgnWiT6ApSEyOTv+pnFYE+b/s+vyu8FJ483mG8uGzxg6eSeBZ98
XNiHlOIi9D30JD0G//e68hgpACcYpKSaYW/6l1R2MrD4I+MweYFP8Jtby85vbyaf
RgFTTjKA4pVSDZ2oMuIVn/M3J+OkI7SQ35HwMzH1
=md2G
-----END PGP SIGNATURE-----

B
B
Bruno Victal wrote on 12 Jan 2023 15:53
b263b300-a3c5-f579-45b5-c72cc7f9466e@makinata.eu
On 2023-01-12 14:31, Declan Tsien wrote:
Toggle quote (10 lines)
> Bruno Victal <mirai@makinata.eu> writes:
>
>>
>> IMO if that's not the case, neither iwd nor wpa-supplicant backends should be pulled by connman. (or at least they should be required only if they are present among the services field)
>> This is because not every machine comes or wants to use a wireless adapter.
>>
>
> Right, are you suggesting removing wpa-supplicant from requirement
> field?

If that's possible, yes.
D
D
Declan Tsien wrote on 12 Jan 2023 16:22
(name . Bruno Victal)(address . mirai@makinata.eu)(address . 60752@debbugs.gnu.org)
871qnzwzfn.fsf@riseup.net
Bruno Victal <mirai@makinata.eu> writes:

Toggle quote (13 lines)
> On 2023-01-12 14:31, Declan Tsien wrote:
>> Bruno Victal <mirai@makinata.eu> writes:
>>
>>>
>>> IMO if that's not the case, neither iwd nor wpa-supplicant backends should be pulled by connman. (or at least they should be required only if they are present among the services field)
>>> This is because not every machine comes or wants to use a wireless adapter.
>>>
>>
>> Right, are you suggesting removing wpa-supplicant from requirement
>> field?
>
> If that's possible, yes.

I think that is a question for people with more knowledge in this regard.

But to my experiencing using connman and iwd. I think it's OK.
Now I am running these two shepherd services separately

- connman (without wpa-supplicant and iwd)
- iwd

This patch can be closed without applying.

Thanks for clarifying things for me.
-----BEGIN PGP SIGNATURE-----

iQHLBAEBCAA1FiEE9pXznsYl4IEztXWfD8aHA3Xv4vUFAmPAJZwXHGRlY2xhbnRz
aWVuQHJpc2V1cC5uZXQACgkQD8aHA3Xv4vUPOwwAqJXABn25U0uZikhUVkKUi4PG
xC/9yzGceFmPg1GF5eQcttcJkKJHcY/fC/IPGOdSoN/p3Rq+gUFlKb/xlXBdN4rh
R7gOV0cGi3/7Y+aKmJN5FHMWLHw+8wLou90ZQjdvWbA38nU9yVHK/T4JP3Yz4efH
mvPQJ1HDCnDXYJjPexglTIA/7VoCDgLHGZ3z/z4WuyJGsSUm1YONGphsu5trdqWh
AhEX3UOd3lE0d7of3vwEjzrX94BgdzD4Fn31HgCtyMhYcnAgXH5TpWKhnk77HyEO
h3DW+aiWlAMhy0676HdW0F8LXQqicUcaT0fAEr5U7n0/vudjfDZVvDuwQp+arygS
7YfbCs9iVUyJC3PYJr9wIE/mwtRxx96ZvCd4KR5c6yfITBEOK1w4nlUZEzSBQgrz
cGsJ8uHkwZhueU9E51c4tbQNYr2mpSgLfv6DvzVCe2DrGVFSuK9x4BosVj1yOI/7
xl8sOpPLSGhodwKX2Onc7PM5C2c/n4tEvFpKGXEQ
=e0ni
-----END PGP SIGNATURE-----

D
D
Declan Tsien wrote on 14 Jan 2023 02:17
[Declan Tsien] Re: [bug#60752] [PATCH] services: connman: Add option to disable wpa-supplicant.
(address . 60752@debbugs.gnu.org)
87wn5pap9t.fsf@riseup.net
-------------------- Start of forwarded message --------------------
From: Declan Tsien <declantsien@riseup.net>
To: Bruno Victal <mirai@makinata.eu>
Subject: Re: [bug#60752] [PATCH] services: connman: Add option to disable
wpa-supplicant.
Date: Sat, 14 Jan 2023 09:13:50 +0800
Bruno Victal <mirai@makinata.eu> writes:

Toggle quote (10 lines)
> Hi,
>
> Does connman absolutely require a wireless adapter backend?
> IMO if that's not the case, neither iwd nor wpa-supplicant backends should be pulled by connman. (or at least they should be required only if they are present among the services field)
> This is because not every machine comes or wants to use a wireless adapter.
>
>
> Cheers,
> Bruno

Hi,
what about this.
From 379d4afac343101a2351bab4f314496395828d8d Mon Sep 17 00:00:00 2001
From: Declan Tsien <declantsien@riseup.net>
Date: Sat, 14 Jan 2023 08:57:02 +0800
Subject: [PATCH] services: connman: Add option to disable wpa-supplicant.

* gnu/services/networking.scm
(connman-configuration)[disable-wpa-supplicant?]: New field.
(connman-shepherd-service): Applied disable-wpa-supplicant? logic.

* doc/guix.texi: Add information about connman-configuration
disable-wpa-supplicant? option.
---
doc/guix.texi | 4 ++++
gnu/services/networking.scm | 20 ++++++++++++--------
2 files changed, 16 insertions(+), 8 deletions(-)

Toggle diff (65 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index 751d0957d8..29be830bd4 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -19726,6 +19726,10 @@ The connman package to use.
@item @code{disable-vpn?} (default: @code{#f})
When true, disable connman's vpn plugin.
+
+@item @code{disable-wpa-supplicant?} (default: @code{#f})
+When true, remove @code{wpa-supplicant} requirement. Let users disable
+wireless adapters or hook in a another implementation like @code{iwd}.
@end table
@end deftp
diff --git a/gnu/services/networking.scm b/gnu/services/networking.scm
index 702404bc6c..39162fe822 100644
--- a/gnu/services/networking.scm
+++ b/gnu/services/networking.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2022 Andrew Tropin <andrew@trop.in>
+;;; Copyright © 2023 Declan Tsien <declantsien@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1262,10 +1263,12 @@ (define network-manager-service-type
(define-record-type* <connman-configuration>
connman-configuration make-connman-configuration
connman-configuration?
- (connman connman-configuration-connman
- (default connman))
- (disable-vpn? connman-configuration-disable-vpn?
- (default #f)))
+ (connman connman-configuration-connman
+ (default connman))
+ (disable-vpn? connman-configuration-disable-vpn?
+ (default #f))
+ (disable-wpa-supplicant? connman-configuration-disable-wpa-supplicant?
+ (default #f)))
(define (connman-activation config)
(let ((disable-vpn? (connman-configuration-disable-vpn? config)))
@@ -1280,13 +1283,14 @@ (define (connman-shepherd-service config)
"Return a shepherd service for Connman"
(and
(connman-configuration? config)
- (let ((connman (connman-configuration-connman config))
- (disable-vpn? (connman-configuration-disable-vpn? config)))
+ (let ((connman (connman-configuration-connman config))
+ (disable-vpn? (connman-configuration-disable-vpn? config))
+ (disable-wpa-supplicant? (connman-configuration-disable-wpa-supplicant? config)))
(list (shepherd-service
(documentation "Run Connman")
(provision '(networking))
- (requirement
- '(user-processes dbus-system loopback wpa-supplicant))
+ (requirement (append '(user-processes dbus-system loopback)
+ (if disable-wpa-supplicant? '() '(wpa-supplicant))))
(start #~(make-forkexec-constructor
(list (string-append #$connman
"/sbin/connmand")
--
2.38.1
This way, connman service can let users disable wireless adapters or hook
in a another implementation like iwd.

Cheers,
Declan
-----BEGIN PGP SIGNATURE-----

iQHLBAEBCAA1FiEE9pXznsYl4IEztXWfD8aHA3Xv4vUFAmPCAc8XHGRlY2xhbnRz
aWVuQHJpc2V1cC5uZXQACgkQD8aHA3Xv4vUxIQwAuzYVJzeAFsGT48FxhoAOHrEU
Q1p/SidSM5u9MgK7HBnqxDR9WyMVAmb5takf331aE7gVT4NHQ8eO+/CnDbq8JajP
CCBaXTLBlYU349OwTGS69O1JVCYriQNEAS8EPnb3w5vHc1iFvJTXN0tUAIKUxSO4
84RttbYkRQ6+i+g3u2n0ARyapRR3Gw6TxK/544DZG9xUZt3/o8udI9PZUJuc48St
709p8VqjkgOra2nbbsciwSguIIQ+Yb8VbaEQzaNukboJBQO2hSioDmXbTddDGCkU
/CZqi3HXwj+Y78PQ9dSlUOQ9aKpl5Qe9A55JzN5q5yUUzgP2SFozJcFR+x8ZC1eC
9ESVgOxNH/s/N5yVX+QrpYNqfA8rNszPf6G+xI/9xfrYdeKnAZ2eAKZMQEWCvR5X
Z/8U0UQTRKtoMILeET5Ad1VgcahNIeLUqGb76RknEmYU3U+5Ezkv1fwfhgBTaMQv
JwQAo2tyFudPQ6t2mv7N4h0CYnnrWRpmOZnwlN3F
=eAfk
-----END PGP SIGNATURE-----
-------------------- End of forwarded message --------------------
-----BEGIN PGP SIGNATURE-----

iQHLBAEBCAA1FiEE9pXznsYl4IEztXWfD8aHA3Xv4vUFAmPCAo4XHGRlY2xhbnRz
aWVuQHJpc2V1cC5uZXQACgkQD8aHA3Xv4vWgCQwAmtEq+SGtPiPOFqGZlxwWASpd
rN2DTpoPNlHMRXZYJH/+E6VqMp9ewp+Q7cYMAonmy9IHeCtEb7SZjq6CS+tp6xzC
tILOfpuYdAuF4H5MW3M3HXa8rAJXyy5KvY82X0LvOkrfXNpt+Cpcs+SqOsG9/aKo
wOGWS94rxolYz3TytM5cEK9uMzSmGB9vzIWELBLR6DN11Bi2LdoTKwB9kSUTMMj/
CfMe0y1nVyBr0v7fM+hhYMknXz5E8C6k0w6cJKXnU/ewDEbuwX6y7ivDyuvSUt0W
IgQeZet/yjoF3Qt7WX0v4vZxNJxub5OHXOqX+MHa+bC3SutxdBjOiq/AavUS0k2n
OAneTVwhMFHA3WvFLZrKPb8Ep2OzOAIov67tiMwyYzE4IA/E3DhIG6H876kVsyQh
Yc82LPIdkStOzjgTR5+GkOyga3xlqtVNxjxyl/kYPbbltdW3ZAfmox23tqrYf5Sj
1ptBTr0NftKYv6DFIfgYm/6bjDvSlcmNJr72F9V5
=p9S3
-----END PGP SIGNATURE-----

D
D
Declan Tsien wrote on 14 Jan 2023 02:54
(address . 60752-done@debbugs.gnu.org)
87pmbhank4.fsf@riseup.net
Started a new thread since the subject has changed
-----BEGIN PGP SIGNATURE-----

iQHLBAEBCAA1FiEE9pXznsYl4IEztXWfD8aHA3Xv4vUFAmPCCzsXHGRlY2xhbnRz
aWVuQHJpc2V1cC5uZXQACgkQD8aHA3Xv4vV3VQv8ClKYjsdqWt5xjwKZHMdUUyEK
1DQ7hJv1UtbWr1/+wEIMA2VfZ7RWz6xVj8E5+uO8MbjkhbtXh1eaHALj0yIEA2Vm
4Otd8RGDdIqqAXDj4uxJjBjYsib45PPVgp0Hht/9leMOgFcC3TJHyQoBtcRT6ZJf
vGOgEMHKMhubeZ5Pgp2CSlQud/vkAaQfdjuNuaq5AZSAz9QnefFiN5CbIJWu0Grg
B38ox3W6ZaQie3egctssxZWKEXnSHhd8ETG4ixJzB7nm3nuU0ENhqMS9gHxqWry4
TDToz4FcB6t4hnZCMFBOsNVypMs39lWhV/MN+i76TtD+bZn7wo2PKuNYqSKGtQ5P
ZoRodBPwYvF+hDrGRwVcutXHdRifKhdDe1sbEkXD49YQptJ/olPARiS6enwSydIh
mdLohg2kIsjtda113p1qfzsIgQFy5kW48scgtL1CO/13+qFB3oLA3WqYv5edneIY
H+7uRDceOWWayf/A3+V2Vb/PxzZBIh+CIVx2PL39
=HpRr
-----END PGP SIGNATURE-----

Closed
A
A
Andrew Tropin wrote on 16 Jan 2023 17:34
(address . control@debbugs.gnu.org)
87o7qyl9pn.fsf@trop.in
reopen 60752
merge 60752 60800
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmPFfJQACgkQIgjSCVjB
3rDTEw//cy608zyzDz75vj3usKHX50Uofy1CX8h5vGtI3mcdWMb1fvqQS9IHweP1
MJbzulh7XVXQxMaP6g8EFQLFj5gpoB5vCvniyiMXbATwqWi6Edu8zN/ZunXqsnWe
HEQbyKru+iZjyxpAHntYIzI0SaXJHJwoRWSlYV4XIfad9ldUllj9Qtkv2Y57FFtb
ZxQfr9wHvoVgTDIeKOgmDz7qtY6oDQWqM0MAJkfeZEQEcWriU/bcpLt8+DG4GH3j
cvYEHHVMsTQ79oCyLoh16ZIHpSW6UjwxT2sN9jHLUtOq5x/g+rIj5xLsRNXH6un2
8I0QZWHSWkQydux8jNZnyNRh8BFaUHbzsfPJxc0TsMhz6Yj89MbWZaMms/LJi9TR
DIpcgcpHv6pnfxmGlMtk+JNTbI7k2ToyoVTb47DA9Vlp5YWsuqoNCk6UVNzzv3P5
2cJtahs0/ajc8tustVJ/EyQoJ/BoqZl6lHUB+sAT+CuU9srjAEw6waC/2PbX/ev1
OVHN9VKJOWNIdSDlshcxJnPC9g8hsJBel13wiqn3eY2aNK7S52/WpiAl2wdsc5+R
QeHbUcSEm8VxdIU/m92w+RtWddeGzFG3uzU/q9aI6SjZDUYPyv8zH+qiKSm3aGnp
lowcxvBcenoLr154KrDaSCFa4vLfKbnER4lz7oAdcmXw4SAi6v0=
=agd2
-----END PGP SIGNATURE-----

A
A
Andrew Tropin wrote on 16 Jan 2023 18:22
87k01ml7i4.fsf@trop.in
On 2023-01-14 09:54, Declan Tsien wrote:

Toggle quote (3 lines)
> Started a new thread since the subject has changed
> https://issues.guix.gnu.org/60800

Let's keep the discussion in this thread, not to lose the context.

BTW, there is a retitle command for debbugs in case it necessary to
change the title of the bug.


From what I see wpa-supplicant requirement is not needed, as Bruno
mentioned, there are use cases, where connman can be used without
wpa-supplicant or wireless backend at all.

According to the documentation I was able to find, to enable iwd support
--wifi=iwd_agent should be added to connmand, so I applied the first
patch with a few adjustments: Completely removed wpa-supplicant
requirement, realigned the code. Unfortunately, I don't use connman and
can't easily check, Declan, could you please confirm that iwd is now
working correctly with connman?

--
Best regards,
Andrew Tropin
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmPFh8MACgkQIgjSCVjB
3rBcJRAAiWhBemgjt8vn46TwEF0J0dM5nNU1v34M0QgRhl/KEI0BSQZM3414twRx
mYJ6xFtdZKUg1pI543Khq2Y1xWuHTwBsSeiGJOE3sUU0aRI+ASyYXYyawLiNqXcO
Lxok1rKU/GyG2YuH7XQXz7l5Jk5zrkg6Fcfx2Hn/dR9oOKzqYAssfvla7/JU7tyR
I6iOMbGlBNp70z7I/Cr+921V7cr/txA1U88IckS88AOJoCLT8XWFBDXe5cZnksNX
9+VCCC0N9/fCu/riTajHKy011xaKZYHbe4igPr+hbno5pEiyn2mnz5JD31L/B+t+
7yooLFX7Vvbc0wosB3pq2/kpIrZ7jTVYCbfsXCshisc9EqyRShtxtl/3BzXQ50IQ
jXJbDq7SEtYN84uKdwE1hQllqd6EB6F9cMQIpOqvq0rA4cOTKam4GiOX3uvcPYvH
Jz1uvKv1U9v138OKniCm3Pk6xT8ZJKwX2A4mhSYJxeLbUJTgKatPkX2z/44TJz1b
giyYr3PcQRD8fPhWn8BazOh8m9Us2xnXvp9B02Me/6uM9Ad40tIzDZYnxeiK/nPb
3Nt5t91ARyhVv6dVwi0lVD7xodHkxHFy8xSwFJb2LESOsctNyo4Swc7sCuzbhUw3
K6iwjneULrENHyP+ZQK+vXsJl6t+A60sDvCStsjg7EqEX8tS1ns=
=AL04
-----END PGP SIGNATURE-----

Closed
D
D
Declan Tsien wrote on 17 Jan 2023 01:30
(name . Andrew Tropin)(address . andrew@trop.in)(address . 60752@debbugs.gnu.org)
87fscadmte.fsf@riseup.net
Andrew Tropin <andrew@trop.in> writes:

Toggle quote (11 lines)
> On 2023-01-14 09:54, Declan Tsien wrote:
>
>> Started a new thread since the subject has changed
>> https://issues.guix.gnu.org/60800
>
> Let's keep the discussion in this thread, not to lose the context.
>
> BTW, there is a retitle command for debbugs in case it necessary to
> change the title of the bug.
>

Thanks.

Toggle quote (16 lines)
>
> From what I see wpa-supplicant requirement is not needed, as Bruno
> mentioned, there are use cases, where connman can be used without
> wpa-supplicant or wireless backend at all.
>
> According to the documentation I was able to find, to enable iwd support
> --wifi=iwd_agent should be added to connmand, so I applied the first
> patch with a few adjustments: Completely removed wpa-supplicant
> requirement, realigned the code. Unfortunately, I don't use connman and
> can't easily check, Declan, could you please confirm that iwd is now
> working correctly with connman?
>
> --
> Best regards,
> Andrew Tropin

Yeah, Its working.

In my case, --wifi=iwd_agent is not required either when using iwd.
But it should be useful when wpa-supplicant and iwd services are both
in the system.

Best regards,
Declan Tsien
-----BEGIN PGP SIGNATURE-----

iQHLBAEBCAA1FiEE9pXznsYl4IEztXWfD8aHA3Xv4vUFAmPF7D0XHGRlY2xhbnRz
aWVuQHJpc2V1cC5uZXQACgkQD8aHA3Xv4vW48Qv/a1vMt7KXlprhddpKSwN3Cf68
VBl6/mdyKPiDFV6PJBm5uqfroGWoNO2goyzaA8yQGNzomJH1NhPh8mFvm4u+eoVv
nLhq7E/yC54O2uH7pXmcrV8gIzbDu5BqSH2zOu5E2W/NlnLdicywuJEl0QbupBBi
b2P2cM4N0xcfarj95wJqykbJmhObtYy//r9qLi0bkddta4hCo9w+FuST65TO+H7z
CvtI2VCkDa2BtUjDva4vTlZzGu/cvW4j0nPS++3r+zh2mKaba1QazCo838Jwy2RS
x2KMuKMi2jnIjgSajtp8zRpt5ZoaQgRr+jA2UaOTsJTXlU49tdY0C7/SdcdYROYM
al+l8a0BeBYfXuO8TaQinnBC/r0FKeBcK1ve1OYYkFZerAvawT4JUrKZYHemdmy3
rbD8uqj1/LNFoZms6TDC6pnXOl8Yaal+YeelW5IUas0rX3bgaMGhIGo1/WEihJYq
/nOhLGR/m3NW/e/g2FbH3CSYZX8R90FM+o/y3ZDP
=2Tqi
-----END PGP SIGNATURE-----

?