[PATCH] gnu: pantalaimon: Install documentation and use gexps.

  • Done
  • quality assurance status badge
Details
3 participants
  • Morgan.J.Smith
  • Nicolas Goaziou
  • Michael Rohleder
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal

Debbugs page

Morgan.J.Smith wrote 2 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR03MB3163E2A8BF1E9B576E792B0AC5FC9@DM5PR03MB3163.namprd03.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/matrix.scm (pantalaimon)[arguments]: Turn into gexps. Add
install-doc phase
---
gnu/packages/matrix.scm | 37 +++++++++++++++++++++++--------------
1 file changed, 23 insertions(+), 14 deletions(-)

Toggle diff (57 lines)
diff --git a/gnu/packages/matrix.scm b/gnu/packages/matrix.scm
index d5e0060c04..2ed7a9a782 100644
--- a/gnu/packages/matrix.scm
+++ b/gnu/packages/matrix.scm
@@ -36,6 +36,7 @@ (define-module (gnu packages matrix)
#:use-module (gnu packages xml)
#:use-module (guix build-system python)
#:use-module (guix download)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix packages))
@@ -248,20 +249,28 @@ (define-public pantalaimon
"16ask8v00654q307c55q5gnm8hrj40gibpab5zl52v4i0bgl9j68"))))
(build-system python-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'downgrade-appdirs-requirement
- (lambda _
- (substitute* "setup.py"
- ;; FIXME: Remove this once appdirs is updated.
- ;; Upgrading python-appdirs requires rebuilting 3000+ packages,
- ;; when 1.4.4 is a simple maintenance fix from 1.4.3.
- (("appdirs >= 1.4.4") "appdirs >= 1.4.3"))))
- (replace 'check
- (lambda* (#:key tests? inputs outputs #:allow-other-keys)
- (when tests?
- (add-installed-pythonpath inputs outputs)
- (invoke "pytest" "-vv" "tests")))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'downgrade-appdirs-requirement
+ (lambda _
+ (substitute* "setup.py"
+ ;; FIXME: Remove this once appdirs is updated.
+ ;; Upgrading python-appdirs requires rebuilting 3000+ packages,
+ ;; when 1.4.4 is a simple maintenance fix from 1.4.3.
+ (("appdirs >= 1.4.4") "appdirs >= 1.4.3"))))
+ (add-after 'install 'install-doc
+ (lambda _
+ (with-directory-excursion "docs/man"
+ (let ((man (string-append #$output "/share/man")))
+ (install-file "panctl.1" (string-append man "/man1"))
+ (install-file "pantalaimon.5" (string-append man "/man5"))
+ (install-file "pantalaimon.8" (string-append man "/man8"))))))
+ (replace 'check
+ (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-vv" "tests")))))))
(native-inputs
(list python-aioresponses
python-faker
--
2.38.1
Michael Rohleder wrote 2 years ago
(address . Morgan.J.Smith@outlook.com)(address . 60738@debbugs.gnu.org)
87y1pltiim.fsf@rohleder.de
This looks good to me, thank you!

--
Listen and silent are spelled with the same letters.
-----BEGIN PGP SIGNATURE-----

iQFFBAEBCAAvFiEEdV4t5dDVhcUueCgwfHr/vv7yyyUFAmPWngERHG1pa2VAcm9o
bGVkZXIuZGUACgkQfHr/vv7yyyWLhAf/dAiShqdttRAtN3wU9LH1a5swHgNHXNQO
H/1Ls6YU5ElVbeK8/1cjaD9ClRwx0qm/dqNBYmceHVIUBXcU4t0yBzpMvoi7TBNh
NwUtKq3SH4KFu96Ei2wjnhNnluHFUxFJlLzx9yQwlCPbr3VAhliXwoRzmjDLJNpC
MfO2iPAtVWsgmoudlITrbadMiiq8PeI+Ss3nvrq3Iy8pM6zGRKRQ84eso0sUOK+P
RntGvju8l9iqKneCixDjteA6XP47P9EQLQLgyhCKGM3rMAzV0D5nQIglnAWmT2gL
uZyJbJ7U+mgwj6QklAnoiunHRzQzMZbv0od41VAPVPyIlK5GUOUlrQ==
=lhDZ
-----END PGP SIGNATURE-----

Nicolas Goaziou wrote 2 years ago
Re: [bug#60738] [PATCH] gnu: pantalaimon: Install documentation and use gexps.
(address . Morgan.J.Smith@outlook.com)(address . 60738-done@debbugs.gnu.org)
874jrrudi1.fsf@nicolasgoaziou.fr
Hello,

Morgan.J.Smith@outlook.com writes:

Toggle quote (3 lines)
> * gnu/packages/matrix.scm (pantalaimon)[arguments]: Turn into gexps. Add
> install-doc phase

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60738@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60738
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help