[PATCH] gnu: rss2email: Update to 3.14.

  • Done
  • quality assurance status badge
Details
2 participants
  • Morgan.J.Smith
  • 宋文武
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal

Debbugs page

Morgan.J.Smith wrote 2 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR03MB3163CF3EE21A462AF7FD5185C5FC9@DM5PR03MB3163.namprd03.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/mail.scm (rss2email): Update to 3.14.
[arguments]: Use gexps. Add install-documentation phase
---
gnu/packages/mail.scm | 33 +++++++++++++++++++--------------
1 file changed, 19 insertions(+), 14 deletions(-)

Toggle diff (55 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index de868e948b..2c7f3fd9ff 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -4685,7 +4685,7 @@ (define-public crm114
(define-public rss2email
(package
(name "rss2email")
- (version "3.13.1")
+ (version "3.14")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -4694,21 +4694,26 @@ (define-public rss2email
(file-name (git-file-name name version))
(sha256
(base32
- "0g1yr3v3ibdh2jqil64fbdbplx5m2yzxr893fqfkwcc5c7fbwl4d"))))
+ "0rmcwvf8whf49qq5rgp5hhmhfjli1vhjlc7fjhj24gyy1kkjir2k"))))
(build-system python-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (with-directory-excursion "test"
- ;; Skip networking tests
- (substitute* "test.py"
- (("( *)class (:?TestSend|TestFetch).*" match indent)
- (string-append indent "@unittest.skip(\"Networking stuff skipped\")\n"
- indent match)))
- (invoke "python" "-m" "unittest"))))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion "test"
+ ;; Skip networking tests
+ (substitute* "test.py"
+ (("( *)class (:?TestSend|TestFetch).*" match indent)
+ (string-append indent
+ "@unittest.skip(\"Networking stuff skipped\")\n"
+ indent match)))
+ (invoke "python" "-m" "unittest")))))
+ (add-after 'install 'install-documentation
+ (lambda _
+ (install-file "r2e.1" (string-append #$output "share/man/man1")))))))
(inputs
(list python-feedparser python-html2text))
(home-page "https://github.com/rss2email/rss2email")
--
2.38.1
宋文武 wrote 2 years ago
(address . Morgan.J.Smith@outlook.com)(address . 60737-done@debbugs.gnu.org)
87lelnqjr2.fsf@envs.net
Morgan.J.Smith@outlook.com writes:

Toggle quote (5 lines)
> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * gnu/packages/mail.scm (rss2email): Update to 3.14.
> [arguments]: Use gexps. Add install-documentation phase

Applied, thank you!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60737@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60737
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help