[PATCH] gnu: hledger: Install documentation.

  • Done
  • quality assurance status badge
Details
2 participants
  • Morgan.J.Smith
  • Ludovic Courtès
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal

Debbugs page

Morgan.J.Smith wrote 2 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR03MB3163D3F6BCD872F190733907C5FC9@DM5PR03MB3163.namprd03.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/finance.scm (hledger)[phases]: Add install-doc phase
---
gnu/packages/finance.scm | 8 ++++++++
1 file changed, 8 insertions(+)

Toggle diff (21 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index f5906ec738..3c7b8a4a18 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -227,6 +227,14 @@ (define-public hledger
(base32
"07fcfkmv4cy92njnf2qc7jh0naz96q962hxldcd7hk4k7ddv0mss"))))
(build-system haskell-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'install-doc
+ (lambda _
+ (install-file "hledger.info" (string-append #$output "/share/info"))
+ (install-file "hledger.1" (string-append #$output "/man/man1")))))))
(inputs
(list ghc-ansi-terminal
ghc-base-compat-batteries
--
2.38.1
Ludovic Courtès wrote 2 years ago
(address . Morgan.J.Smith@outlook.com)(address . 60736-done@debbugs.gnu.org)
87h6wma3i7.fsf@gnu.org
Hi,

Morgan.J.Smith@outlook.com skribis:

Toggle quote (4 lines)
> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * gnu/packages/finance.scm (hledger)[phases]: Add install-doc phase

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60736@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60736
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help