python build systems does not support cross-compilation

  • Open
  • quality assurance status badge
Details
One participant
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 11 Jan 2023 17:43
(name . bug-guix)(address . bug-guix@gnu.org)
87r0w1hvj1.fsf@gmail.com
Hello,

Here's an example:

Toggle snippet (6 lines)
$ guix build --target=aarch64-linux-gnu python-coverage

guix build: error: gnu/packages/check.scm:1997:2: python-coverage@5.2.1:
build system `python' does not support cross builds

Python byte compiled files are not architecture dependents, so nothing
is needed for them. In some cases where C extensions are used,
setuptools or PEP 517 python build systems handle this transparently.

So it seems like we should be able to support cross-compiling Python
packages easily, which can be useful when building images containing
Python packages for embedded systems via cross-compilation.

Thoughts?

--
Thanks,
Maxim
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 60733@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60733
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch