[PATCH] build-system: copy: Add substitutable keyword.

  • Done
  • quality assurance status badge
Details
2 participants
  • Jonathan Brielmaier
  • Ludovic Courtès
Owner
unassigned
Submitted by
Jonathan Brielmaier
Severity
normal

Debbugs page

Jonathan Brielmaier wrote 2 years ago
(address . guix-patches@gnu.org)(address . jonathan.brielmaier@web.de)
20230110233330.22439-1-jonathan.brielmaier@web.de
* guix/build-system/copy.scm (copy-build): Add substitutable keyword.
---
guix/build-system/copy.scm | 3 +++
1 file changed, 3 insertions(+)

Toggle diff (28 lines)
diff --git a/guix/build-system/copy.scm b/guix/build-system/copy.scm
index 4894ba46fb..c98b266561 100644
--- a/guix/build-system/copy.scm
+++ b/guix/build-system/copy.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2021 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2023 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -94,6 +95,7 @@ (define* (copy-build name inputs
%standard-phases))
(system (%current-system))
(target #f)
+ (substitutable? #t)
(imported-modules %copy-build-system-modules)
(modules '((guix build copy-build-system)
(guix build utils))))
@@ -129,6 +131,7 @@ (define builder
(gexp->derivation name builder
#:system system
#:target #f
+ #:substitutable? substitutable?
#:guile-for-build guile)))

(define copy-build-system
--
2.38.1
Ludovic Courtès wrote 2 years ago
(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)(address . 60720@debbugs.gnu.org)
877cxia3aw.fsf@gnu.org
Hi,

Jonathan Brielmaier <jonathan.brielmaier@web.de> skribis:

Toggle quote (2 lines)
> * guix/build-system/copy.scm (copy-build): Add substitutable keyword.

LGTM, thanks!

Ludo’.
Jonathan Brielmaier wrote 2 years ago
(address . 60720-done@debbugs.gnu.org)(name . Ludovic Courtès)(address . ludo@gnu.org)
e0dfb50f-42d6-4554-8d50-c901f7293296@web.de
Pushed as 3e8dd0df8cdb693c9b86bcf2b0b1d2239cd83311.

It does not seem to trigger rebuilds of the packages who use
`copy-build-system`.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60720@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60720
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help