[PATCH] gnu: hwloc: Update to 2.9.0.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Ludovic Courtès
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Ludovic Courtès
Severity
normal
L
L
Ludovic Courtès wrote on 10 Jan 2023 10:04
(address . guix-patches@gnu.org)(name . Ludovic Courtès)(address . ludovic.courtes@inria.fr)
20230110090414.32124-1-ludo@gnu.org
From: Ludovic Courtès <ludovic.courtes@inria.fr>

* gnu/packages/mpi.scm (hwloc-2): Update to 2.9.0.
[arguments]: Add 'skip-test-that-requires-/sys' phase.
---
gnu/packages/mpi.scm | 10 +++++++---
1 file changed, 7 insertions(+), 3 deletions(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index af2409aeab..56b7d04209 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015, 2018, 2019 Eric Bavier <bavier@member.fsf.org>
-;;; Copyright © 2014-2022 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014-2023 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2017 Dave Love <fx@gnu.org>
@@ -143,7 +143,7 @@ (define-public hwloc-2
;; Note: 2.x isn't the default yet, see above.
(package
(inherit hwloc-1)
- (version "2.8.0")
+ (version "2.9.0")
(source (origin
(method url-fetch)
(uri (string-append "https://download.open-mpi.org/release/hwloc/v"
@@ -151,7 +151,7 @@ (define-public hwloc-2
"/hwloc-" version ".tar.bz2"))
(sha256
(base32
- "1ha23yqfx9kfxm5fcj9m0fnyf0r2k6p4k88xxqishclcsky752il"))))
+ "11v8hnl6fdsdbm3wnz5gg88f2ghixjyl7jlfmywj293ab5iyjw10"))))
;; libnuma is no longer needed.
(inputs (modify-inputs (package-inputs hwloc-1)
@@ -167,6 +167,10 @@ (define-public hwloc-2
(substitute* "tests/hwloc/linux-libnuma.c"
(("numa_available\\(\\)")
"-1"))))
+ (add-before 'check 'skip-test-that-requires-/sys
+ (lambda _
+ ;; 'test-gather-topology.sh' requires /sys as of 2.9.0; skip it.
+ (setenv "HWLOC_TEST_GATHER_TOPOLOGY" "0")))
(add-before 'check 'skip-test-that-fails-on-qemu
(lambda _
;; Skip test that fails on emulated hardware due to QEMU bug:

base-commit: 84f117f49587b608b287827793b1b8036d2cff7f
--
2.38.1
M
M
Maxim Cournoyer wrote on 10 Jan 2023 17:34
(name . Ludovic Courtès)(address . ludo@gnu.org)
877cxul55z.fsf@gmail.com
Hi,

Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (21 lines)
> From: Ludovic Courtès <ludovic.courtes@inria.fr>
>
> * gnu/packages/mpi.scm (hwloc-2): Update to 2.9.0.
> [arguments]: Add 'skip-test-that-requires-/sys' phase.
> ---
> gnu/packages/mpi.scm | 10 +++++++---
> 1 file changed, 7 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
> index af2409aeab..56b7d04209 100644
> --- a/gnu/packages/mpi.scm
> +++ b/gnu/packages/mpi.scm
> @@ -1,6 +1,6 @@
> ;;; GNU Guix --- Functional package management for GNU
> ;;; Copyright © 2014, 2015, 2018, 2019 Eric Bavier <bavier@member.fsf.org>
> -;;; Copyright © 2014-2022 Ludovic Courtès <ludo@gnu.org>
> +;;; Copyright © 2014-2023 Ludovic Courtès <ludo@gnu.org>
> ;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
> ;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
> ;;; Copyright © 2017 Dave Love <fx@gnu.org>

Nitpick: arguably not a copyrightable change (< 10 lines of additions).

Toggle quote (30 lines)
> @@ -143,7 +143,7 @@ (define-public hwloc-2
> ;; Note: 2.x isn't the default yet, see above.
> (package
> (inherit hwloc-1)
> - (version "2.8.0")
> + (version "2.9.0")
> (source (origin
> (method url-fetch)
> (uri (string-append "https://download.open-mpi.org/release/hwloc/v"
> @@ -151,7 +151,7 @@ (define-public hwloc-2
> "/hwloc-" version ".tar.bz2"))
> (sha256
> (base32
> - "1ha23yqfx9kfxm5fcj9m0fnyf0r2k6p4k88xxqishclcsky752il"))))
> + "11v8hnl6fdsdbm3wnz5gg88f2ghixjyl7jlfmywj293ab5iyjw10"))))
>
> ;; libnuma is no longer needed.
> (inputs (modify-inputs (package-inputs hwloc-1)
> @@ -167,6 +167,10 @@ (define-public hwloc-2
> (substitute* "tests/hwloc/linux-libnuma.c"
> (("numa_available\\(\\)")
> "-1"))))
> + (add-before 'check 'skip-test-that-requires-/sys
> + (lambda _
> + ;; 'test-gather-topology.sh' requires /sys as of 2.9.0; skip it.
> + (setenv "HWLOC_TEST_GATHER_TOPOLOGY" "0")))
> (add-before 'check 'skip-test-that-fails-on-qemu
> (lambda _
> ;; Skip test that fails on emulated hardware due to QEMU bug:

Otherwise LGTM.

--
Thanks,
Maxim
L
L
Ludovic Courtès wrote on 10 Jan 2023 18:06
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 60706@debbugs.gnu.org)
87zgaql3pb.fsf@gnu.org
Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:

Toggle quote (25 lines)
> Ludovic Courtès <ludo@gnu.org> writes:
>
>> From: Ludovic Courtès <ludovic.courtes@inria.fr>
>>
>> * gnu/packages/mpi.scm (hwloc-2): Update to 2.9.0.
>> [arguments]: Add 'skip-test-that-requires-/sys' phase.
>> ---
>> gnu/packages/mpi.scm | 10 +++++++---
>> 1 file changed, 7 insertions(+), 3 deletions(-)
>>
>> diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
>> index af2409aeab..56b7d04209 100644
>> --- a/gnu/packages/mpi.scm
>> +++ b/gnu/packages/mpi.scm
>> @@ -1,6 +1,6 @@
>> ;;; GNU Guix --- Functional package management for GNU
>> ;;; Copyright © 2014, 2015, 2018, 2019 Eric Bavier <bavier@member.fsf.org>
>> -;;; Copyright © 2014-2022 Ludovic Courtès <ludo@gnu.org>
>> +;;; Copyright © 2014-2023 Ludovic Courtès <ludo@gnu.org>
>> ;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
>> ;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
>> ;;; Copyright © 2017 Dave Love <fx@gnu.org>
>
> Nitpick: arguably not a copyrightable change (< 10 lines of additions).

Riiight.

Toggle quote (2 lines)
> Otherwise LGTM.

Thanks for taking a look!

Let’s see if https://qa.guix.gnu.org/issue/60706 can tell us more
about dependents and non-x86 architectures…

Ludo’.
L
L
Ludovic Courtès wrote on 27 Jan 2023 18:19
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 60706-done@debbugs.gnu.org)
87sffv520l.fsf_-_@gnu.org
Ludovic Courtès <ludovic.courtes@inria.fr> skribis:

Toggle quote (3 lines)
> Let’s see if https://qa.guix.gnu.org/issue/60706 can tell us more
> about dependents and non-x86 architectures…

Pushed as 317ea0458927810754ab154228ace04ff7bab717 with a fix for the
issues qa.guix found in dependent packages.

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60706@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60706
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch